Re: Important announcement: starting today, some add-ons will require you to upgrade to NVDA 2016.4


 

Hi,
They will install. The problem comes in if users attempt to use parts of
add-ons that are now powered by 2016.4 code base, including newer-style
dialogs (gui.guiHelper, for instance) and causing various errors (mostly
attribute error) to be recorded in the log and things to not function
correctly.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Rui
Fontes
Sent: Friday, December 16, 2016 2:52 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Important announcement: starting today, some add-ons
will require you to upgrade to NVDA 2016.4

I think they will not install...

Rui


-----Mensagem Original-----
De: Brian's Mail list account
Data: 16 de dezembro de 2016 10:31
Para: nvda@nvda.groups.io
Assunto: Re: [nvda] Important announcement: starting today, some add-ons
will require you to upgrade to NVDA 2016.4

Sounds reasonable but will you be testing that if people attempt to run
newer versions on older nvda, that it won't screw anything up and just won't
load or turn them off?
Otherwise I can see the folk who never read the words or update unless they
need to getting their nvdas in a bit of a pickle!
Maybe the last version which worked on 2016.3 should be retained on a page
of legacy add onse for those for whatever reason who cannot update. This
will probably be those who rely on their administrators to install nvda.


Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal email to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Joseph Lee" <joseph.lee22590@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Friday, December 16, 2016 3:43 AM
Subject: [nvda] Important announcement: starting today, some add-ons will
require you to upgrade to NVDA 2016.4


Hi everyone,

For those using 2016.3 or earlier: there will come a time when some
add-ons
will ask you to upgrade to NVDA 2016.4 in order for them to function. For
my
add-ons, I'll enforce 2016.4 requirement from February 2017 releases:



* StationPlaylist Studio: Version 17.04 (currently listed as
17.1-dev) will require 2016.4 or later. Major parts of this add-on now
uses
features introduced in 2016.4 (specifically, new user interface routines).

* Windows 10 App Essentials: Version 17.02 will not run properly
under NVDA 2016.3 or earlier. A critical component required to support
universal apps and write app modules for them has been included in NVDA
2016.4, thus this is no longer needed in the add-on.



Other add-ons that will require you to use NVDA 2016.4 include upcoming
versions of Place Markers, Rapid Settings, Clip Contents Designer and
others. Also, an add-on called Indentone (by Derek Riemer), used to let
you
hear indentation via tones, is hereby deprecated and should be removed, as
NVDA 2016.4 includes this feature.



For add-on writers: I'll write a formal directive to the add-ons list, but
the big picture is: if you are going to use graphical user interfaces such
as dialogs, you should use GUI Helper services provided by NVDA 2016.4 or
later. Also, you can now write app modules where executable names have a
dot
in the middle (for that, replace dots with underscores).



Thank you.

Cheers,

Joseph

Join nvda@nvda.groups.io to automatically receive all group messages.