Re: Emergency advisory for Windows XP and Resource Monitor users: please use version 16.08 or disable the add-on


 

Hi,
End of XP support will be spring 2018 from Resource Monitor add-on.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Bill Dengler
Sent: Sunday, July 16, 2017 2:52 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Emergency advisory for Windows XP and Resource Monitor users: please use version 16.08 or disable the add-on

Remove XP support. It was marked EOL way back in 2014. People have had more than enough time to transition.

Bill

On Jul 16, 2017, at 8:26 PM, Joseph Lee <joseph.lee22590@gmail.com> wrote:

Hi all,

Emergency advisory notice for Windows XP users using Resource Monitor: as part of Resource Monitor 17.02, I have updated psutil to 5.0.1. This is causing an error message to be shown for Windows XP users as newer psutil versions aren’t compatible with it. The last version of psutil and Resource monitor that’s compatible with Windows XP are 3.4.2 and 16.08, respectively.

Until further notice, I advise Windows XP users to either use version 16.08 or disable the add-on. If you do downgrade to 16.08, you’ll lose uptime announcement (NVDA+Shift+7) and bug fix for disk status command (fixes introduced in 17.02).

There are several ways of resolving this:

• Bundle an old version of psutil package with the add-on. This may introduce compatibility problems.
• Disable support for XP: catch the error and tell XP users that some add-on features aren’t compatible.
• Remove support for XP. However, this runs into issues for those who rely on XP.

Cheers,
Joseph

Join nvda@nvda.groups.io to automatically receive all group messages.