Re: Update issues on snapshots again


Dave Grossoehme
 

Good Afternoon:  It's possibile that your files are in a buffer that won't empty out the new info to entered?

Dave Insider

On 10/3/2017 4:28 AM, Brian's Mail list account via Groups.Io wrote:
Its getting even more complicated now as the same is happening on the portable installs. It seems to me that files in nvda are being held as un renamable even when a different copy of nvda is running, thus when the temp copy of the installer on next or master attempts to rename the old files before deleting them after replacement it simply cannot do so unless its straight after a system restart.

Is this something peculiar to windows 7, is there anything you can think of that might be doing this or what? As it seems to affect this and the other machine in different locations then it looks to me like something is keeping files as in use when they are not.
I'm at a loss to know wheere to proceed with this as onther software that updates behaves as it always used to and if it were a windows issue it would show up elsewhere one would have thought.


I have now restored working by doing resets and running  a third copy to run the instalations of both master and next to make the appropriate versions carefully making sure not to have had that version I'm installing or copying over in that windows session. this unfortunately really means manual download of the installed branch, Master so one can control the  session.
Is there any way to tell which files windows treats as in use?
I did notice a change about when this started by Mick of changing file names to stop the old copies from being used in the new version so that Firefox would not become unusable when nvda updates if it happened to be running at that time. It was around this time things started to misbehave.


Before that could it have been handled differently so that the problem was not noticed?
Brian

bglists@...
Sent via blueyonder.
Please address personal email to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
----- Original Message ----- From: "Quentin Christensen" <quentin@...>
To: <nvda@nvda.groups.io>
Sent: Tuesday, October 03, 2017 10:08 AM
Subject: Re: [nvda] Update issues on snapshots again


May be too late to get the original log back, but per
https://github.com/nvaccess/nvda/wiki/LogFilesAndCrashDumps if you look in
%temp%, you should find any recent logs which still exist and there may be
something in there.


On Tue, Oct 3, 2017 at 7:09 PM, Brian's Mail list account via Groups.Io <
bglists=blueyonder.co.uk@groups.io> wrote:

Further to this, the same problems have occurred today updating to the one
with the slight documentation changes, so the problem still exists.
I had to restart windows to get the  installer to run. It is, as I say not
allowing things to be deleted. Any ideas on what to try in nvda?
Its obibviously a recent issue.

I could completely reinstall but that would be impractical at the moment
due to work.

Besides if its affecting me then when the new version comes out there is
going to be a lot of problems.
Brian

bglists@...
Sent via blueyonder.
Please address personal email to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
----- Original Message ----- From: "Brian's Mail list account via
Groups.Io" <bglists=blueyonder.co.uk@groups.io>
To: <nvda@nvda.groups.io>
Sent: Tuesday, October 03, 2017 8:17 AM

Subject: Re: [nvda] Update issues on snapshots again


Yes this reboot is fine but its hard to replicate the exact conditions you
had the first time certainly not just by reinstalling old version and
updating again seems not to create the issue. it is obviously something
going on which still leaves some files locked. Could the log somehow tell
us which the files are which are causing it. That might suggest the issue
to be fixed. IE could there be circumstances in nvda with another program
running that means the system cannot unhook the files it needs to change?
That was muy feeling when I saw the log but without knowing the files its
a bit like a game of battleships!
Brian

bglists@...
Sent via blueyonder.
Please address personal email to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
----- Original Message ----- From: "Quentin Christensen" <
quentin@...>
To: <nvda@nvda.groups.io>
Sent: Monday, October 02, 2017 10:51 PM
Subject: Re: [nvda] Update issues on snapshots again


I just installed 14463 on Windows 7, 64-bit, then ran that copy and
upgraded to 14473 and it seems to be working fine for me.

How is yours after a reboot?

Quentin.

On Mon, Oct 2, 2017 at 7:45 PM, Brian's Mail list account via Groups.Io <
bglists=blueyonder.co.uk@groups.io> wrote:

Anyone running master having update issues today?

Windows 7 64 just did an update as flagged and it deleted the main files
then fell over with  file in use errors leaving it completely brokeen,
Luckily I do have a bckup portable but that won't install either. I
seem to
feel that something that told NVDA to stop using some old files seems to
have failed.
I will need to reboot the computer and then do a clean install I
suspect.
Info nobody running master as an installed copy is having this issue
then
one has to say its an anomaly here, but I cannot see why it would happen
when the last few updates have gone fine.
Brian

bglists@...
Sent via blueyonder.
Please address personal email to:-
briang1@..., putting 'Brian Gaff'
in the display name field.




--
Quentin Christensen
Training and Support Manager

Official NVDA Training modules and expert certification now available:
http://www.nvaccess.org/shop/

www.nvaccess.org
Facebook: http://www.facebook.com/NVAccess
Twitter: @NVAccess






--
Quentin Christensen
Training and Support Manager

Official NVDA Training modules and expert certification now available:
http://www.nvaccess.org/shop/

www.nvaccess.org
Facebook: http://www.facebook.com/NVAccess
Twitter: @NVAccess

Join nvda@nvda.groups.io to automatically receive all group messages.