Re: Bug in espeak ng used in NVDA Next


Simon Eigeldinger
 

Hi Brian,

old espeak can be ran on win xp yes.
the newer compilers also have a xp mode but espeak ng uses the windows 8.1 sdk.
don't know if it can be compiled though with an older sdk.

greetings,
simon


Am 23.02.2018 um 11:35 schrieb Brian's Mail list account via Groups.Io:

It is probably due to the compiler used to make the executable. Modern versions of Microsoft compilers no longer support xp or vista. They may still work on 32 bit systems running under 7, indeed the espeak build in nvda is  a 32 bit build as nvda is 32 bit.
 I'm guessing you might be using the  sapi version of Espeak which will probably be designed to run on modern processors. The question is best asked on their mail list.
Brian
bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal email to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
----- Original Message ----- From: "zahra" <nasrinkhaksar3@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Thursday, February 22, 2018 5:06 PM
Subject: Re: [nvda] Bug in espeak ng used in NVDA Next
hi.
i downloaded any version of 1.49.1 and 1.49.2 of espeak ng and says
that its not valid for win32!
but i am sure that download x86 version of espeak.
do you know the reason of this error?
On 2/22/18, Simon Eigeldinger <simon.eigeldinger@vol.at> wrote:
Hi Brian,

This is just a german only problem i have had.
already have reported to the espeak ng team and it has been fixed in
espeak ng master.
nvda next has espeak ng master from a few weeks where the bug is present.

Greetings,
Simon


Am 22.02.2018 um 10:47 schrieb Brian's Mail list account via Groups.Io:
I'm still using the old Espeak in the speech palyer in espeak as the
weird ways some words are said in ng is still a problem.
brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal email to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
----- Original Message ----- From: "Quentin Christensen"
<quentin@nvaccess.org>
To: <nvda@nvda.groups.io>
Sent: Thursday, February 22, 2018 3:32 AM
Subject: Re: [nvda] Bug in espeak ng used in NVDA Next


Hi Simon,

What version of eSpeak-NG are you using? Looking at:
https://github.com/espeak-ng/espeak-ng/releases indicates that the latest
version is 1.49.2, which we updated to prior to NVDA 2017.4.

Having said that, I know there are still issues with eSpeak, some of
which
are tracked on our issue tracker, and some on eSpeak-NG's here:
https://github.com/espeak-ng/espeak-ng/issues

Kind regards

Quentin.

On Thu, Feb 22, 2018 at 5:35 AM, Simon Eigeldinger
<simon.eigeldinger@vol.at
wrote:
Hi all,

The currently used espeak ng has a bug in the german language.
The bug has been fixed and espeak ng should be updated to latest master.
haven't opened a ticket yet because i thought i'll not make to much
noise about it.
though i can open a ticket as well if the devs prefer that.

Greetings and thanks,
Simon



---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
https://www.avast.com/antivirus






Join nvda@nvda.groups.io to automatically receive all group messages.