FW: [nvda-addons] Notice: later in 2018, Joseph Lee's add-ons will require NVDA release powered by wxPython 4


 

Hi,

 

The following is an important advisory for people using the listed add-ons below. I asked add-ons community to provide notices regarding their add-ons if they are impacted by wxPython 4 changes. Thanks.

 

From: nvda-addons@nvda-addons.groups.io <nvda-addons@nvda-addons.groups.io> On Behalf Of Joseph Lee
Sent: Friday, March 16, 2018 6:29 PM
To: nvda-addons@nvda-addons.groups.io
Subject: [nvda-addons] Notice: later in 2018, Joseph Lee's add-ons will require NVDA release powered by wxPython 4

 

Hi everyone,

 

Due to internal changes to wxPython 4, some of my add-ons will require a future NVDA release powered by wxPython 4. Specifically, wxPython 4 drops wx.PyDeadObjectError in favor of raising RuntimeError.

 

The following add-ons (either I created or am maintaining) are affected:

 

  • Enhanced Touch Gestures
  • Golden Cursor
  • StationPlaylist Studio
  • Windows 10 App Essentials

 

All of these add-ons display add-on configuration dialogs and thus are impacted by wxPython 4 changes. The NVDA release requirement will go into effect 30 days after release of the NVDA stable release powered by wxPython 4 (e.g. if NVDA 2018.2 is powered by wxPython 4 and is released on May 31, 2018, the above requirement will go into effect starting with the add-on releases scheduled for June 30, 2018 or later).

 

Special note for StationPlaylist Studio add-on: the above requirement is for those NOT on LTS channel.

 

Thank you.

Cheers,

Joseph

P.S. I encourage other add-on writers to post notices like this if your add-on(s) are impacted by wxPython 4 changes.

Join nvda@nvda.groups.io to automatically receive all group messages.