Re: I take it there have been no improvements to the flawed espeak ng in 2017.4?


Hareth <hareth4m@...>
 

You can try to copy the "synthDrivers" folder from your preferred NVDA
version installation directory,
and replace it with the current NVDA release.
I'd assume it would work for you.

On 3/25/18, Sharni-Lee Ward <sharni-lee.ward@hotmail.com> wrote:
Okay, I installed NVDA 2018.1, after creating a portable copy in case it
became too much to bear.


I don't like Eloquence because it isn't as crisp as Espeak. I have compared
it to A.M radio in the past, and Espeak to FM/CD Quality sound. Also, it has
only eight variants as opposed to Espeak's forty-something (I just realised
my lovingly customised alternate female variants have somehow been broken by
more recent changes which makes me sad, but I usually stick with Linda
anyway).


It's still doing the things that annoyed me in December, but I'm willing to
try and see if I get used to them.


I don't expect a program to be perfect. I don't expect a synth to be
perfect. I would like to hope that people don't break something that was
perfectly all right in a previous version, however.


And as for inflection, I have it set to 100% (GAH, it does the thing with
percent....), which makes Eloquence sound overly chipper, another reason I
don't enjoy that synth as much. By flat, I mean the voice does not use
perceptible inflection in the cases of question marks, commas and
exclamation points. This should not be something a blind user has to put up
with when it comes to synthesised voice. How is one supposed to know if the
statement is yelled or spoken calmly if the voice doesn't give it away? How
emotionally invested can they be in a story if there is no noticeable
inflection for something as basic as exclamations and question marks?



On 25/03/2018 4:54 PM, Gene wrote:
I need to correct one statement. You can't, as it appears, change
inflection in Eloquence with NVDA. I don't know what you consider flat.
But if you give Eloquence a chance, you may find that the amount of
inflection it uses is not bothersome to you. You may want an exaggerated
amount of inflection. I don't know how you have E-Speak set. But you may
find that, if you give Eloquence a chance and get used to it, you may find
it generally superior over time.

Gene
----- Original Message -----
From: Gene<mailto:gsasner@ripco.com>
Sent: Sunday, March 25, 2018 12:50 AM
To: nvda@nvda.groups.io<mailto:nvda@nvda.groups.io>
Subject: Re: [nvda] I take it there have been no improvements to the flawed
espeak ng in 2017.4?

Also, what's wrong with Eloquence? Have you tried it And as I recall, you
can adjust inflection with it. Don't use the Brittish English voice. It's
obviously programmed by Americans amateurishly trying to imitate a Brittish
accent. Use the default American English. It pronounces a great many more
words correctly compared with e-speak. And I use it very well with the NVDA
speech dictionary. Are you familiar with the SAPI 5 demo you can try of
Eloquence? Eloquence and Via Voice, the same synthesizer from a sound and
performance standpoint, are the most accurate in terms of proper
pronounciation of words in my experience.

Gene
----- Original Message -----
From: nvda@nvda.groups.io<mailto:nvda@nvda.groups.io>
<nvda@nvda.groups.io<mailto:nvda@nvda.groups.io>> On Behalf Of Sharni-Lee
Ward
Sent: Saturday, March 24, 2018 10:27 PM
To: nvda@nvda.groups.io<mailto:nvda@nvda.groups.io>
Subject: [nvda] I take it there have been no improvements to the flawed
espeak ng in 2017.4?

I've just caught up on all my emails. If I understood an earlier thread
correctly, despite our complaints when 2017.4 came out, the devs did not
roll back the version of espeak packaged with NVDA to the version in 2017.3,
which means that I will not be updating NVDA, despite the wonderful-sounding
new features.


Espeak, and subsequently Espeak NG, has been my default synth since I
started using NVDA. There was an issue in 2014 but I was able to get used to
that, and then it got fixed, so I was contented. The problems I found in the
espeak packaged with 2017.4 were more than I could stand, as someone who
primarily uses NVDA to read fanfiction and my own stories. However, Espeak
is among the only synths compatible with NVDA's inflection slider, which I
have maxed out for optimal performance. I'm not about to sacrifice broad
inflection for the drones of MS voices, and I'm currently using a Win 7
computer, but even if I was on a Win 10 one, the 1Core voices don't do it
for me either. They're pleasant, but also flat. No inflection. No way to
change the inflection. I can't stand human-sounding voices because they're
less flexible than synthetic ones in this regard. Also, nearly all non
Espeak voices are slow as well as flat, partially due to the length of
pauses between clauses of a sentence, and this is about as unbearable as the
flatness. And there is one more thing that really clinches my unwillingness
to change synths. I cannot get anything else to cooperate with my speech
dictionary. As I said, I read a lot of fanfiction, and I have put lots of
characters'
names and the names of Pokémon into my dictionary so that they are
pronounced properly. The other synths simply do not like these names, no
matter what I try to do with them, and some of them even pronounced my name
wrong, so I gave up on them.


This is why I want whoever's developing Espeak to roll back their changes to
a previous version (surely they have older versions backed up somewhere. I
would if I was developing something like this), and for NVDA to likewise
roll back the version packaged with it until the devs of the synth work out
how to alter one language without screwing up twenty others in the process.
I know I can only go so far before I am forced to update to the latest
version of NVDA or be left to languish as more and more things become
incompatible with the last tolerable version I have.


Please, I am begging you, do something about this.










Join nvda@nvda.groups.io to automatically receive all group messages.