Re: Add-on compatibility notice: NvDA Remote Support add-on 2.1 is not compatible with wxPython 4, new release recommended


Jonathan COHN
 

While I see this as essential in order to move to current versions of software / packages it is concerning that addons are breaking due to upgrading of the NVDA code base.  I worked in an office where we developed 25 scripts for AT technologies a year and still had a back log of portions of applications that were not fully compliant with Windows accessibility API’s. If in addition to keeping up with Windows and application changes that occur regularily, addon developers have to do regular work on their stock of addons I could see this as a deterrent to wide spread adoption of NVDA. Is this a general problem in the Python community or just an issue from the transition to Python 3.

 

Thanks,

 

Jonathan Cohn

  

Join nvda@nvda.groups.io to automatically receive all group messages.