Re: Add-on compatibility notice: NvDA Remote Support add-on 2.1 is not compatible with wxPython 4, new release recommended


 

Hi,
It does not affect 2018.2.
As for dependencies and Python 3: we're not yet talking about Python 3 transition as something that's in progress; rather, we're talking about wxPython 4, a necessary milestone before we can even think about Python 3 work. Moving to Python 3 has huger implications than switching to wxPython 4, as some add-ons will break, especially those that are orphaned at this time (no maintainer, lost contact with authors, etc.).
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Brian's Mail list account via Groups.Io
Sent: Thursday, June 7, 2018 11:57 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Add-on compatibility notice: NvDA Remote Support add-on 2.1 is not compatible with wxPython 4, new release recommended

Just to clarify, i do not think its an issue in the new current rc3 of
2018.2 is it? its when the new code for getting ready for Python 3 hits nvda that we all may need to go on an add on updating spree. It also seems to me that for some reasons we are going to need old and new versions of add ons, as updates may screw it for the older installs. Those people may well be in companies and unable to update until their sys admins do so.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Tyler Wood" <tcwood12@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Friday, June 08, 2018 4:06 AM
Subject: Re: [nvda] Add-on compatibility notice: NvDA Remote Support add-on
2.1 is not compatible with wxPython 4, new release recommended


Hi,

Hopefully this will get fixed soon. I will, too, be staying back as
this is used pretty regularly when I use NVDA.



On 07-Jun-2018 10:17 PM, Richard Wells wrote:

I use it regularly with users. If this is not fixed before new
release, I will need to stay back until they get it working. It is
too important to my work.


On 6/7/2018 4:17 PM, Ervin, Glenn wrote:

I’ve never gotten it to work, I’ve tried several times since it came
out.

Glenn

*From:*nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] *On Behalf
Of *Sarah k Alawami
*Sent:* Thursday, June 07, 2018 12:58 PM
*To:* nvda list list
*Subject:* Re: [nvda] Add-on compatibility notice: NvDA Remote
Support add-on 2.1 is not compatible with wxPython 4, new release
recommended

I Actually did not take part in the crowd funding as I didn't
believe this add on would ever happen, and I knew one of the devs so
perosnally did not crowd fund it, I just will not go thee, not here.

Anyway yeah any way to get hold of the devs of the remote add on and
ask them to please fix? At least for some of us who use it. I only
used it once and that was this year.

Here's hoping for a fix eh?



On Jun 7, 2018, at 10:23 AM, Mallard <mallard@kimabe.eu
<mailto:mallard@kimabe.eu>> wrote:

Considering that, unlike other add-ons, we all crowdfunded the
development of this very add-on, I'd hope something is done about it
very soon,





Il 07/06/2018 18:14, Joseph Lee ha scritto:


Hi all,

The below notice is considered critical:

It’s happening again: with the introduction of wxPython 4 in next
snapshots, users of NVDA Remote add-on are having startup issues
related to missing attribute in wxPython 4.

I propose the following solutions:

* I highly recommend releasing Remote add-on 2.2 to fix this issue.
* Perhaps adding a statement on nvdaremote.com
<http://nvdaremote.com> website explaining that Remote add-on should
be disabled if using recent NVDA next snapshots.
* The community should release an updated version of this add-on
with permission from add-on authors and maintainers.

Thanks.

Cheers,

Joseph






Join nvda@nvda.groups.io to automatically receive all group messages.