FW: [Nvda-devel] FW: Browse Mode with NVDA 2016.2 not working

 

Hi,
Let us know what your thoughts are so one of us can forward this to the
developers (or if you are a member of the nvda-devel list, I'd like to
request help in shuttling emails back and forth). Thanks.
Cheers,
Joseph

-----Original Message-----
From: James Teh [mailto:jamie@...]
Sent: Thursday, June 2, 2016 4:50 PM
To: NVDA screen reader development <nvda-devel@...>
Subject: Re: [Nvda-devel] FW: [nvda] Browse Mode with NVDA 2016.2 not
working

This suggests NVDA is unable to inject itself into the browser. There are a
few possibilities here:
1. NVDA's dll files didn't get updated properly for some reason. This would
also affect a portable copy if that portable copy was generated from the
installed copy. However, if the portable copy was created from a download
directly, that probably isn't the issue.
2. Something is blocking NVDA's dll files on that system; e.g. a virus
scanner.
3. If NVDA is started while a browser is focused, it sometimes cannot
inject. Does the issue persist if the user opens the browser *after* opening
NVDA?

Jamie

On 3/06/2016 8:02 AM, Joseph Lee wrote:
Hi,
I don't follow as to what's going on in the below log. Thanks.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of
Ethan
Sent: Thursday, June 2, 2016 2:58 PM
To: nvda@nvda.groups.io
Subject: [nvda] Browse Mode with NVDA 2016.2 not working

Hello all:

I was not sure where to post this so I apologize if this is off topic.

When I am using NVDA on the web in Firefox or Internet Explorer, it does
not read the page content. I am able to press tab to move through the
elements on the page, but when I press up or down arrow, nothing happens. It
is acting as if it is in browse mode and I am unable to exit out of browse
mode. No audible tones are heard to indicate entering or exit of browse
mode.
Ever since NVDA 2015.4 or NVDA 2016.1, I have been unable to use the
latest version of NVDA on my work computer. Instead, I am using NVDA 2015.3.
This problem appears to happen both on a portable copy and an installed copy
which makes me think it has to do something with dependent software that
needs to be updated on the individual computer. Here is my log viewer on
debug mode at the error point:
WindowsError: [Error 1702] The binding handle is invalid

// Start of log:
INFO - __main__ (16:15:53):
Starting NVDA
INFO - core.main (16:15:53):
Config dir: E:\NVDA 2016.2\userConfig
DEBUG - core.main (16:15:53):
setting language to Windows
INFO - core.main (16:15:53):
NVDA version 2016.2
INFO - core.main (16:15:53):
Using Windows version 6.1.7601 service pack 1 workstation INFO - core.main
(16:15:53):
Using Python version 2.7.11 (v2.7.11:6d1b6a68f775, Dec 5 2015,
20:32:19) [MSC v.1500 32 bit (Intel)]
INFO - core.main (16:15:53):
Using comtypes version 0.6.2
DEBUG - core.main (16:15:53):
Initializing addons system.
DEBUG - addonHandler._getAvailableAddonsFromPath (16:15:53):
Listing add-ons from E:\NVDA 2016.2\userConfig\addons DEBUG - core.main
(16:15:54):
Initializing appModule Handler
DEBUG - core.main (16:15:54):
Initializing NVDAHelper
DEBUG - core.main (16:15:54):
Speech Dictionary processing
DEBUG - speechDictHandler.SpeechDict.load (16:15:54):
Loading speech dictionary '.\userConfig\speechDicts\default.dic'...
DEBUG - speechDictHandler.SpeechDict.load (16:15:54):
file '.\userConfig\speechDicts\default.dic' not found.
DEBUG - speechDictHandler.SpeechDict.load (16:15:54):
Loading speech dictionary 'builtin.dic'...
DEBUG - speechDictHandler.SpeechDict.load (16:15:54):
3 loaded records.
DEBUG - core.main (16:15:54):
Initializing speech
INFO - synthDrivers.espeak.SynthDriver.__init__ (16:15:54):
Using eSpeak version 1.48.15 16.Apr.15 DEBUG -
speechDictHandler.SpeechDict.load (16:15:54):
Loading speech dictionary '.\userConfig\speechDicts\espeak-english.dic'...
DEBUG - speechDictHandler.SpeechDict.load (16:15:54):
file '.\userConfig\speechDicts\espeak-english.dic' not found.
INFO - synthDriverHandler.setSynth (16:15:54):
Loaded synthDriver espeak
INFO - core.main (16:15:54):
Using wx version 3.0.2.0 msw (classic) DEBUG - core.main (16:15:54):
Initializing braille
INFO - braille.initialize (16:15:54):
Using liblouis version 2.6.5
INFO - braille.BrailleHandler.setDisplayByName (16:15:54):
Loaded braille display driver noBraille, current display has 0 cells.
DEBUG - core.main (16:15:54):
Initializing braille input
INFO - brailleInput.initialize (16:15:54):
Braille input initialized
DEBUG - core.main (16:15:54):
Initializing displayModel
DEBUG - core.main (16:15:54):
Initializing GUI
DEBUG - core.main (16:15:54):
initializing Java Access Bridge support DEBUG - core.main (16:15:54):
Initializing winConsole support
DEBUG - core.main (16:15:54):
Initializing UIA support
DEBUG - core.main (16:15:54):
Initializing IAccessible support
DEBUG - core.main (16:15:54):
Initializing input core
DEBUGWARNING - inputCore.InputManager.loadLocaleGestureMap (16:15:54):
No locale gesture map for language en
DEBUGWARNING - inputCore.InputManager.loadUserGestureMap (16:15:54):
No user gesture map
DEBUG - core.main (16:15:54):
Initializing keyboard handler
DEBUG - core.main (16:15:54):
initializing mouse handler
DEBUG - core.main (16:15:54):
Initializing touchHandler
DEBUGWARNING - touchHandler.initialize (16:15:54):
Touch only supported on installed copies DEBUG - core.main (16:15:54):
Initializing global plugin handler
DEBUG - core.main (16:15:54):
Initializing core pump
DEBUG - core.main (16:15:54):
Initializing watchdog
DEBUG - core.main (16:15:54):
initializing updateCheck
INFO - core.main (16:15:54):
NVDA initialized
DEBUG - core.main (16:15:54):
entering wx application main loop
IO - speech.speak (16:15:55):
Speaking [LangChangeCommand ('en_GB'), u'Google - Mozilla Firefox icon 2
of 3'] IO - speech.speak (16:15:55):
Speaking [LangChangeCommand ('en_GB'), u'Google - Mozilla Firefox'] DEBUG
- treeInterceptorHandler.update (16:15:55):
Adding new treeInterceptor to runningTable:
<virtualBuffers.gecko_ia2.Gecko_ia2 object at 0x059ACDF0> ERROR -
virtualBuffers.Gecko_ia2._loadBuffer (16:15:55):
Traceback (most recent call last):
File "virtualBuffers\__init__.pyo", line 369, in _loadBuffer
WindowsError: [Error 1702] The binding handle is invalid

Thank you for any information you can provide,

Ethan




----------------------------------------------------------------------
-------- What NetFlow Analyzer can do for you? Monitors network
bandwidth and traffic patterns at an interface-level. Reveals which
users, apps, and protocols are consuming the most bandwidth. Provides
multi-vendor support for NetFlow, J-Flow, sFlow and other flows. Make
informed decisions using capacity planning reports.
https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
_______________________________________________
Nvda-devel mailing list
Nvda-devel@...
https://lists.sourceforge.net/lists/listinfo/nvda-devel
--
James Teh
Executive Director, NV Access Limited
Ph +61 7 3149 3306
www.nvaccess.org
Facebook: http://www.facebook.com/NVAccess
Twitter: @NVAccess
SIP: jamie@...


----------------------------------------------------------------------------
--
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are

consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
_______________________________________________
Nvda-devel mailing list
Nvda-devel@...
https://lists.sourceforge.net/lists/listinfo/nvda-devel

Join nvda@nvda.groups.io to automatically receive all group messages.