Re: Intermittent failure of focus in Explorer


Brian's Mail list account
 

Well all I can say is that in 10 portable nvda is awful on explorer, whereas on 7 its no different.

I do not think uia is involved as if you look at the log no errors or mention of uia is there at all.
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Felix G." <constantlyvariable@...>
To: <nvda@nvda.groups.io>
Sent: Friday, December 14, 2018 2:18 PM
Subject: Re: [nvda] Intermittent failure of focus in Explorer


Hello Brian,
actually Windows 7 does use UIA quite a lot, so it may well be involved.
Best,
Felix

Am Fr., 14. Dez. 2018 um 15:02 Uhr schrieb Brian's Mail list account
via Groups.Io <bglists@...>:

Windows 7 does not use UIA though which was why I specifically mentioned it
here.
I think its simply missing something, as its not every time, only
sometimes.
Its only started to happen recently say in the last couple of releases of
nvda. I guess it might be that the system has to decide if its uia or not
which might stop it getting the info from windows if its significantly
slower than it used to be. My machine is still the same though, so unless
something I installed is doing tit , I'm at a loss.
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Felix G." <constantlyvariable@...>
To: <nvda@nvda.groups.io>
Sent: Friday, December 14, 2018 1:02 PM
Subject: Re: [nvda] Intermittent failure of focus in Explorer


Hi!
It's a long-standing issue. I reported it at:
https://github.com/nvaccess/nvda/issues/8389
It's probably UIA-related. On Windows 10 build 1809 I haven't seen it
thus far, so it may have been solved there.
Best,
Felix

Am Fr., 14. Dez. 2018 um 11:55 Uhr schrieb Brian's Mail list account
via Groups.Io <bglists@...>:

This is Windows 7, and only seems to have started to happen recently.
I have had a short cut to the root of drive C: on my desktop, but it can
happen at any time in opening drives or folders, where the actual focused
drive is not spoken by nvda. Here is the log file. Its not very long. I
select the shortcut with L then hit enter wait and nothing is spoken then
I
did an nvda/f1 to see what was going on. there is an exception and
nothing
gets focus.


IO - speech.speak (10:41:26.296):

Speaking [LangChangeCommand ('en_GB'), u'Local Disk (C) 44 of 72']

DEBUG - queueHandler.pumpAll (10:41:26.299):

generator 4809 finished

IO - inputCore.InputManager.executeGesture (10:41:27.397):

Input: kb(desktop):enter

IO - inputCore.InputManager.executeGesture (10:41:42.644):

Input: kb(desktop):NVDA+f1

INFO - globalCommands.GlobalCommands.script_navigatorObject_devInfo
(10:41:42.894):

Developer info for navigator object:

name: u'Local Disk (C)'

role: ROLE_LISTITEM

states: STATE_FOCUSABLE, STATE_SELECTABLE, STATE_SELECTED

isFocusable: True

hasFocus: False

Python object: <NVDAObjects.IAccessible.sysListView32.ListItem object at
0x055BCC30>

Python class mro: (<class
'NVDAObjects.IAccessible.sysListView32.ListItem'>,
<class 'NVDAObjects.behaviors.RowWithFakeNavigation'>, <class
'NVDAObjects.behaviors.RowWithoutCellObjects'>, <class
'NVDAObjects.IAccessible.sysListView32.ListItemWithoutColumnSupport'>,
<class 'NVDAObjects.IAccessible.IAccessible'>, <class
'NVDAObjects.window.Window'>, <class 'NVDAObjects.NVDAObject'>, <class
'documentBase.TextContainerObject'>, <class
'baseObject.ScriptableObject'>,
<class 'baseObject.AutoPropertyObject'>, <type 'object'>)

description: None

location: RectLTWH(left=228, top=425, width=76, height=68)

value: None

appModule: <'explorer' (appName u'explorer', process ID 1660) at address
5137ab0>

appModule.productName: u'Microsoft\xae Windows\xae Operating System'

appModule.productVersion: u'6.1.7600.16385'

TextInfo: <class 'NVDAObjects.NVDAObjectTextInfo'>

windowHandle: 65782

windowClassName: u'SysListView32'

windowControlID: 1

windowStyle: 1442855488

windowThreadID: 1664

windowText: u'FolderView'

displayText: u'Local Disk (C)'

IAccessibleObject: <POINTER(IAccessible) ptr=0x837ca08 at 4f77a80>

IAccessibleChildID: 44

IAccessible event parameters: windowHandle=65782, objectID=-4, childID=44

IAccessible accName: u'Local Disk (C)'

IAccessible accRole: ROLE_SYSTEM_LISTITEM

IAccessible accState: STATE_SYSTEM_SELECTABLE, STATE_SYSTEM_SELECTED,
STATE_SYSTEM_MULTISELECTABLE, STATE_SYSTEM_FOCUSABLE, STATE_SYSTEM_VALID
(19922946)

IAccessible accDescription: exception: (-2147352573, 'Member not found.',
(None, None, None, 0, None))

IAccessible accValue: None





So has any other windows 7 user got this issue? Also if anyone can shed
any
light on it, be my guest. It has been fine.
Brian
bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.






Join nvda@nvda.groups.io to automatically receive all group messages.