Re: Some add-ons fail to install/work under NVDA 2018.4


Clare Page <clare.page@...>
 

Hi!
It's true that NVDA can read a lot of emoji now without the Emoticons add-on running, but it doesn't always read the old-fashioned emoticons, made with punctuation marks and sometimes letters, with that add-on disabled: I just tested that on my Windows 7 computer. What's more, even though Windows 10 users can add emoji by accessing the appropriate panel there, the emoji panel doesn't exist in older versions of Windows, and users of Windows 7 or 8 might also want to use those old emoticons I've already mentioned. Given that Windows 10 isn't used by all NVDA users, and people may still want to read and add old-fashioned emoticons as well as more modern emoji, there are still good reasons for the Emoticons add-on for NVDA to continue to exist, in my opinion. So please don't scrap it yet!
Bye for now!
From Clare

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Brian's Mail list account via Groups.Io
Sent: mercredi 19 décembre 2018 15:46
To: nvda@nvda.groups.io
Subject: Re: [nvda] Some add-ons fail to install/work under NVDA 2018.4

Several other things spring to mind. There has been a lot of talk that the
emoticons are in the core now, so do you need the add on at all? also I'm
totally confused about the state of the win 10 essentials as it seems there
are now strict limits to which versions of windows 10 work with which
versions of the add on.
Might it be that windows 10s version is incompatible with the add ons being
used in some way?
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Clare Page" <clare.page@wanadoo.fr>
To: <nvda@nvda.groups.io>
Sent: Wednesday, December 19, 2018 1:43 PM
Subject: Re: [nvda] Some add-ons fail to install/work under NVDA 2018.4


Hi!

I also had the problem that the new version of the Emoticons add-on failed
to install: in my case there was an error with the installation of that
add-on’s update when I used the add-on updater to do it. But the Emoticons
add-on installed normally when I downloaded it from the website and did the
installation by opening the add-on from where it got downloaded to.

By the way, I couldn’t download NVDA 2018.4 using Check For Updates the
other day either, once again I actually had to download the ;exe file to
update NVDA, so I wonder if there is some gproblem with NVDA updates
generally, either the program itself or add-ons.

Thanks in advance for any explanation if there is one.

Bye for now!

From Clare



From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Kostadin
Kolev
Sent: mercredi 19 décembre 2018 13:30
To: nvda@nvda.groups.io
Subject: [nvda] Some add-ons fail to install/work under NVDA 2018.4



Hello all,

A friend of mine has reported to me a problem with his copy of NVDA 2018.4.
Some add-ons fail to install/work under this version of NVDA. It is an
installed copy of NVDA. He sent me the log file. I can see some errors about
the "Emoticons" (v9.0 if I'm not mistaking) and "Windows 10 App Essentials"
add-ons, but I don't understand what the errors mean. I'm pasting his log
file here, in case someone can help us to solve this issue.

Thanks much in advance!

Here's the log:

INFO - _main_ (13:20:43.529):
Starting NVDA
INFO - core.main (13:20:43.802):
Config dir: C:\Users\kalin\AppData\Roaming\nvda
INFO - config.ConfigManager._loadConfig (13:20:43.802):
Loading config: C:\Users\kalin\AppData\Roaming\nvda\nvda.ini
INFO - core.main (13:20:43.921):
NVDA version 2018.4
INFO - core.main (13:20:43.921):
Using Windows version 10.0.17134 workstation
INFO - core.main (13:20:43.921):
Using Python version 2.7.15 (v2.7.15:ca079a3ea3, Apr 30 2018, 16:22:17) [MSC
v.1500 32 bit (Intel)]
INFO - core.main (13:20:43.921):
Using comtypes version 1.1.3
INFO - core.main (13:20:43.921):
Using configobj version 5.1.0 with validate version 1.0.1
ERROR - addonHandler.completePendingAddonInstalls (13:20:43.933):
Failed to complete addon installation for emoticons
Traceback (most recent call last):
File "addonHandler.pyo", line 89, in completePendingAddonInstalls
WindowsError: [Error 183] Cannot create a file when that file already exists
ERROR - addonHandler._getAvailableAddonsFromPath (13:20:43.940):
Error loading Addon from path:
C:\Users\kalin\AppData\Roaming\nvda\addons\emoticons
Traceback (most recent call last):
File "addonHandler.pyo", line 163, in _getAvailableAddonsFromPath
File "addonHandler.pyo", line 226, in _init_
File "addonHandler.pyo", line 561, in _init_
File "configobj\__init__.pyo", line 1199, in _init_
File "configobj\__init__.pyo", line 1292, in _load
ParseError: Invalid line
(u'\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00')
(matched as neither section nor keyword) at line 1.
ERROR - addonHandler._getAvailableAddonsFromPath (13:20:43.944):
Error loading Addon from path:
C:\Users\kalin\AppData\Roaming\nvda\addons\wintenApps
Traceback (most recent call last):
File "addonHandler.pyo", line 163, in _getAvailableAddonsFromPath
File "addonHandler.pyo", line 226, in _init_
File "addonHandler.pyo", line 561, in _init_
File "configobj\__init__.pyo", line 1199, in _init_
File "configobj\__init__.pyo", line 1292, in _load
ParseError: Invalid line
(u'\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00')
(matched as neither section nor keyword) at line 1.
WARNING - stdout (13:20:44.332):
hooked waveOutOpen
WARNING - stdout (13:20:44.332):
hooked waveOutClose
INFO - synthDriverHandler.setSynth (13:20:44.572):
Loaded synthDriver sapi5
INFO - core.main (13:20:44.855):
Using wx version 4.0.3 msw (phoenix) wxWidgets 3.0.5
INFO - brailleInput.initialize (13:20:44.855):
Braille input initialized
INFO - braille.initialize (13:20:44.861):
Using liblouis version 3.7.0
INFO - braille.BrailleHandler.setDisplayByName (13:20:44.865):
Loaded braille display driver noBraille, current display has 0 cells.
WARNING - core.main (13:20:44.930):
Java Access Bridge not available
INFO - _UIAHandler.UIAHandler.MTAThreadFunc (13:20:44.944):
UIAutomation: IUIAutomation5
INFO - core.main (13:20:46.591):
NVDA initialized
ERROR - eventHandler.executeEvent (13:22:24.211):
error executing event: mouseMove on <NVDAObjects.IAccessible.mozilla.Mozilla
object at 0x05F4B390> with extra args of {'y': 384, 'x': 683}
Traceback (most recent call last):
File "eventHandler.pyo", line 155, in executeEvent
File "eventHandler.pyo", line 92, in _init_
File "eventHandler.pyo", line 100, in next
File "NVDAObjects\__init__.pyo", line 930, in event_mouseMove
File "NVDAObjects\IAccessible\__init__.pyo", line 152, in expand
AttributeError: 'NoneType' object has no attribute 'rindex'

______
Best wishes,
Kostadin Kolev

Join nvda@nvda.groups.io to automatically receive all group messages.