Re: Issue with focus mode in 2016.2


Jenine Stanley
 

I can certainly check this. Not sure what good it will do but if it could help, I’ll take a look at my error log tomorrow.

2016.1 was fine, no such issues.
Jenine Stanley
dragonwalker64@gmail.com

On Jun 9, 2016, at 5:58 PM, Ethan <ethan8768@gmail.com> wrote:

Jenine:

I have reported this issue before with a NVDA log attached with no
solution to the NVDA list. This focus mode problem happens for me as
well with NVDA 2016.2 at work. The only solution I have is to install
NVDA 2015.3 onto your computer. Ever since 2015.4 for me it seems to
not work. NVDA 2016.2 works fine on my computer at home.

Check your NVDA error log and see if any of these lines are present
when you load a webpage: (I have NVDA set on debug logging level)
<virtualBuffers.gecko_ia2.Gecko_ia2 object at 0x059FAFD0>
ERROR - virtualBuffers.Gecko_ia2._loadBuffer
Traceback (most recent call last):
File "virtualBuffers\__init__.pyo", line 369, in _loadBuffer
WindowsError: [Error 1702] The binding handle is invalid

Thank you,

Ethan

On 6/9/16, Jenine Stanley <dragonwalker64@gmail.com> wrote:
Thanks Jacob,

I just tried this, toggling control-F6 and though it did exactly what it was
supposed to do in terms of moving me between the search bar and the web page
contents, it did nothing to effect focus mode with NVDA.

I’ll try anything though so never fear.
Jenine Stanley
dragonwalker64@gmail.com



On Jun 9, 2016, at 3:33 PM, Jacob Kruger <jacob@blindza.co.za> wrote:

Try one other one thing, just in case - in both IE, and firefox, ctrl + F6
might toggle focus between address bar, and webpage contents.

As in, try hitting alt + D to focus on address bar again, and then ctrl +
F6 to, possibly, jump to/focus on the webpage itself.

But, this might not solve the problem at all, but, is just a keystroke
combination I have used for a while with multiple screen readers to, at
times, make sure it is focused on webpage contents.

STay well

Jacob Kruger
Blind Biker
Skype: BlindZA
"Resistance is futile, acceptance is versatile"

----- Original Message ----- From: "Jenine Stanley"
<dragonwalker64@gmail.com>
To: <nvda@nvda.groups.io>
Sent: 09 June, 2016 8:55 PM
Subject: Re: [nvda] Issue with focus mode in 2016.2


Thanks Joseph,

I’m glad I’m not alone. I ahve seen some improvement when tabbing around
some web sites but unfortunately, not many. If the site has a lot of
places that would trigger focus mode, it doesn’t tend to work.

I’m all ears for any ways to deal with this as I’m effectively shut out of
browsing, reading or tasks for my job, on the Windows machine anyway.
Jenine Stanley
dragonwalker64@gmail.com



On Jun 9, 2016, at 2:44 PM, Joseph Lee <joseph.lee22590@gmail.com>
wrote:

Hi,
We have reports of this happening to users (you are not alone). Sounds
like somehow browse mode routine (specifically, the behind the scenes
routine of browse mode) is failing somehow. When this happens, try
tabbing around (I found that it works for some websites where it'll take
a long time for NVDA to render browse mode).
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of
Jenine Stanley
Sent: Thursday, June 9, 2016 10:24 AM
To: nvda@nvda.groups.io
Subject: [nvda] Issue with focus mode in 2016.2

Apologies in advance for the length of this post. I downloaded the latest
version of NVDA the day it came out and began to notice right away that I
was having a problem with focus mode when opening web pages.

My sistem is as follows:

Windows 7 latest updates
Web browsers: Internet Explorer 11 and Firefox

All of my other programs have no issues with NVDA.

Here’s what happens when I open a web page.

Nothing is announced until I alt-tab away from the page. then the title
of the page is announced but the word “document” is after the title of
the web page.

Focus mode appears to be on.

Here’s what I’ve done.

1. toggled Focus Mode with NVDA-space. with no effect and no speech or
sound with each toggle 2. Hit escape several times with no speech, audio
or change.
3. Made sure the numlock key was off, toggled it on and off again. This
function spoke but had no effect on Focus Mode.
4. Left the web page and tried focus mode in another app, Outlook 2007,
worked as normal.
5. Tried both browsers, same result, Focus Mode locked.
6. Updated Windows7, IE and Firefox. Restarted computer, no change.
7. downloaded and stalled a new version of NVDA over the old one.
Restarted computer, no change.
8. Removed NVDA and reinstalled the version I’d downloaded, all mentioned
versions are current btw. No change.
9. I even tried Window-Eyes to see if it was my computer. No, Window-Eyes
worked fine on both browsers.

I then looked at the settings for browsers but didn’t understand several
of them. I tried toggling them on/off and testing web pages but no
change.

Any idea what’s going on here?

Thanks for any advice you can give.
Jenine Stanley
dragonwalker64@gmail.com


















Join nvda@nvda.groups.io to automatically receive all group messages.