Re: Calling All Object Navigation Experts!


Jackie
 

Be sure to always maximize the window, Brian V, but, having thus said,
sometimes--indeed most of the time--that isn't always very helpful.
It's a real pita when programs are like that.

On 1/10/19, Brian's Mail list account via Groups.Io
<bglists=blueyonder.co.uk@groups.io> wrote:
I agree. Until developers grasp the nettle and begin to design access in you

will get silly situations like this one. I've found many places when you get

buttons navigating and the action to press them only works with a mouse. Its

ridiculous.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Brian Vogel" <britechguy@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Thursday, January 10, 2019 5:00 PM
Subject: Re: [nvda] Calling All Object Navigation Experts!


Jackie,

I have tried the object navigation command - no dice; NVDA says "No Action."

The control itself is visually presented as a link. If I use the Report
Current Object command (NVDA+NumPad5), it says, "Clone this disc, text, read

only."

I just tried the route mouse to navigator object command, followed by the
NVDA left click command and also using the actual left click on my mouse
pad, an this works!

I find it utterly bizarre how NVDA navigates through the pane in question. I

get focus on what is the first control at the top, and use the navigate to
next object and there is "no next." But if I use navigate to previous object

it starts going through controls lower down on the page, which is entirely
counterintuitive. Of course, I'm quite sure this is dependent on the code
that NVDA is dealing with in Macrium, as opposed to NVDA itself.

What's even weirder, and this wasn't happening earlier, is that I cannot
consistently "object navigate" the Macrium Reflect window. If I fire up the

program after searching for it, then ALT+TAB to the window, NVDA tells me
nothing at all once I have focus on it. If I hit ALT to make focus go to the

menus I do get reports on that, but afterward I still can't seem to object
navigate to the panes, and I could swear I had done it that way earlier this

morning.

Object Navigation will keep becoming a much bigger deal with time. I think
that the battle to get developers to understand accessibility under this
paradigm is going to be a challenge.

Thank you very much for your assistance. I'll report back as additional time

for experimentation allows.




--

Brian *-* Windows 10 Home, 64-Bit, Version 1809, Build 17763

*A great deal of intelligence can be invested in ignorance when the need for

illusion is deep.*

~ Saul Bellow, To Jerusalem and Back








--
Subscribe to a WordPress for Newbies Mailing List by sending a message to:
wp4newbs-request@freelists.org with 'subscribe' in the Subject field OR by
visiting the list page at http://www.freelists.org/list/wp4newbs
& check out my sites at www.brighter-vision.com & www.mysitesbeenhacked.com

Join nvda@nvda.groups.io to automatically receive all group messages.