Re: Addon updater


 

Hi,

No because 19.02.2 restores Python 3 compatibility, and current version isn’t python 3 compatible (at least one particular area of code; previously it was Python 3 compatible but in an attempt to fix compatibility with older NVDA releases, a method that was optimized for Python 2 was selected on a temporary basis).

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of marcio via Groups.Io
Sent: Friday, February 1, 2019 12:30 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Addon updater

 

Hi,
I'm on the Alpha channel.
So let's say, if I still choose to wait beyond the 2019.0.2.2, from this point I'll be able to update it automatically?


Cheers,
Marcio
Follow me on Twitter

Em 01/02/2019 18:29, Joseph Lee escreveu:

Hi,

Depends on which NVDA version you’ve got:

  • 2018.4.1: manual update is mandatory.
  • Alpha/beta: automatic update will work.

 

However, for this one and upcoming 19.02.2, you SHOULD update manually.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of marcio via Groups.Io
Sent: Friday, February 1, 2019 12:22 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Addon updater

 

Hi Joseph,
If I choose to wait for the next version of add-on updater, will I still need to update it manually or can I simply update from the version I have right now to the newer one?


Cheers,
Marcio
Follow me on Twitter

Em 01/02/2019 14:41, Joseph Lee escreveu:

Hi,
This is the reason why I told everyone yesterday that users should install Add-on Updater 19.02.1A manually.
Speaking of Add-on Updater: it looks like I need to push another mandatory update to this add-on next week. The current solution I wrote as part of 19.02.1A is a temporary one that isn't compatible with Python 3 version of NVDA. The upcoming 19.02.2 will make sure Add-on Updater is both backward and forward compatible.
Cheers,
Joseph
 
-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Don H
Sent: Friday, February 1, 2019 8:36 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Addon updater
 
It tells me that Addon updater version is not compatible with my version of NVDA.  Says I need NVDA 2.0.
I am running NVDA 2018.4.1.
 
On 2/1/2019 9:09 AM, Joseph Lee wrote:
Hi,
Fixed in Add-on Updater 19.02.1A.
Cheers,
Joseph
 
-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan 
Milam
Sent: Friday, February 1, 2019 7:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Addon updater
 
Same here.
 
Jonathan
 
-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Don H
Sent: Friday, February 1, 2019 9:15 AM
To: nvda@nvda.groups.io
Subject: [nvda] Addon updater
 
Running latest released version of NVDA not alpha.  Get a update notice to update the addon update addon.  If I say ok to update I get a message that the addon is not compatible with my version of NVDA.  Get this addon update notice every time I start NVDA.
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

Join nvda@nvda.groups.io to automatically receive all group messages.