Re: Emailing: NVDA Excel losing focus.log


Quentin Christensen
 

Hi Cearbhall,

As I think Gene noted in the other thread, you can't send attachments via the list.  Re only seeing the errors, you likely have your log level set to "info".  There are several settings through the "Debug" which records the keystrokes and everything and can help narrow down exactly what was happening when a problem occurs.

(if sending an uncut log at debug level, feel free to send it directly to me rather than to the list).

I can reproduce the losing focus - that's been an ongoing issue with a number of triggers - but mine isn't throwing errors like your is.  You could try the usual: Restart with add-ons disabled etc and see if anything makes a difference.

Regards

Quentin.

On Sun, Feb 24, 2019 at 10:25 AM Cearbhall O'Meadhra <cearbhall.omeadhra@...> wrote:
Quentin,

I wonder if you can help me with this problem?

I am running Windows 10, Office 365, and the latest NVDA. I am working on an
Excel worksheet where I have three panels of data that must correlate in
various ways.     One of the tasks is to compare the contents of cells in
columns "K", "Z" and "AK for the same row.

When I press F5 to go to, say, K19, NVDA echoes the contents of the cell
perfectly and I can review the data under the numpad key 5 .
I then press F5 again and type in AK19 and press enter to reach that cell.
NVDA does not call out the contents of the cell but focusses on the top of
the screen and will not be moved for love or money!
I then press alt+tab to swap out of Excel elsewhere and press alt+tab again
to get back into excel. Now NVDA reports the contents of the cell and I can
review the contents under the numpad 5 key.
Pressing F5 again, brings me back to the K19 cell and this time NVDA does
not focus on the cell and so I must switch away and back again with alt+tab
to read the cell contents.

This is the repeated pattern. Occasionally, NVDA does echo the target cell
on landing but more often than not, it does not do so.

I have attached the log file but all I can see in it are errors and no sign
of my keystrokes.

I tried these steps with JAWS and each cell is echoed perfectly. I take it,
then, that Windows is working perfectly.
Is this a known bug in NVDA?
Is there an options setting that I should set?

All advice welcome!

All the best,

Cearbhall

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...








--
Quentin Christensen
Training and Support Manager

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 

Join nvda@nvda.groups.io to automatically receive all group messages.