Re: Hearing "Unknown" when Using a Mouse


Travis Siegel <tsiegel@...>
 

Yes, I know, and my message below applies to all such items, as I said.  I've been developing web sites myself since 1996, so I am well versed in web content components, and I dis state in the message that the label applies to other gui elements as well, which would include radio buttons, checkboxes, edit boxes, submit buttons, and the like.


On 2/25/2019 10:27 PM, Rosemarie Chavarria wrote:

Some forms have radio buttons which allow you to make a choice whenselecting something. There are also combo boxes.



On 2/25/2019 7:25 PM, Travis Siegel wrote:

When using forms mode, it is expected that some sort of identifying text will be included with the item needing to be acted upon.  Therefore, some checkboxes might have a title saying it's the yes or the no check box.  If the said text isn't present, then NVDA has no way to know what the item is refering to, so will only state the actual item and not what it is supposed to be referring to.  This goes for all gui elements, not just checkboxes.

On 2/25/2019 10:10 PM, bestuiexperience wrote:
I am a software developer trying to develop accessible software. I am working with some checkboxes that always announce "unknown" before announcing the label. This occurs only in forms mode and only when using a mouse (which I understand some NVDA users do). Any clue as to what might be causing the issue?

Virus-free. www.avast.com

Join nvda@nvda.groups.io to automatically receive all group messages.