Re: Clock Addon


Luke Davis
 

Andrea

As an addendum to my last:

After my initial tests, I set the quiet hours to 10:00 PM-1:01 am, and the interval to 10 minutes.
Just for further changes, i altered the announcement type to sound only (no speech).

I heard no sounds until midnight, when suddenly I started getting announcements every 10 minutes!

I tried changing the end time to 01:01 am, but it continued going off. So then I tried changing it to 01:01 AM (capitalized AM), and nothing changed, it still went off at the next 10 minute mark.

So then I tried 24 hour mode, using the same effective times (22:00-01:01). I restarted NVDA twice, and at 12:50, sure enough, it still made the sound, totally ignoring the setting.

Next, at 01:02, I tried changing the quiet hours to 00:01-01:35. At 1:10, no alarm. At 1:20, no alarm. At 1:30, no alarm. At 1:40, alarm!

So upon further testing, I can confirm your bug.

It seems clear that there is a math error of some sort going on here.

Luke

On Wed, 21 Aug 2019, Luke Davis wrote:

First, some questions:

Are you using the stable version or the development version of the Clock and Calendar add-on?

Have you tried contacting the developers of the add-on? they are still active, and the add-on was last updated in May.

To test, I installed the stable add-on in latest NVDA beta.
I set to 10 minute voice and sounds announcements, and started testing at 8:58 PM (20:58).
I set to the 24 hour quiet hours, and entered:
Start: 21:11
End: 21:38

At 21:00 and 21:10, I got the normal announcement I was expecting.
At 21:20, nothing happened.
At 21:22, I quit then restarted NVDA.
At 21:30, nothing happened.
At 21:40, I got the normal announcement I was expecting.

Since everything seemed to be working well, I now made the following changes:
I turned off 24 hour quiet hours mode.
I set the interval to 15 minutes.
I set the quiet start time to: 8:00 PM.
I set the quiet end time to 10:05 pm. Note the lower case--I just thought I'd try that, and also tried 8:00 instead of 08:00.

At 9:45 PM and 10:00 PM, nothing happened.
At 10:15 PM, I got the normal announcement I was expecting.

Therefore, I very much do not confirm your bug. If you repeat my steps (with adjusted times, of course), what happens?

The following appears on the add-on's page (accessible from the add-ons manager):

To avoid bugs, the quiet hours must follow a rigorous and precise syntax;

If you check the "Input in 24-hour format" checkbox, the format must be "HH:MM";
If you uncheck the "Input in 24-hour format" checkbox, the format must be "HH:MM AM" or "HH:MM PM", the HH must contain a 12-hour format, from 0 to 12 and th$
If you check the Quiet hours" checkbox and keep the "Quiet hours start time" or "Quiet hours end time" field empty, or type a mistaken value, the "Quiet hour$
A message should be displayed to report your error.

Luke

Andrea Sherry wrote:

Using latest NVDA and clock settings addon.Having some issues with the clock addon.
The problem is with the quiet hours setting.
Have tried both 12-hour and 24-hour settings.
My settings were to have chhime stop at 9:30 pm and begin again at 6:00 am.
In toth instances the addon was correctly set. However the time announcement continued throughout the night.
Any ideas?
Andrea

Join nvda@nvda.groups.io to automatically receive all group messages.