Re: Sample of link in email that will not work properly


Robert Doc Wright godfearer
 

Luke, what email client are you using that seems to be causing this problem?

 

******If we can't look at ourselves, and ask, why?  then where does the learning start?***     

 

From: Luke Davis
Sent: Friday, September 20, 2019 12:27 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Sample of link in email that will not work properly

 

On Thu, 19 Sep 2019, Brian Vogel wrote:

 

>  I will lay you money that if you're looking at that message and bring up the screen reader links list it will not be present.           I don't understand

> why, on rare occasion, things that are clearly links do not end up being "linkified" (as I call the process of automatically changing what is clearly the

> text of a link into an actual embedded link) automatically.   It's a mystery, but one that does happen.

 

Easy to understand. Harder to explain.

 

Almost every email message that acts like a webpage, has two actual versions of

the message included.

One of them is text only, and one is HTML so it can be rendered prettily, and

behave more like a webpage.

 

It is the second of these that we usually see.

 

Indeed, when I looked at the message, the link in question wasn't clickable,

just as everyone but Gene experienced.

Since I am using alpine, I am able to look at the individual text and html

attachments that are included with the message. I don't know if Windows mail or

Outlook can actually do that, because these are not intended to be saved

independently from the message.

 

Anyway, saving the HTML attachment separately, and then viewing the source, it

is easy to see what is happening. That particular link is presented in a span

element, that is styled into being a link via CSS. Either the email programs

aren't loading or can't process that CSS, like mine, or they don't understand it

because of whatever rendering engine they use. The other links above and below

the one you are talking about, are presented in normal anchor elements, and so

can be easily clicked.

 

Interestingly, if you view the text version of the attachment in an email

program, the email app's own linking function is active, recognizes it as a

link, and makes it clickable.

Of course, to do that, you probably have to disable HTML emails, which will make

things very unusual for you.

 

For example, the text version of messages on this list, have very different

footers than the HTML versions (no "reply to sender", etc., links, for example),

although you usually only see them if someone sends a text only message, and the

groups.io interface doesn't HTMLize it, which it doesn't always do.

 

Anyway, that's why this is happening: Applevis's wordpress plugin that generates

those emails, encodes the links incorrectly for email presentation in the HTML

version of the emails it sends.

 

Interestingly, if you hit the "view this email on the web" link at the top, the

link will work fine on the page, and in the source, presents in an anchor

element. This is entirely a Wordpress problem.

 

Luke

 

 

 

Join nvda@nvda.groups.io to automatically receive all group messages.