Re: NVDA sometimes loses control and needs to be restarted


Sarah k Alawami
 

I've seen this before. Even narrator loses the narrator key when tha thappens. Saw it with 1903 and 1909 just recently. I had a memmory leak and. a program had crashed and nvda and narrator lost control of their keys. It was odd. Another time I think it just happened out of the blue. I could not get a log because of corse, the nvda key was not working.

Sarah Alawami, owner of TFFP. . For more info go to our website. This is also our libsyn page as well.

to subscribe to the feed click here

Our telegram channel is also a good place for an announce only in regard to podcasts, contests, etc.

Our discord is where you will know when we go live on youtube, twitch and mixer. Thanks Restream staff.

Finally, to become a patron and help support the podcast go here

On 10 Dec 2019, at 2:55, Vincent Le Goff wrote:

Hi everyone,

This has been happening for some time, on so many computers and with so many different NVDA versions I can't believe I would be the only one to see this, and it's not a huge inconvenience, but it's strange and might be worth looking into.  Regardless of the activity sometimes NVDA "loses control".  The key hooks (the NVDA key and all the shortcuts associated with it) stop working.  Using the numeric keypad works as would without NVDA.  Pressing Caplocks, which is a NVDA key for me, triggers the CapLock function.  NVDA still works somewhat and tries to report information, but one can't open the NVDA menu, read the time, look at the window title or indeed do lots of things controlled directly by NVDA.

When does it happen?  I've tried to reproduce the issue and it's tricky.  It never seems to happen at a given time or in any given application.  All I know is that it seems to "lose control" when a lot of memory is required by other applications, which creates some kind of lag.  So this happens in a browser when the site has a lot of scripts for instance.  This can happen in Word if the document is long.  This can happen while the Windows CLI is opened and a "demanding" task is running.  This can happen when lots of update information is sent to NVDA (the message queue gets long). It happens more frequently if the machine on which NVDA runs doesn't have a lot of memory.  It sounds like a Windows lock, not NVDA's fault, but is there a workaround?  Restarting NVDA and the delay it causes isn't really annoying, but it's definitely strange.

Most important question though: has anyone noticed this problem? Or am I the only lucky one?  Does happen!

Thanks,

Vincent

Join nvda@nvda.groups.io to automatically receive all group messages.