Re: NVDA sometimes loses control and needs to be restarted


Kevin Cussick
 

Look, the same here. but I remember at some point some time ago now there was some sort of problem with windows explorer and maybe Nvda I do remember loads of users reporting this some wile back but can't really remember what the fix if any was given.

On 10/12/2019 15:18, Luke Davis wrote:
You're not the only one to ever see it. I have had it happen many times, though not even as predictably as yours, and primarily in Firefox.
I have always, without fail, been in a hurry, and been unable to take the time to save a debug log to try to track the problem down later.
Luke
On Tue, 10 Dec 2019, Vincent Le Goff wrote:

This has been happening for some time, on so many computers and with so many different NVDA versions I can't believe I would be the only one to see this, and it's not a huge inconvenience, but it's strange and might be worth looking into.  Regardless of the activity sometimes NVDA "loses control". The key hooks (the NVDA key and all the shortcuts associated with it) stop working.  Using the numeric keypad works as would without NVDA.  Pressing Caplocks, which is a NVDA key for me, triggers the CapLock function.  NVDA still works somewhat and tries to report information, but one can't open the NVDA menu, read the time, look at the window title or indeed do lots of things controlled directly by NVDA.

When does it happen?  I've tried to reproduce the issue and it's tricky.  It never seems to happen at a given time or in any given application.  All I know is that it seems to "lose control" when a lot of memory is required by other applications, which creates some kind of lag.  So this happens in a browser when the site has a lot of scripts for instance.  This can happen in Word if the document is long.  This can happen while the Windows CLI is opened and a "demanding" task is running.  This can happen when lots of update information is sent to NVDA (the message queue gets long). It happens more frequently if the machine on which NVDA runs doesn't have a lot of memory.  It sounds like a Windows lock, not NVDA's fault, but is there a workaround?  Restarting NVDA and the delay it causes isn't really annoying, but it's definitely strange.

Most important question though: has anyone noticed this problem? Or am I the only lucky one?  Does happen!

Join nvda@nvda.groups.io to automatically receive all group messages.