Re: can't play an internet station using waterfox


Richard Kuzma
 

Sorry worng email was replyd to.

Sorry.

 

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Richard Kuzma via Groups.Io
Sent: Sunday, January 26, 2020 9:16 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] can't play an internet station using waterfox

 

Oki doki, no problem

 

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Gene
Sent: Sunday, January 26, 2020 7:17 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] can't play an internet station using waterfox

 

This should be moved to the NVDA chat list but I'll say that I more or less accomplished the same thing after seeing your message.  I don't think most people would have the technical knowledge to trouble shoot the problem, but I know enough that I was able to after reading your message. 

 

The person who created the web page will probably get so many complaints that he/she may correct the problem but who knows.

 

At any rate, it was interesting using your discussion to allow me to figure out how to make the stream play using an improperly configured link.

 

Gene

----- Original Message -----

From: Oriana

Sent: Sunday, January 26, 2020 6:03 AM

Subject: Re: [nvda] can't play an internet station using waterfox

 

Incidentally, if anyone is interested in collecting radio stations and switching between them like preprogrammed channels on a digital FM radio, all you need to do is collect the stream urls (the urls encapsulated in files such as live.wax) and enter them each on one line in a text file and save it as a .pls filetype, something like radio.pls . Then when you load it into WMP or VLC, you can flip through radio stations simply by using the "next track" button. However, if any one of the streams change their stream url, the media player will skip that radio station and move on to the next, usually without any kind of dialogue or error.

 

On Sun, Jan 26, 2020, 6:39 AM Oriana via Groups.Io <o.neulinger=gmail.com@groups.io> wrote:

Gene,

 

When you attempt to use the .wax file in VLC, it attempts to resolve to the stream url i posted with the character %20 appended to the end. (I don't know that the error displaying this attempt is displayed accessibly, however, which is likely why the end user was unable to troubleshoot.) %20 is url encoding for space, which is not usually appended to the end of urls. To test my theory that the stream url would work without the space, i downloaded the .wax file, which turned out to be a ".pls by any other name", removed the space in my text editing app Quoda, and opened it as a playlist in VLC... and that solved the problem as i expected. I am not familiar with .wax filetype, but it seems it encodes trailing spaces as being part of the url and thus, it was a typo. The "AAC" playlist file is also VLC compatible, at least on my version of VLC, which means the trailing space is not encoded, if it's present, and it's very likely the "Android" playlist file also ignores spaces, playing as designed in my browser. I suspect the same trailing space issue is present in the fourth playlist file, or possibly, given the error code i received, that the url is missing entirely. (After seeing how many other typos and broken tags are in the HTML for the website, the file could contain the entirety of War And Peace without surprising me.)

 

Note: by ".pls by any other name" what i mean is, most online streaming playlists are nothing more than some kind of text file that includes nothing but one or more actual stream url. This is handy for making shortcuts to the radio station, simply download the file and rename it to the radio station, and run it every time you want to listen - your media player (such as VLC, which is free, low-memory, and handles nearly every filetype you can throw at it) will load the stream url automatically. However, I don't understand why there are so many different "filetypes" for the same, standard behavior... all they are is a text document containing a url!

 

 

On Sun, Jan 26, 2020, 3:17 AM Gene <gsasner@...> wrote:

I should also say that trying another browser is still a good idea, but not believing the site and trying the link I discussed is the first thing to do.  it is the easiest, and it may solve the problem, as in this case.

 

Gene

----- Original Message -----

Sent: Sunday, January 26, 2020 1:54 AM

Subject: Re: [nvda] can't play an internet station using waterfox

 

I'm going into detail of how you may approach a problem like this so you may have a better understanding of what to do in future when you encounter such a problem.  Those who are not interested may want to skip this message.  Those interested may find it useful in future.

 

I see no error in the Windows Mediaplayer link.  I pasted it to the clippboard using the copy address submenu function in Chrome and got the following:

 

There are many listen links but, except for the Android devices link, However, they appear to be somehow coded incorrectly.  They cause Chrome to display a save as dialog, at least on my machine.  Others may report what they do on theirs.  I doubt using another browser would solve the problem, though that is generally one of the first gthings I do in such a case.  But, based on the behavior here, I doubt it will help, though I'm not sure. 

Given the odd behavior, the thing to do is the following:

Never believe a site in such a case.  Site developers may not know what they are doing and they may mislabel links in terms of describing what they do.  Try the android devices link.  I pressed enter on it and the stream played in my browser.  In short, the Android devices link is properly configured and will play in a Windows browser.  It may play using android devices as well but, the person who labeled the link as to its purpose didn't know what the link would do and mislabeled the only one that works.

 

Gene

----- Original Message -----

Sent: Saturday, January 25, 2020 10:21 PM

Subject: Re: [nvda] can't play an internet station using waterfox

 

www.thegridfm.com.

 

 

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Brian Vogel
Sent: Saturday, January 25, 2020 8:20 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] can't play an internet station using waterfox

 

There appear to be a number of URLs that get you to this station.  Could you please share the address you're using?

--

Brian - Windows 10 Pro, 64-Bit, Version 1909, Build 18363  

Power is being told you're not loved and not being destroyed by it.

       ~ Madonna

 

 

Join nvda@nvda.groups.io to automatically receive all group messages.