Re: interesting issue with file explorer on windows 10


 

Hello Shaun,

In the file operation progress dialog, there should be a button saying something of the sort of "Show more details" or "Show less details". If it says "Show less details", activate it. That way the file operation progress dialog will show less details. That should help to make NVDA report the progress bar in the dialog.

The dialog should show less details by default, but sometimes (probably due to accidental activation of the "Show more details" button by the user), it shows more details and that option is saved permanently until changed again by the user by activating the "Show less details" button.

The problem with this file operation progress dialog is that when it shows/displays more details about the current operation, the way it presents the progress bar is not normal. Instead of a standard progress bar, it displays an operation speed graph which vertically displays the operation speed and horizontally displays the progress. Apparently this non-standard way of displaying the progress bar brakes its detection and reporting by the screen readers. NV Access and Microsoft should investigate this and fix it.

______
Best wishes,
Kostadin Kolev

На 10.8.2020 г. в 21:53, Shaun Everiss написа:

Hi all.

I have noticed this for several weeks after the windows 2004 update on my computers, I have tried this on both.

I have also tried nvda 2017.3 to the latest with and without addons, and at least can confirm this aint nvda.

In windows explorer when performing file opperations, copy, delete, mainly, the progress bars do not beep.

Now progress bars will beep as they should in programs that they usually beep in like thunderbird, and if I try to access a network or large folder in file explorer they work as normal.

Only delete, move and copy are these progress bars not spoken, unless I tab back and forth, nvda will voice their percentages from time to time initially but will not do this unless I alt tab back and forth.

Its obvious that windows has changed something but its obviously working according to nvda as there are no log errors.

At least in the info log.

I assume its to do with the display of some bars.

Is this something nvda can get fixed so these work or is this something for microsoft to fix.

This aint a show stopper its just off putting that some bars do not read.

For me I do delete and copy files about especially if its a lot of data and from time to time I will want to know what all this is about.

I assume that its all this new universalising of the os which is causing this change.

Is it worth sending a debug to someone about this, and who do I send it at.






Join nvda@nvda.groups.io to automatically receive all group messages.