Re: Mouse navigation and Chrome


Gene
 

I said that this needs to be verified. I'm not sure if it does. Your procedure works in Firefox so what is occurring in Chrome? I suspect the mouse is moving to the right place, but the left click command doesn't activate the control, for some reason.

Gene

-----Original Message-----
From: Gene
Sent: Tuesday, November 17, 2020 11:57 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Mouse navigation and Chrome

On playing with the page further, I'll add that it may well be that the
mouse is not in the right place but that needs to be verified. Some other
things around that button can be activated and sme can't. OIs that because
the mouse doesn't move to those things or because there is something about
those things that they aren't activated?


Gene

-----Original Message-----
From: Gene
Sent: Tuesday, November 17, 2020 11:47 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Mouse navigation and Chrome

I should say I think its very likely the mouse isn't in the right place.

Gene
-----Original Message-----
From: Gene via groups.io
Sent: Tuesday, November 17, 2020 11:39 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Mouse navigation and Chrome

It is likely the case that the mouse isn't in the right place. That hasn't
been verified, however.

Gene
-----Original Message-----
From: Tyler Spivey
Sent: Tuesday, November 17, 2020 11:32 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Mouse navigation and Chrome

NVDA numpad enter will activate the button because the navigator is on
it. That has nothing to do with the mouse.

On 11/17/2020 9:27 PM, Gene wrote:
I am not aware of anything. The mouse, in this instance, is in the right place but for some reason, the left click command isn't clicking the button. You can verify that by using numpad insert numpad enter instead of left click. The button is activated.

Gene
-----Original Message----- From: Tyler Spivey
Sent: Tuesday, November 17, 2020 10:32 PM
To: nvda@nvda.groups.io
Subject: [nvda] Mouse navigation and Chrome

I'm trying to route the mouse in Chrome and am running into issues.

I'm playing incremental games that need mouse hovers to work reliably.
NVDA's mouse navigation doesn't work very well.

As a very basic example which requires not too much setup, I can
demonstrate this easily enough on Google.

I should be able to search Google, using mouse navigation to click the
button. I'm doing the following:
1. Restart NVDA with add-ons disabled.
2. Start Chrome, navigate to google.com.
3. Type test into the search field.
4. Hit f in browse mode until I find the Google Search button.
5. NVDA+numpad / to route the mouse, and click with numpad /.

When I do this, my page doesn't change. NVDA doesn't seem to be clicking
the button.

What can I do to make things work better?








Join nvda@nvda.groups.io to automatically receive all group messages.