Re: problems with a punctuation mark


Giles Turnbull
 

Hi to those who have replied. I normally use SAPI5 voice Zira, and occasionally Hazel. I just tried using the eSpeak synthesiser and the result is the same.

I did wonder if it might be the fact that I have the NVDA Speech settings option for automatic language switching toggled on, but I just toggled it off and that hasn't made any difference. I've noticed this in one friend posting from Minsk in Belarus, and another in Germany. The only comparable thing I've ever encountered is when viewing Word documents written in English by somebody in Germany, when a full stop gets spoken as "punkt", which is the German full stop punctuation mark. But, like others have noted, I can't imagine why somebody would use two single apostrophes as opposed to a double quote mark.

I did try the regular expression entry that Brian suggested, with no effect. I also tried changing the tick marks in the search and replacement fields (the tick / apostrophe does not seem to be not the same as a ′ symbol since NVDA says "tick" for the apostrophe but "prime" for the symbol) ... and there is still no change to NVDA saying "prime".

My only other thought is that I've only noticed this on Facebook and I know the Belarussian friend's posts reach me via Facebook's translation service. I cannot remember whether the German case had been translated. Much in the same way that OCR can render punctuation symbols as letters, maybe it is interpretting a double quote mark as being two prime symbols .. in fact, I'd go as far as to say that's highly likely! I will make enquiries about it :)

Thanks all

Giles .

Join nvda@nvda.groups.io to automatically receive all group messages.