Re: Strange problem with NVDA and LibreOffice


Quentin Christensen
 

I believe so - but it's always tricky with issues like that, to know exactly where the problem needs to be addressed, so absolutely do keep raising such things here - and also do contact the other program developer - LibreOffice in this case about it as well) - the more they know about things which are problematic for their users, the more likely they are to make it a higher priority.  I think there was a linked LibreOffice issue (on LibreOffice's Bugzilla tracker) as well.


On Thu, Apr 29, 2021 at 5:05 PM Michael Chopra <michaelchopra38@...> wrote:
Hi. Yes, I read all of that and that appears to be the issue that I'm
talking about. According to that GitHub issue, this appears to be
something that needs to be fixed in LibreOffice, is that right?
Thanks.
From Michael.

On 29/04/2021, Quentin Christensen <quentin@...> wrote:
> Hi Michael,
>
> Is this the issue you are facing:
> https://github.com/nvaccess/nvda/issues/4119  There's a lot of discussion
> on that issue, but basically, you press NVDA+down arrow / NVDA+a to say
> all, and NVDA only reads the first line or two of the document and stops?
>
> If so, the workaround I found seems to be effective, is to load your
> document, press CONTROL+END to jump to the end of the document, then
> control+home back to the start, and then try say all.
>
> Quentin.
>
> On Thu, Apr 29, 2021 at 10:48 AM Michael Chopra <michaelchopra38@...>
> wrote:
>
>> Hi everyone. I have a strange problem. It appears when using the ?Say
>> all"
>> command in NVDA with LibreOffice, the command does not work as expected.
>> I
>> use Caps lock as my NVDA modifier key and when I press it, normally it
>> would start reading from the current cursor positon to the end of the
>> document. It is not doing that in this instance. If I use the same
>> command
>> in Word, it works as expected.
>> I've been able to reproduce the issue multiple times and was wondering
>> what was going on here. I'm using Version: 7.1.2.2 (x64 of LibreOffice. I
>> have a friend who was also able to reproduce the issue, we have both now
>> switched back to word because of it.
>> My question then is this, is it an NVDA problem or is it a problem for
>> LibreOffice to fix?
>> I'm also using the latest version of NVDA as well.
>> Thanks for your help.
>> From Michael.
>>
>>
>>
>
> --
> Quentin Christensen
> Training and Support Manager
>
> Web: www.nvaccess.org
> Training: https://www.nvaccess.org/shop/
> Certification: https://certification.nvaccess.org/
> User group: https://nvda.groups.io/g/nvda
> Facebook: http://www.facebook.com/NVAccess
> Twitter: @NVAccess <https://twitter.com/NVAccess>
>
>
>
>
>
>







--
Quentin Christensen
Training and Support Manager

Join nvda@nvda.groups.io to automatically receive all group messages.