Re: How do I Stop NVDA from saying Blank when I arrow down in a document or email


JOHN RIEHL
 

Very interesting. Where do I go in NVDA to do this? If this is an elementary question I apologize; I'm a new user.

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Jonathan COHN via groups.io
Sent: Saturday, October 2, 2021 1:45 PM
To: Gene <gsasner@...>
Cc: nvda@nvda.groups.io
Subject: Re: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

Hello,

rather forcing blank to be changed in pronunciation using a regular expression dictionary entry might be useful.

^ is the beginning of line in regular expressions.

$ is the end of line in regular expressions.

* in regular expressions means 0 or more of the previous character or pattern 

So: 

^ *$ 

should match a line with just spaces in it.  ( note there is a space between the ^ and the * , also note you might want to turn on all punctuation to read my descriptions above, I can't be sure on this computer how much of NVDA reads of the above special characters.

Jonathan 

 



On Oct 2, 2021, at 11:38, Gene <gsasner@...> wrote:

 

I don’t know what accounts for the difference.  While others may know of another solution, you can use the speech dictionary so the word blank is never spoken.  But you may not want to do that in case you want to hear it spoken in certain contexts. 

 

Do you need to read moving line by line or can you read whatever you are reading using read to end.  If you use read to end, blank lines aren’t spoken.

 

Gene

-----Original Message-----

Sent: Saturday, October 02, 2021 10:00 AM

Subject: [nvda] How do I Stop NVDA from saying Blank when I arrow down in a document or email

 

I'm just getting started using NVDA at home and at work. About the only issue I'm having so far is that, on my work computer, when I'm arrowing down a document, either in Outlook 2016, Word, or in a web application that uses Firefox or chrome, I can't get NVDA 2021-2 to stop saying "blank" whenever I encounter a blank line. I have punctuation and symbols  set to none, and NVDA is set not to echo typed characters. Strangely, this isn't happening on my home computer using Office 2019 programs and, as far as I know, I have NVDA configured the same way.

Anybody got any suggestions?

 

Thanks for the help.

John Riehl 

 

Join nvda@nvda.groups.io to automatically receive all group messages.