Re: Issue Installing the Application Dictionary Add-On


 

Hi,

The issue is with the add-on. The message you get has to do with add-on API level - the latest API compatibility level is 2021.1. It is possible for add-on authors to specify a newer NVDA release (I had to change API level/release to 2021.2 a few weeks ago; for details, see the release announcements for version 21.10 of my add-ons).

Just changing the manifest is not a complete solution. Even if the add-on works after changing the "last tested version" field, things would have changed that causes old behavior to no longer work. This is why I always advise add-ons community to give status updates on add-ons as soon as the upcoming version enters beta phase, more so if it is a year.1 release.

The bigger issue is not keeping add-on author contact information up to date, as well as looking for maintainers. In terms of the latter point, it would have been emphasized lot more if the world didn't go south since 2020; since people are going through many things, it is perfectly understandable that the community would have a harder time finding maintainers. This will become very important soon when people find out that some important add-ons stopped working in NVDA 2022.1 beta 1 (thankfully the community has learned how severe that situation would be a bit early, so folks are keeping a closer eye on it).

Cheers,

Joseph

Join nvda@nvda.groups.io to automatically receive all group messages.