Re: NVDA Crashes on launch, log:OSError: [WinError 193]


Tyler Spivey
 

This is a weird one.
Go here and see if you can run nvdaHelperRemoteLoader.exe:

C:\Program Files (x86)\NVDA\lib64\2021.3.1

What error do you get when you try that? That line of code is pointing at that file, and my hope is that even though it's not running under NVDA, we'll get a more useful error out of it.

On 1/26/2022 7:06 PM, bpurvis@... wrote:
Moderator's Note:  The posting of log files on the group is discouraged for two reasons:
1. They can contain private data.
2.  There are few members who are able to interpret them.
Because this issue is so strange, I'm granting a one-time exception. General practice is to post the issue and offer to send the log privately to whoever may request it.  Please do this going forward.
--------------------------------------------------
Windows 7 SP1
During installation NVDA works fine. I can even select the option to Continue Running without doing an installation and it will work perfectly.
However once the installation is complete I can hear the NDVA startup sound which is immediately followed by the exit sound.
I have tried installing the latest version and even uninstalled, rebooted and installed the previous with the same results.
NVDA fails to launch with the same characteristics after a reboot.
Never does it remain in the taskbar.
While running in the Continue mode I can fully navigate the menus and have tried resetting/factory defaults but no change.
Even tried different voice profiles.
I have AVG Business installed and added the NDVA installed path as an exemption.
When I took a look at the logs I see this in the last line. OSError: [WinError 193] %1 is not a valid Win32 application.
*Full Log:
INFO - __main__ (21:46:36.635) - MainThread (5972):
Starting NVDA version 2021.3.1
INFO - core.main (21:46:36.686) - MainThread (5972):
Config dir: C:\Users\Jeffery\AppData\Roaming\nvda
INFO - config.ConfigManager._loadConfig (21:46:36.686) - MainThread (5972):
Loading config: C:\Users\Jeffery\AppData\Roaming\nvda\nvda.ini
INFO - core.main (21:46:36.729) - MainThread (5972):
Windows version: Windows 7 (6.1.7601) service pack Service Pack 1 workstation
INFO - core.main (21:46:36.729) - MainThread (5972):
Using Python version 3.7.9 (tags/v3.7.9:13c94747c7, Aug 17 2020, 18:01:55) [MSC v.1900 32 bit (Intel)]
INFO - core.main (21:46:36.729) - MainThread (5972):
Using comtypes version 1.1.8
INFO - core.main (21:46:36.729) - MainThread (5972):
Using configobj version 5.1.0 with validate version 1.0.1
CRITICAL - __main__ (21:46:36.932) - MainThread (5972):
core failure
Traceback (most recent call last):
  File "nvda.pyw", line 362, in
  File "core.pyc", line 442, in main
  File "NVDAHelper.pyc", line 569, in initialize
  File "NVDAHelper.pyc", line 482, in __init__
  File "winKernel.pyc", line 351, in CreateProcessAsUser
OSError: [WinError 193] %1 is not a valid Win32 application.
Any Suggestions?
Thanks

Join nvda@nvda.groups.io to automatically receive all group messages.