Update On My Incompatible Add-Ons


Ron Canazzi
 

Hi Group,

I took the radical step of simply changing the manifest.ini for some of my add-ons that are listed as incompatible with NVDA 2022.1.  I know this is somewhat dangerous, but for simple, non essential type things like Extended Winamp and phonetic reading, I gave it a go. The following add-ons work when using this inefficient method.

extended Winamp
enhanced phonetic reading
clock
day of the week.

Again, this is a radical step and over time, if these add-ons are not rewritten, there will probably be problems. But as a stop gap until people update, this might be something to consider. I advise doing this one at a time, exiting and restarting NVDA and seeing if there is any deleterious effect--not only for the add on itself, but for NVDA in general. Who knows what this kind of Gerry rigging might cause.

--
Signature:
For a nation to admit it has done grevous wrongs and will strive to correct them for the betterment of all is no vice;
For a nation to claim it has always been great, needs no improvement and to cling to its past achievements is no virtue!

Join nvda@nvda.groups.io to automatically receive all group messages.