Date   

Re: NVDA 2016.4 released #nvdasr

Jason White
 

Joseph Lee <@joslee> wrote:
Hi,
Try with log level set to input/output.
This delivered the goods - see the exerpt from the log below.

DEBUGWARNING - updateCheck.UpdateDownloader._bg (13:17:20):
Error downloading
https://www.nvaccess.org/download/nvda/releases/2016.4/nvda_2016.4.exe?update=1
Traceback (most recent call last):
File "updateCheck.pyo", line 304, in _bg
File "updateCheck.pyo", line 326, in _download
RuntimeError: Download failed with code 503
DEBUGWARNING - WX Widgets (13:17:20):
..\..\src\common\timerimpl.cpp, line 60:
assert wxThread::IsMain(): timer can only be started from the main thread
Stack trace:
File "threading.pyo", line 774, in __bootstrap
File "threading.pyo", line 801, in __bootstrap_inner
File "threading.pyo", line 754, in run
File "updateCheck.pyo", line 313, in _bg
File "updateCheck.pyo", line 295, in _guiExec
File "wx\_misc.pyo", line 1324, in Start
File "core.pyo", line 213, in OnAssert
IO - braille.BrailleBuffer.update (13:17:20):
Braille regions text: [u'OK btn']


Re: NVDA 2016.4 released #nvdasr

 

Hi,
Try with log level set to input/output.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Jason
White via Groups.Io
Sent: Friday, December 16, 2016 9:52 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2016.4 released #nvdasr

Joseph Lee <@joslee> wrote:
Hi,
Can you post the relevant portion of the log so we can find out what's
going on/
Log Viewer only shows the initialization of NVDA; there are no messages
referring to the update attempts. To test, I restarted NVDA and ran the
update, resulting in the same error, and nothing in the logs.

Do I need to raise the log level, or are the update-related logs stored
elsewhere?


Re: NVDA 2016.4 released #nvdasr

Jason White
 

Joseph Lee <@joslee> wrote:
Hi,
Can you post the relevant portion of the log so we can find out what's going
on/
Log Viewer only shows the initialization of NVDA; there are no messages
referring to the update attempts. To test, I restarted NVDA and ran the
update, resulting in the same error, and nothing in the logs.

Do I need to raise the log level, or are the update-related logs stored
elsewhere?


Re: NVDA2016.4 issue on Windows 10 Anniversary Update

Chris
 

Its all bill gates fault talk to him

 

 


Re: NVDA and icloud.com

Chris
 

If I cloud drive is enabled on your phone then is should sync without you doing anything

just make sure icloud drive is enabled in the icloud setting on your pc  which can be found in your start menu

And of course in your icloud settings in your phone

 

 


Re: NVDA 2016.4 released #nvdasr

Antony Stone
 

Those are the *ideal* specifications.

As Joseph wrote in an earlier posting in this thread, the minimum
specifications are Windows XP SP2 or above, a gigahertz processor or faster, at
least 256 MB of RAM and 90 MB free space on your drive.


Antony.

On Friday 16 December 2016 at 17:21:16, nasrin khaksar wrote:

hi joseph.
what do you mean about requirements Windows 7 SP1, 1 GB of RAM or
greater, 1 GHz or faster processor, and at least 100 MB of free space
on the drive?
is it system requirements for nvda 2017.1?
whats the system requirements for that version?
--
Normal people think "If it ain't broke, don't fix it".
Engineers think "If it ain't broke, it doesn't have enough features yet".

Please reply to the list;
please *don't* CC me.


Re: NVDA 2016.4 released #nvdasr

 

hi joseph.
what do you mean about requirements Windows 7 SP1, 1 GB of RAM or
greater, 1 GHz or faster processor, and at least 100 MB of free space
on the drive?
is it system requirements for nvda 2017.1?
whats the system requirements for that version?

On 12/16/16, Joseph Lee <@joslee> wrote:
Hi,
Can you post the relevant portion of the log so we can find out what's
going
on/
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Jason
White via Groups.Io
Sent: Friday, December 16, 2016 8:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2016.4 released #nvdasr

When I try to update from 2016.3 to 2016.4, I get an error dialogue stating
that it failed to download the update.







--
we have not sent you but as a mercy to the creation.
holy quran, chapter 21, verse 107.
in the very authentic narration is:
imam hosein is the beacon of light and the ark of salvation.
best website for studying islamic book in different languages
al-islam.org


Re: NVDA 2016.4 released #nvdasr

 

Hi,
Can you post the relevant portion of the log so we can find out what's going
on/
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Jason
White via Groups.Io
Sent: Friday, December 16, 2016 8:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2016.4 released #nvdasr

When I try to update from 2016.3 to 2016.4, I get an error dialogue stating
that it failed to download the update.


Re: NVDA 2016.4 released #nvdasr

 

Hi,
Starting with NVDA 2016.4, the new UEB tables are used to display braille (if chosen). I, Jamie (from NV Access) and others spent months perfecting this, and the overall result is that you should encounter fewer translation errors in UEB. Braille input is under intensive testing (only available in next branch snapshots at the moment) and requires some more work, particularly when it comes to handling some oddities in back-translation routines (some of which are quite serious).
Cheers,
Joseph
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Nevzat Adil
Sent: Friday, December 16, 2016 7:33 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2016.4 released #nvdasr

I upgraded with no problem. Looks like NVDA has been greatly improved thanks to the hard work of the developers.
My expectation was that there would be input table for UEB.
In what's new it says:

• Updated liblouis braille translator to 3.0.0. This includes significant enhancements to Unified English Braille. (

I have no idea wath improvements were made as it is a very obscure statement.
Well, I'll keep my fingers crossed for the next release.
Although my main screen reader is NVDA, I still use JAWS as a backup because of UEB output and input tables.
Keep up the good work.
Nevzat Adil


On 12/16/16, brian <sackriderbrian45@...> wrote:
For those of you who are concerned about your upgrade to the
full version if you have a release candidate you will get the full
version. I had rc 2 and just now I checked for updates and it told me
that an update was available so I downloaded and installed it. This
should reassure people about this issue thats why I have never
downloaded any rc candidates before now. I was not sure if I would
get the full version but I did.

Brian Sackrider


On 12/15/2016 8:31 PM, Joseph Lee wrote:

Hi all,

If you are using Windows 10, I strongly recommend upgrading to 2016.4.
Thank you Quentin and other NV Access staff, fellow users and
developers for making this possible and providing us (the community)
with something to celebrate as we close NVDA’s tenth anniversary
celebrations.

Cheers,

Joseph

*From:*nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] *On Behalf Of
*Quentin Christensen
*Sent:* Thursday, December 15, 2016 5:26 PM
*To:* nvda@nvda.groups.io
*Subject:* [nvda] NVDA 2016.4 released #nvdasr

Hi everyone,

NVDA 2016.4 Now Available

NV Access is pleased to announce that version 2016.4 of NVDA, the
free screen reader for Microsoft Windows, has now been released.

Highlights of this release include improved support for Microsoft
Edge; browse mode in the Windows 10 Mail app; and significant
improvements to NVDA’s dialogs.

See the full release announcement and download link for #nvdasr
2016.4
at: http://www.nvaccess.org/post/nvda-2016-4-now-available/
<http://l.facebook.com/l.php?u=http%3A%2F%2Fwww.nvaccess.org%2Fpost%2
Fnvda-2016-4-now-available%2F&h=QAQEFYvVwAQEgvZeQY9NX5kAYJ8X98Z6ZBXHf
RkFOiX-BnA&enc=AZP2-ASs3Us4H4VLyIVukfll1eAFodxp1wsttuyefcfhBhml_MUwh8
Q2IysLjDG-ocYl6s0H9UOk6pu7ByhyJ9QxagLqZDfkwxAm8jp12hI5GqkIFRn8GBxPDzv
wU8VbvEha2sjRVDd5ShzT3p8aNWjsbq2HHgtzxHGsBgz9Mo7igaf7zGjwfGl4w9AUvlzO
UQ3-I70S-AVidKJWtzvt1QPR&s=1>

Kind regards

Quentin.

--

Quentin Christensen
Training Material Developer

Basic Training for NVDA & Microsoft Word with NVDA E-Books now
available: http://www.nvaccess.org/shop/

Ph +61 7 3149 3306 <tel:%2B61%207%203149%203306>

Direct: +61 413 904 383
www.nvaccess.org <http://www.nvaccess.org/>
Facebook: http://www.facebook.com/NVAccess
Twitter: @NVAccess


Re: NVDA2016.4 issue on Windows 10 Anniversary Update

 

Hi,

Yes for stable build users.

Cheers,

Joseph

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Supanut Leepaisomboon
Sent: Friday, December 16, 2016 7:38 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA2016.4 issue on Windows 10 Anniversary Update

 

Oh. So I have to wait until spring 2017 to get this issue fixed?


Re: NVDA 2016.4 released #nvdasr

 

Hi,
At least that's the absolute minimum specs. The ideal spec would be Windows 7 SP1, 1 GB of RAM or greater, 1 GHz or faster processor, and at least 100 MB of free space on the drive. We're using absolute minimum specs on paper because many around the world cannot afford computers with ideal specifications.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Antony Stone
Sent: Friday, December 16, 2016 7:43 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2016.4 released #nvdasr

Windows XP in 256 MB of RAM!?

Surely that's almost unusable, with or without NVDA?

Antony.

On Friday 16 December 2016 at 16:40:27, Joseph Lee wrote:

Hi,
Generally speaking, you'll need Windows XP SP2 or above, a gigahertz
processor or faster, at least 256 MB of RAM and 90 MB free space on
your drive. Cheers, Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of
nasrin khaksar Sent: Friday, December 16, 2016 5:09 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2016.4 released #nvdasr

whats the system requirements for nvda 2017.1?
i am realy curious about it and the new features and changes of nvda.
--
René Descartes walks in to a bar.
The barman asks him "Do you want a drink?"
Descartes says "I think not," and disappears.

Please reply to the list;
please *don't* CC me.


Re: NVDA 2016.4 released #nvdasr

Jason White
 

When I try to update from 2016.3 to 2016.4, I get an error dialogue stating
that it failed to download the update.


Re: NVDA 2016.4 released #nvdasr

Antony Stone
 

Windows XP in 256 MB of RAM!?

Surely that's almost unusable, with or without NVDA?

Antony.

On Friday 16 December 2016 at 16:40:27, Joseph Lee wrote:

Hi,
Generally speaking, you'll need Windows XP SP2 or above, a gigahertz
processor or faster, at least 256 MB of RAM and 90 MB free space on your
drive. Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of nasrin
khaksar Sent: Friday, December 16, 2016 5:09 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2016.4 released #nvdasr

whats the system requirements for nvda 2017.1?
i am realy curious about it and the new features and changes of nvda.
--
René Descartes walks in to a bar.
The barman asks him "Do you want a drink?"
Descartes says "I think not," and disappears.

Please reply to the list;
please *don't* CC me.


Re: NVDA 2016.4 released #nvdasr

 

Hi,

A lot of things being tested and under design at the moment. I won’t say what they are until some of them comes to master snapshots, as things can change in the next branch snapshots. One thing I can say though is that there will be something that’ll be helpful for those composing complex documents in Word.

Cheers,

Joseph

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Supanut Leepaisomboon
Sent: Friday, December 16, 2016 4:28 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2016.4 released #nvdasr

 

I use to play around with the Next snapshot branch, but kind of stopped as on my desktop I don't use NVDA very often and I don't really want to use beta/alpha builds of NVDA on my laptop as I'm using that one for college and so I want only stable builds.

What features/enhancements I can look forward to for the 2017.1 release?


Re: NVDA 2016.4 released #nvdasr

 

Hi,
Generally speaking, you'll need Windows XP SP2 or above, a gigahertz processor or faster, at least 256 MB of RAM and 90 MB free space on your drive.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of nasrin khaksar
Sent: Friday, December 16, 2016 5:09 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2016.4 released #nvdasr

whats the system requirements for nvda 2017.1?
i am realy curious about it and the new features and changes of nvda.

On 12/16/16, Gerardo Corripio <gera1027@...> wrote:
Yes just updated my copy of NVDA to 2016.4 and working just great!
Thanks for making available a free screen reader for those in
less-developped countries where the luxury of the competition is way
too expensive to use as needed and not (you know what i mean).

El 16/12/2016 06:30 a.m., Mário Navarro escribió:



Hi
I want to thank you for all that NV Access and collaborators have
done for all the blind in the world.
God bless and give you years of healthy life.
You are the best in this world.
Thank you and congratulations for another excellent NVDA release!
Thank you!
Cheers.


Às 01:26 de 16/12/2016, Quentin Christensen escreveu:
Hi everyone,

NVDA 2016.4 Now Available

NV Access is pleased to announce that version 2016.4 of NVDA, the
free screen reader for Microsoft Windows, has now been released.

Highlights of this release include improved support for Microsoft
Edge; browse mode in the Windows 10 Mail app; and significant
improvements to NVDA’s dialogs.

See the full release announcement and download link for #nvdasr
2016.4 at: http://www.nvaccess.org/post/nvda-2016-4-now-available/
<http://l.facebook.com/l.php?u=http%3A%2F%2Fwww.nvaccess.org%2Fpost%
2Fnvda-2016-4-now-available%2F&h=QAQEFYvVwAQEgvZeQY9NX5kAYJ8X98Z6ZBX
HfRkFOiX-BnA&enc=AZP2-ASs3Us4H4VLyIVukfll1eAFodxp1wsttuyefcfhBhml_MU
wh8Q2IysLjDG-ocYl6s0H9UOk6pu7ByhyJ9QxagLqZDfkwxAm8jp12hI5GqkIFRn8GBx
PDzvwU8VbvEha2sjRVDd5ShzT3p8aNWjsbq2HHgtzxHGsBgz9Mo7igaf7zGjwfGl4w9A
UvlzOUQ3-I70S-AVidKJWtzvt1QPR&s=1>


Kind regards


Quentin.


--
Quentin Christensen
Training Material Developer
Basic Training for NVDA & Microsoft Word with NVDA E-Books now
available: http://www.nvaccess.org/shop/

Ph +61 7 3149 3306 <tel:%2B61%207%203149%203306>
Direct: +61 413 904 383
www.nvaccess.org <http://www.nvaccess.org/>
Facebook: http://www.facebook.com/NVAccess
Twitter: @NVAccess
--
Enviado desde mi lap
Gerardo J Corripio Flores Psicólogo, Terapéuta Reiki Saludos desde
Tampico, Tamaulipas México


--
we have not sent you but as a mercy to the creation.
holy quran, chapter 21, verse 107.
in the very authentic narration is:
imam hosein is the beacon of light and the ark of salvation.
best website for studying islamic book in different languages al-islam.org


Re: Important announcement: starting today, some add-ons will require you to upgrade to NVDA 2016.4

 

Hi,
They will install. The problem comes in if users attempt to use parts of
add-ons that are now powered by 2016.4 code base, including newer-style
dialogs (gui.guiHelper, for instance) and causing various errors (mostly
attribute error) to be recorded in the log and things to not function
correctly.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Rui
Fontes
Sent: Friday, December 16, 2016 2:52 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Important announcement: starting today, some add-ons
will require you to upgrade to NVDA 2016.4

I think they will not install...

Rui


-----Mensagem Original-----
De: Brian's Mail list account
Data: 16 de dezembro de 2016 10:31
Para: nvda@nvda.groups.io
Assunto: Re: [nvda] Important announcement: starting today, some add-ons
will require you to upgrade to NVDA 2016.4

Sounds reasonable but will you be testing that if people attempt to run
newer versions on older nvda, that it won't screw anything up and just won't
load or turn them off?
Otherwise I can see the folk who never read the words or update unless they
need to getting their nvdas in a bit of a pickle!
Maybe the last version which worked on 2016.3 should be retained on a page
of legacy add onse for those for whatever reason who cannot update. This
will probably be those who rely on their administrators to install nvda.


Brian

bglists@...
Sent via blueyonder.
Please address personal email to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda@nvda.groups.io>
Sent: Friday, December 16, 2016 3:43 AM
Subject: [nvda] Important announcement: starting today, some add-ons will
require you to upgrade to NVDA 2016.4


Hi everyone,

For those using 2016.3 or earlier: there will come a time when some
add-ons
will ask you to upgrade to NVDA 2016.4 in order for them to function. For
my
add-ons, I'll enforce 2016.4 requirement from February 2017 releases:



* StationPlaylist Studio: Version 17.04 (currently listed as
17.1-dev) will require 2016.4 or later. Major parts of this add-on now
uses
features introduced in 2016.4 (specifically, new user interface routines).

* Windows 10 App Essentials: Version 17.02 will not run properly
under NVDA 2016.3 or earlier. A critical component required to support
universal apps and write app modules for them has been included in NVDA
2016.4, thus this is no longer needed in the add-on.



Other add-ons that will require you to use NVDA 2016.4 include upcoming
versions of Place Markers, Rapid Settings, Clip Contents Designer and
others. Also, an add-on called Indentone (by Derek Riemer), used to let
you
hear indentation via tones, is hereby deprecated and should be removed, as
NVDA 2016.4 includes this feature.



For add-on writers: I'll write a formal directive to the add-ons list, but
the big picture is: if you are going to use graphical user interfaces such
as dialogs, you should use GUI Helper services provided by NVDA 2016.4 or
later. Also, you can now write app modules where executable names have a
dot
in the middle (for that, replace dots with underscores).



Thank you.

Cheers,

Joseph


Re: NVDA2016.4 issue on Windows 10 Anniversary Update

 

Oh. So I have to wait until spring 2017 to get this issue fixed?


Re: NVDA 2016.4 released #nvdasr

 

I upgraded with no problem. Looks like NVDA has been greatly improved
thanks to the hard work of the developers.
My expectation was that there would be input table for UEB.
In what's new it says:

• Updated liblouis braille translator to 3.0.0. This includes
significant enhancements to Unified English Braille. (

I have no idea wath improvements were made as it is a very obscure statement.
Well, I'll keep my fingers crossed for the next release.
Although my main screen reader is NVDA, I still use JAWS as a backup
because of UEB output and input tables.
Keep up the good work.
Nevzat Adil

On 12/16/16, brian <sackriderbrian45@...> wrote:
For those of you who are concerned about your upgrade to the
full version if you have a release candidate you will get the full
version. I had rc 2 and just now I checked for updates and it told me
that an update was available so I downloaded and installed it. This
should reassure people about this issue thats why I have never
downloaded any rc candidates before now. I was not sure if I would get
the full version but I did.

Brian Sackrider


On 12/15/2016 8:31 PM, Joseph Lee wrote:

Hi all,

If you are using Windows 10, I strongly recommend upgrading to 2016.4.
Thank you Quentin and other NV Access staff, fellow users and
developers for making this possible and providing us (the community)
with something to celebrate as we close NVDA’s tenth anniversary
celebrations.

Cheers,

Joseph

*From:*nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] *On Behalf Of
*Quentin Christensen
*Sent:* Thursday, December 15, 2016 5:26 PM
*To:* nvda@nvda.groups.io
*Subject:* [nvda] NVDA 2016.4 released #nvdasr

Hi everyone,

NVDA 2016.4 Now Available

NV Access is pleased to announce that version 2016.4 of NVDA, the free
screen reader for Microsoft Windows, has now been released.

Highlights of this release include improved support for Microsoft
Edge; browse mode in the Windows 10 Mail app; and significant
improvements to NVDA’s dialogs.

See the full release announcement and download link for #nvdasr 2016.4
at: http://www.nvaccess.org/post/nvda-2016-4-now-available/
<http://l.facebook.com/l.php?u=http%3A%2F%2Fwww.nvaccess.org%2Fpost%2Fnvda-2016-4-now-available%2F&h=QAQEFYvVwAQEgvZeQY9NX5kAYJ8X98Z6ZBXHfRkFOiX-BnA&enc=AZP2-ASs3Us4H4VLyIVukfll1eAFodxp1wsttuyefcfhBhml_MUwh8Q2IysLjDG-ocYl6s0H9UOk6pu7ByhyJ9QxagLqZDfkwxAm8jp12hI5GqkIFRn8GBxPDzvwU8VbvEha2sjRVDd5ShzT3p8aNWjsbq2HHgtzxHGsBgz9Mo7igaf7zGjwfGl4w9AUvlzOUQ3-I70S-AVidKJWtzvt1QPR&s=1>

Kind regards

Quentin.

--

Quentin Christensen
Training Material Developer

Basic Training for NVDA & Microsoft Word with NVDA E-Books now
available: http://www.nvaccess.org/shop/

Ph +61 7 3149 3306 <tel:%2B61%207%203149%203306>

Direct: +61 413 904 383
www.nvaccess.org <http://www.nvaccess.org/>
Facebook: http://www.facebook.com/NVAccess
Twitter: @NVAccess


Re: NVDA2016.4 issue on Windows 10 Anniversary Update

 

Hi,

It turns out this was partly Microsoft’s fault. Luckily, NV Access wrote a patch for it, and this patch is being reviewed. Note that this patch will require you to use Creators Update (spring 2017). I’ll write a more detailed post today.

Cheers,

Joseph

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Supanut Leepaisomboon
Sent: Friday, December 16, 2016 6:26 AM
To: nvda@nvda.groups.io
Subject: [nvda] NVDA2016.4 issue on Windows 10 Anniversary Update

 

Hi all,

I just updated my laptop to Windows 10 Aniversary Update along with NVDA to the new 2016.4 release, and I'm having one issue. When in universal apps, even the settings app, NVDA won't read any characters that I typed, for instance into the Settings app's search field, but when I pressed the backspace key, NVDA reads the deleted character just fine. I tried uninstalling and reinstalling NVDA, running NVDA as admin, still no luck.

Is this a NVDA bug?


Re: cloud OCR

 

I would like to know this too


On 12/16/2016 7:31 AM, Devin Prater wrote:
Hi all. Has anyone noticed that the Cloud OCR addon has stopped working? Is there, now, a better solution than the addon made in 2011 or so?
--
Devin Prater
r.d.t.prater@...