Date   

Re: suggestion: giving google chrome a try Performance degradation in current Firefox

Chris Mullins
 

Hi Nimer

Just a few questions:

Can I establish if you  are using Chrome or Canary?  

What is ChromeVox?

What is the status of the ‘automatically run say all on page load’ in  the NVDA Browse mode dialog?

What is the status of the ‘automatic focus mode for focus changes’ in  the NVDA Browse mode dialog?

What is the status of the ‘automatic focus mode for caret movement’ in  the NVDA Browse mode dialog?

 

I have   Chrome and Canary and don’t get the same as you re pressing tab to see the content in either version of the browser

The quick navigation keys operate when you are in browse mode and I’ve not had trouble with them in standard web pages with eiter browser but there is a problem with them in the settings page of Chrome but they seem to work OK in the Canary settings page.

The chrome menu reads perfectly in chrome but there are a couple of gaps in the Canary version after Zoom and Edit entries.

 

Cheers

Chris

From: Nimer Jaber [mailto:nimerjaber1@...]
Sent: 27 March 2016 22:37
To: nvda@groups.io
Subject: Re: suggestion: giving google chrome a try [nvda] Performance degradation in current Firefox

 

Unfortunately, Chrome accessibility has a bit of a ways to go. I wish it didn't. I wish I could reliably use Chrome without the strangeness that persists, but I can't. With Canary, some menu items are not read out by NVDA, but are by Chromevox. Others are read out by NVDA and not by Chromevox. I don't want two screen reading packages running. When navigating the web and going to a new web page, I seem to have to push tab after a new page loads, otherwise NVDA doesn't seem to see the content on the page. When doing a search on the Google page and when navigating around Chrome in general, pressing H to navigate by heading only works sometimes, but sometimes locks up until I again press tab to force it to get back to the content. The sign-in process in Chrome does not work with NVDA. I needed to use Window-eyes to get it to read the content. JAWS was also unable to read it. And I will post another thread about this, but Hangouts doesn't work very well. the Hangouts app seems to be totally inaccessible to next branches of NVDA and Canary. And the keyboard shortcuts that Google outlines in their manual at https://support.google.com/hangouts/answer/3112005?rd=1 don't work when navigating to hangouts.google.com, and the article doesn't specify where exactly these shortcuts are supposed to work. Actually many hotkeys that Google outlines interfere with browser-specific hotkeys. So I would be happy to transition to using Chrome, as Firefox is becoming awful, but that would mean a huge loss of productivity for me. So if you have been able to get Chrome to work more reliably, I am interested in which version of Chrome and which version of NVDA, as well as any settings changes that you have made for your specific set-up. If this is localized to just me, I am willing to do some troubleshooting, but on three computers Chrome's behavior seems to be the same. About the only improvement I have seen to Chrome Canary is that NVDA reads out a few additional menu items that it wasn't reading before. I might try resetting Chrome back to default settings and removing all plugins to see if that has any effect, but this installation of Chrome is pretty new, so I'm not sure if that will help or not.

Thanks.

On 3/27/2016 4:05 PM, Scott VanDeWalle wrote:

Hey.
I've been using chrome now for a couple of weeks now i believe.
It is pretty good for the most part.
hth

Scott

On 3/27/2016 9:20 AM, Peter Beasley wrote:

My problem with Firefox is that I am no longer able to use the BBC iplayer. Every time I try to listen to something, I get a message telling me that the Adobe flash plugin has crashed. This particular plugin is up to date and I have been having this problem since early December. I know this is not anNVDA issue but would be greatful if anyone has any ideas on how I can sort this out. I have been using Firefox as my primary browser now for nearly 9 and a half years. 

 

From: mk360

Sent: Sunday, March 27, 2016 1:31 PM

Subject: Re: [nvda] Performance degradation in current Firefox

 

I've in firefox 45.0.1 and all is working fine.

El 27-03-2016 a las 8:46, Mr. Wong Chi Wai, William escribió:

I see no problem with NVDA. I recommend you go onto google and search for about:config that can help improve firefox performace and that pretty helps.

Kevin Chao 27/3/2016 10:13 寫道:

One of Chrome's strengths is performance...I experience 0% lag with MVDA when interacting with modern web apps.

On Sat, Mar 26, 2016 at 5:11 PM Supanut Leepaisomboon <supanut2000@...> wrote:

I noticed performance issues with Firefox as well, but not just with NVDA, but Jaws as well, especially on Facebook where the browser lags. Firefox seemed to perform poorly on my Surface 3, despite not having any addons installed.

 

 

 

 


Re: Suggestion for upcoming NVDA build

Pete <emac00@...>
 

It would be a cool check box to have:
check-box --- update to snapshot versions?
May be at the 20 year mark of nvda.
Pete

On 3/27/2016 5:29 PM, Christopher-Mark Gilland wrote:
Oh yeah, I didn't mean remove the update option to a normal build. I was just simply meaning to add the option to update to a snapshot from within the app if desired. In no way was I suggesting to remove the ability to update to the next official non snapshop build. I agree. That would be a very stupid thing to do.
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.

clgilland07@gmail.com
Phone: (704) 256-8010 Extension 401.
----- Original Message ----- From: "Pete" <emac00@cogeco.ca>
To: <nvda@groups.io>
Sent: Sunday, March 27, 2016 11:13 AM
Subject: Re: [nvda] Suggestion for upcoming NVDA build



Snapshot users use snapshots.
Main branch users use main versions.
This doesn't require the main branch to be modified and instead targets the wanted modification users, snapshot users with the update to snapshots witch is what they want rite?
The normal update channel will stil be there in the snapshot version so if a snapshot user wants to update to a main version she or he can do so if desired.
People using snapshots are more likely to upgrade snapshots.
Why clutter up nvda main with extra options they may, no more than likely use?
Having said all that, the option to update to snapshot versions in the main branchbrantch would keep the code consistant between main and snapshot.
if a snapshot user upgrades to a main version they would loose upgrade to snapshot version, so may be better to modifie the main branch.
Keeping the snapshot and main versions separate makes more sense.
It is less confusing for
snapshot users to update to snapshot version updates
and
main version users update to main version updates
respectively and exclusively.

Pete


On 3/27/2016 10:04 AM, Lenron wrote:
You should just have the option in the main version if you wish to
update to a snap shot or not. I normally love grabbing the next build
as soon as I can.

On 3/27/16, Pete <emac00@cogeco.ca> wrote:
Hi Chris
What I am talking about is the snap shot versions of nvda check for
snap shot updates them selves.
In that way the normal nvda dist users could just go on using the
normal nvda dist with out worrying if it will update to a snap shot.
Pete



On 3/26/2016 6:41 PM, Christopher-Mark Gilland wrote:
Well, when on a snapshot, it actually does notify you of updates at
this point. Not sure when the last time was you tried.
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.

clgilland07@gmail.com
Phone: (704) 256-8010 Extension 401.
----- Original Message ----- From: "Alexander Masic" <list@masic.se>
To: <nvda@groups.io>
Sent: Saturday, March 26, 2016 9:03 AM
Subject: Re: [nvda] Suggestion for upcoming NVDA build


Personaly i think it could be an good idea. I think many like me
often forgot to check for updates even for snapshot, so at least some
kind of notification would be apresiated.



Den 2016-03-26 kl. 13:54, skrev Kevin Cussick via Groups.io:
no this is not a good idea, a newbey might try this feature that
you want and download a snap and it might have problems then threw
word of mouth nvda gets a bad reputation, this was asked for some
years ago and the devs gave this explanation of why it was a bad
idea I agree with them.

On 26/03/2016 03:51, Christopher-Mark Gilland wrote:
I was just thinking how cool of a feature this would be, and I'd not
think it would be terribly hard either to implement.
How hard would it be from the official build, like in this case,
2016.1,
to put an option in the NVDA menu, maybe under Tools, that
automatically
like downloading updates would let the user download and install the
latest snapshot build rather than them having to go out to the web
site
and manually get it. Either that, or maybe under the General tab of
preferences, where you have the box to check or uncheck for
checking for
updates, maybe have another one that says download snapshot builds
when
updating.
What do you all think?
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.
clgilland07@gmail.com <mailto:clgilland07@gmail.com>
Phone: (704) 256-8010 Extension 401.










Re: attempting to instal the google hangouts plugin to firefox

Pete <emac00@...>
 

 
  Hi 
  I first installed the hangouts software with the fire fox browser closed.  it's called google voice and video setup. 
  I downloaded it and installed it. 
  Next  open fire fox and go to 
 
google hangouts
 
  the address is: 
https://hangouts.google.com/
  this is a page wear one can log in start a voice or video call. 
  I was trying to download the hangouts for desktop application, it apparently does not exist.  got sent to google voice and video setup program when I clicked on it. 
  I need to sign up with google before I can use hangouts. 
  I have the google voice and video program zipped to gvavs.zip and uploaded to send space if any one wants it for fire fox.  The password is google and the link is below:
 
gvavs.zip
 
  Pete 
 


Re: attempting to instal the google hangouts plugin to firefox

Kevin Chao
 



On Sun, Mar 27, 2016 at 2:39 PM Nimer Jaber <nimerjaber1@...> wrote:
Hello,

While I have been able to get hangouts.google.com to work for making a video call, I haven't been able to get any of the shortcut keys to work
Are you in focus mode?
 
as are described in https://support.google.com/hangouts/answer/3112005?rd=1 and I'm not really sure where these shortcuts are supposed to work. They interfere with browser-specific hotkeys.
Which ones conflict?
 
If they are supposed to work in the Hangouts Chrome app, that app doesn't seem to be accessible with NVDA.
I've use them in Hangouts integrated in GMail.com and hangouts.google.com 


On 3/27/2016 4:29 PM, Governor staten wrote:

Thanks for that note, as it is something I should have mentioned.




On 3/27/2016 5:09 PM, Kevin Chao wrote:
Note:
This seems to be specific to Firefox, as Governor was able to make a Hangouts video call to me using Internet Explorer. The plugin also installs fine with Chrome and Safari. 

On Sun, Mar 27, 2016 at 1:37 PM Governor staten <govsta@...> wrote:
I"ve tried to do this multiple times. It doesn't seem to work. How do I
know this, you ask? I try to make a video call, and it keeps tkaing me
to the plugin install page. I install it, and it sits there saying it
needs to be verified.


While I"m at it, it appears Webvisum is now disabled. I can't remember
why they say it is. I"m running the latest version of Firefox. Any help,
ideas, or whatever would be welcome.
Thanks in advance.











Re: suggestion: giving google chrome a try Performance degradation in current Firefox

Kevin Chao
 



On Sun, Mar 27, 2016 at 2:37 PM Nimer Jaber <nimerjaber1@...> wrote:
Unfortunately, Chrome accessibility has a bit of a ways to go. I wish it didn't. I wish I could reliably use Chrome without the strangeness that persists, but I can't. With Canary, some menu items are not read out by NVDA,
Which menu items specifically? Could you provide a couple of examples? 
 
but are by Chromevox. Others are read out by NVDA and not by Chromevox. I don't want two screen reading packages running. When navigating the web and going to a new web page, I seem to have to push tab after a new page loads, otherwise NVDA doesn't seem to see the content on the page.
Is this with *any* page or *specific ones? 
 
When doing a search on the Google page and when navigating around Chrome in general, pressing H to navigate by heading only works sometimes, but sometimes locks up
Is there a pattern to when this occurs?
 
until I again press tab to force it to get back to the content. The sign-in process in Chrome does not work with NVDA. I needed to use Window-eyes to get it to read the content. JAWS was also unable to read it. And I will post another thread about this, but Hangouts doesn't work very well. the Hangouts app seems to be totally inaccessible to next branches of NVDA and Canary.
Was the Hangouts app accessible in NVDA release and Chrome stable? I use the Hangouts integrated in Gmail.
 
And the keyboard shortcuts that Google outlines in their manual at https://support.google.com/hangouts/answer/3112005?rd=1 don't work when navigating to hangouts.google.com, and the article doesn't specify where exactly these shortcuts are supposed to work.
There are different sets of keyboard shortcuts on that page: ones for while in a video call and others for when chatting. 
 
Actually many hotkeys that Google outlines interfere with browser-specific hotkeys.
Which ones conflict? Q to search for chat, H > C to go to conversation list, Esc to focus chat window, etc. work for Hangout/screen readers. 
 
So I would be happy to transition to using Chrome, as Firefox is becoming awful, but that would mean a huge loss of productivity for me.
I'm hoping to have a better understanding of these pain points, so bugs could be filed, and feedback could be provided to Chrome/Hangouts accessibility...
 
So if you have been able to get Chrome to work more reliably, I am interested in which version of Chrome and which version of NVDA, as well as any settings changes that you have made for your specific set-up. If this is localized to just me, I am willing to do some troubleshooting, but on three computers Chrome's behavior seems to be the same. About the only improvement I have seen to Chrome Canary is that NVDA reads out a few additional menu items that it wasn't reading before. I might try resetting Chrome back to default settings and removing all plugins to see if that has any effect, but this installation of Chrome is pretty new, so I'm not sure if that will help or not.
This is an excellent message that covers lots of areas in detail, so thanks for it! Hope to continue the conversation! :)

Thanks.


On 3/27/2016 4:05 PM, Scott VanDeWalle wrote:
Hey.
I've been using chrome now for a couple of weeks now i believe.
It is pretty good for the most part.
hth

Scott

On 3/27/2016 9:20 AM, Peter Beasley wrote:
My problem with Firefox is that I am no longer able to use the BBC iplayer. Every time I try to listen to something, I get a message telling me that the Adobe flash plugin has crashed. This particular plugin is up to date and I have been having this problem since early December. I know this is not anNVDA issue but would be greatful if anyone has any ideas on how I can sort this out. I have been using Firefox as my primary browser now for nearly 9 and a half years. 
 
From: mk360
Sent: Sunday, March 27, 2016 1:31 PM
Subject: Re: [nvda] Performance degradation in current Firefox
 
I've in firefox 45.0.1 and all is working fine.

El 27-03-2016 a las 8:46, Mr. Wong Chi Wai, William escribió:
I see no problem with NVDA. I recommend you go onto google and search for about:config that can help improve firefox performace and that pretty helps.


Kevin Chao 於 27/3/2016 10:13 寫道:
One of Chrome's strengths is performance...I experience 0% lag with MVDA when interacting with modern web apps.
On Sat, Mar 26, 2016 at 5:11 PM Supanut Leepaisomboon <supanut2000@...> wrote:
I noticed performance issues with Firefox as well, but not just with NVDA, but Jaws as well, especially on Facebook where the browser lags. Firefox seemed to perform poorly on my Surface 3, despite not having any addons installed.





Re: Saving application settings

sarabrennan@...
 

Thank you!!


Re: attempting to instal the google hangouts plugin to firefox

Nimer Jaber
 

Hello,

While I have been able to get hangouts.google.com to work for making a video call, I haven't been able to get any of the shortcut keys to work as are described in https://support.google.com/hangouts/answer/3112005?rd=1 and I'm not really sure where these shortcuts are supposed to work. They interfere with browser-specific hotkeys. If they are supposed to work in the Hangouts Chrome app, that app doesn't seem to be accessible with NVDA.

On 3/27/2016 4:29 PM, Governor staten wrote:

Thanks for that note, as it is something I should have mentioned.




On 3/27/2016 5:09 PM, Kevin Chao wrote:
Note:
This seems to be specific to Firefox, as Governor was able to make a Hangouts video call to me using Internet Explorer. The plugin also installs fine with Chrome and Safari. 

On Sun, Mar 27, 2016 at 1:37 PM Governor staten <govsta@...> wrote:
I"ve tried to do this multiple times. It doesn't seem to work. How do I
know this, you ask? I try to make a video call, and it keeps tkaing me
to the plugin install page. I install it, and it sits there saying it
needs to be verified.


While I"m at it, it appears Webvisum is now disabled. I can't remember
why they say it is. I"m running the latest version of Firefox. Any help,
ideas, or whatever would be welcome.
Thanks in advance.











Re: suggestion: giving google chrome a try Performance degradation in current Firefox

Nimer Jaber
 

Unfortunately, Chrome accessibility has a bit of a ways to go. I wish it didn't. I wish I could reliably use Chrome without the strangeness that persists, but I can't. With Canary, some menu items are not read out by NVDA, but are by Chromevox. Others are read out by NVDA and not by Chromevox. I don't want two screen reading packages running. When navigating the web and going to a new web page, I seem to have to push tab after a new page loads, otherwise NVDA doesn't seem to see the content on the page. When doing a search on the Google page and when navigating around Chrome in general, pressing H to navigate by heading only works sometimes, but sometimes locks up until I again press tab to force it to get back to the content. The sign-in process in Chrome does not work with NVDA. I needed to use Window-eyes to get it to read the content. JAWS was also unable to read it. And I will post another thread about this, but Hangouts doesn't work very well. the Hangouts app seems to be totally inaccessible to next branches of NVDA and Canary. And the keyboard shortcuts that Google outlines in their manual at https://support.google.com/hangouts/answer/3112005?rd=1 don't work when navigating to hangouts.google.com, and the article doesn't specify where exactly these shortcuts are supposed to work. Actually many hotkeys that Google outlines interfere with browser-specific hotkeys. So I would be happy to transition to using Chrome, as Firefox is becoming awful, but that would mean a huge loss of productivity for me. So if you have been able to get Chrome to work more reliably, I am interested in which version of Chrome and which version of NVDA, as well as any settings changes that you have made for your specific set-up. If this is localized to just me, I am willing to do some troubleshooting, but on three computers Chrome's behavior seems to be the same. About the only improvement I have seen to Chrome Canary is that NVDA reads out a few additional menu items that it wasn't reading before. I might try resetting Chrome back to default settings and removing all plugins to see if that has any effect, but this installation of Chrome is pretty new, so I'm not sure if that will help or not.

Thanks.

On 3/27/2016 4:05 PM, Scott VanDeWalle wrote:
Hey.
I've been using chrome now for a couple of weeks now i believe.
It is pretty good for the most part.
hth

Scott

On 3/27/2016 9:20 AM, Peter Beasley wrote:
My problem with Firefox is that I am no longer able to use the BBC iplayer. Every time I try to listen to something, I get a message telling me that the Adobe flash plugin has crashed. This particular plugin is up to date and I have been having this problem since early December. I know this is not anNVDA issue but would be greatful if anyone has any ideas on how I can sort this out. I have been using Firefox as my primary browser now for nearly 9 and a half years. 
 
From: mk360
Sent: Sunday, March 27, 2016 1:31 PM
Subject: Re: [nvda] Performance degradation in current Firefox
 
I've in firefox 45.0.1 and all is working fine.

El 27-03-2016 a las 8:46, Mr. Wong Chi Wai, William escribió:
I see no problem with NVDA. I recommend you go onto google and search for about:config that can help improve firefox performace and that pretty helps.


Kevin Chao 於 27/3/2016 10:13 寫道:
One of Chrome's strengths is performance...I experience 0% lag with MVDA when interacting with modern web apps.
On Sat, Mar 26, 2016 at 5:11 PM Supanut Leepaisomboon <supanut2000@...> wrote:
I noticed performance issues with Firefox as well, but not just with NVDA, but Jaws as well, especially on Facebook where the browser lags. Firefox seemed to perform poorly on my Surface 3, despite not having any addons installed.





Re: Suggestion for upcoming NVDA build

Christopher-Mark Gilland <clgilland07@...>
 

I don't think the snapshot will update itself, no. It'll still ask if you wish to carry the update through. It's not gonna do anything without your intervention.
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.

clgilland07@gmail.com
Phone: (704) 256-8010 Extension 401.

----- Original Message -----
From: "Pete" <emac00@cogeco.ca>
To: <nvda@groups.io>
Sent: Sunday, March 27, 2016 5:06 PM
Subject: Re: [nvda] Suggestion for upcoming NVDA build



Hi Joseph
1. Correct me if I am wrong.
If I have nvda snapshot latest installed now, then say 4 or five days go by and a new snapshot is released the nvda snapshot I am currently using will update to the newer snapshot.
2. I was thinking about moving the donate item into the help about page from help menu.
Pete
On 3/27/2016 3:44 PM, Joseph Lee wrote:
Hi,
1. Yes, each branch knows which update branch to use.
2. No, I'm in favor of keeping it (and this is useful as a good reminder as to how nVDA funding works and to state the fact that NV Access relies on grants and donations).
Cheers,
Joseph

-----Original Message-----
From: Pete [mailto:emac00@cogeco.ca]
Sent: Sunday, March 27, 2016 12:19 PM
To: nvda@groups.io
Subject: Re: [nvda] Suggestion for upcoming NVDA build


Hi Joseph
Are you saying each branch updates itself from it's own branch?
A second question is can the donate menu item be removed from nvda's menu?
Pete
On 3/27/2016 2:13 PM, Joseph Lee wrote:
Hi everyone,
Let me give you a "backstage tour" regarding this issue and why the suggestion will not be implemented:
As you may know by now, NV Access produces at least three branches: rc (release candidate), master, and next. The rc branch is where the stable (and official) releases happen, master is perpetual beta, and next is alpha-level code (bleeding-edge). For those using Chrome (or are reading the Chrome thread) may have noticed a similar pattern: Canary is equivalent to NVDA next (alpha-level code and is built nightly), dev and beta are equivalent to NVDA master, and the release that gets used by many users is equivalent to NVDA stable build.
Sometimes, NV Access or others may produce other snapshots. In the past, NV Access was known for producing snapshots from branches that required public testing (such as feedback when entering Asian characters). At one point, I have produced third-party snapshots, ranging from Windows 10 support, support for newer processor instructions, initial support for Outlook Calendar, and most recently, UEB tests (my snapshots, unlike those of NV Access, does not support updates).
When we produce snapshots, we assume the following:
* Many people are using stable builds.
* Using a snapshot means more bugs.
* When users are installing snapshots, they do so either because they are adventurous or would like to test upcoming features.
Regarding the last point, in order to move from stable build to development branches and vice versa, you need to download and install the desired build in question. This is because of the following:
* NVDA keeps a record of the branch it should query when connecting to NV Access server to retrieve updates. You can "fool" NVDA to download a different snapshot via code, but it won't work (this record is constant and will revert back to its original string once NVDA restarts).
* When NVDA checks for updates, it'll check the branch in question, and will present the update prompt if the version you've got is different than that of the one hosted on the server.
* Unless silenced, NVDA will check for updates every 24 hours.
Thus, when "changing" branches, you need to do this willingly. Because snapshots are reserved for a specific audience (although stable build users could try them out), the user interface for specifying branches will not be implemented.
Cheers,
Joseph

-----Original Message-----
From: Pete [mailto:emac00@cogeco.ca]
Sent: Sunday, March 27, 2016 8:14 AM
To: nvda@groups.io
Subject: Re: [nvda] Suggestion for upcoming NVDA build


Snapshot users use snapshots.
Main branch users use main versions.
This doesn't require the main branch to be modified and instead targets the wanted modification users, snapshot users with the update to snapshots witch is what they want rite?
The normal update channel will stil be there in the snapshot version so if a snapshot user wants to update to a main version she or he can do so if desired.
People using snapshots are more likely to upgrade snapshots.
Why clutter up nvda main with extra options they may, no more than likely use?
Having said all that, the option to update to snapshot versions in the main branchbrantch would keep the code consistant between main and snapshot.
if a snapshot user upgrades to a main version they would loose upgrade to snapshot version, so may be better to modifie the main branch.
Keeping the snapshot and main versions separate makes more sense.
It is less confusing for
snapshot users to update to snapshot version updates
and
main version users update to main version updates
respectively and exclusively.

Pete


On 3/27/2016 10:04 AM, Lenron wrote:
You should just have the option in the main version if you wish to
update to a snap shot or not. I normally love grabbing the next build
as soon as I can.

On 3/27/16, Pete <emac00@cogeco.ca> wrote:
Hi Chris
What I am talking about is the snap shot versions of nvda check
for snap shot updates them selves.
In that way the normal nvda dist users could just go on using
the normal nvda dist with out worrying if it will update to a snap shot.
Pete



On 3/26/2016 6:41 PM, Christopher-Mark Gilland wrote:
Well, when on a snapshot, it actually does notify you of updates at
this point. Not sure when the last time was you tried.
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.

clgilland07@gmail.com
Phone: (704) 256-8010 Extension 401.
----- Original Message ----- From: "Alexander Masic"
<list@masic.se>
To: <nvda@groups.io>
Sent: Saturday, March 26, 2016 9:03 AM
Subject: Re: [nvda] Suggestion for upcoming NVDA build


Personaly i think it could be an good idea. I think many like me
often forgot to check for updates even for snapshot, so at least
some kind of notification would be apresiated.



Den 2016-03-26 kl. 13:54, skrev Kevin Cussick via Groups.io:
no this is not a good idea, a newbey might try this feature that
you want and download a snap and it might have problems then threw
word of mouth nvda gets a bad reputation, this was asked for some
years ago and the devs gave this explanation of why it was a bad
idea I agree with them.

On 26/03/2016 03:51, Christopher-Mark Gilland wrote:
I was just thinking how cool of a feature this would be, and I'd
not think it would be terribly hard either to implement.
How hard would it be from the official build, like in this case,
2016.1, to put an option in the NVDA menu, maybe under Tools,
that automatically like downloading updates would let the user
download and install the latest snapshot build rather than them
having to go out to the web site and manually get it. Either
that, or maybe under the General tab of preferences, where you
have the box to check or uncheck for checking for updates, maybe
have another one that says download snapshot builds when
updating.
What do you all think?
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.
clgilland07@gmail.com <mailto:clgilland07@gmail.com>
Phone: (704) 256-8010 Extension 401.










Re: Suggestion for upcoming NVDA build

Christopher-Mark Gilland <clgilland07@...>
 

I wouldn't remove the donate menu. I think it's a great thing to have. Though I confess I've not donated as of yet, it is something that I am incredibly seriously considering doing.
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.

clgilland07@gmail.com
Phone: (704) 256-8010 Extension 401.

----- Original Message -----
From: "Pete" <emac00@cogeco.ca>
To: <nvda@groups.io>
Sent: Sunday, March 27, 2016 3:18 PM
Subject: Re: [nvda] Suggestion for upcoming NVDA build



Hi Joseph
Are you saying each branch updates itself from it's own branch?
A second question is can the donate menu item be removed from nvda's menu?
Pete
On 3/27/2016 2:13 PM, Joseph Lee wrote:
Hi everyone,
Let me give you a "backstage tour" regarding this issue and why the suggestion will not be implemented:
As you may know by now, NV Access produces at least three branches: rc (release candidate), master, and next. The rc branch is where the stable (and official) releases happen, master is perpetual beta, and next is alpha-level code (bleeding-edge). For those using Chrome (or are reading the Chrome thread) may have noticed a similar pattern: Canary is equivalent to NVDA next (alpha-level code and is built nightly), dev and beta are equivalent to NVDA master, and the release that gets used by many users is equivalent to NVDA stable build.
Sometimes, NV Access or others may produce other snapshots. In the past, NV Access was known for producing snapshots from branches that required public testing (such as feedback when entering Asian characters). At one point, I have produced third-party snapshots, ranging from Windows 10 support, support for newer processor instructions, initial support for Outlook Calendar, and most recently, UEB tests (my snapshots, unlike those of NV Access, does not support updates).
When we produce snapshots, we assume the following:
* Many people are using stable builds.
* Using a snapshot means more bugs.
* When users are installing snapshots, they do so either because they are adventurous or would like to test upcoming features.
Regarding the last point, in order to move from stable build to development branches and vice versa, you need to download and install the desired build in question. This is because of the following:
* NVDA keeps a record of the branch it should query when connecting to NV Access server to retrieve updates. You can "fool" NVDA to download a different snapshot via code, but it won't work (this record is constant and will revert back to its original string once NVDA restarts).
* When NVDA checks for updates, it'll check the branch in question, and will present the update prompt if the version you've got is different than that of the one hosted on the server.
* Unless silenced, NVDA will check for updates every 24 hours.
Thus, when "changing" branches, you need to do this willingly. Because snapshots are reserved for a specific audience (although stable build users could try them out), the user interface for specifying branches will not be implemented.
Cheers,
Joseph

-----Original Message-----
From: Pete [mailto:emac00@cogeco.ca]
Sent: Sunday, March 27, 2016 8:14 AM
To: nvda@groups.io
Subject: Re: [nvda] Suggestion for upcoming NVDA build


Snapshot users use snapshots.
Main branch users use main versions.
This doesn't require the main branch to be modified and instead targets the wanted modification users, snapshot users with the update to snapshots witch is what they want rite?
The normal update channel will stil be there in the snapshot version so if a snapshot user wants to update to a main version she or he can do so if desired.
People using snapshots are more likely to upgrade snapshots.
Why clutter up nvda main with extra options they may, no more than likely use?
Having said all that, the option to update to snapshot versions in the main branchbrantch would keep the code consistant between main and snapshot.
if a snapshot user upgrades to a main version they would loose upgrade to snapshot version, so may be better to modifie the main branch.
Keeping the snapshot and main versions separate makes more sense.
It is less confusing for
snapshot users to update to snapshot version updates
and
main version users update to main version updates
respectively and exclusively.

Pete


On 3/27/2016 10:04 AM, Lenron wrote:
You should just have the option in the main version if you wish to
update to a snap shot or not. I normally love grabbing the next build
as soon as I can.

On 3/27/16, Pete <emac00@cogeco.ca> wrote:
Hi Chris
What I am talking about is the snap shot versions of nvda check for
snap shot updates them selves.
In that way the normal nvda dist users could just go on using the
normal nvda dist with out worrying if it will update to a snap shot.
Pete



On 3/26/2016 6:41 PM, Christopher-Mark Gilland wrote:
Well, when on a snapshot, it actually does notify you of updates at
this point. Not sure when the last time was you tried.
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.

clgilland07@gmail.com
Phone: (704) 256-8010 Extension 401.
----- Original Message ----- From: "Alexander Masic" <list@masic.se>
To: <nvda@groups.io>
Sent: Saturday, March 26, 2016 9:03 AM
Subject: Re: [nvda] Suggestion for upcoming NVDA build


Personaly i think it could be an good idea. I think many like me
often forgot to check for updates even for snapshot, so at least some
kind of notification would be apresiated.



Den 2016-03-26 kl. 13:54, skrev Kevin Cussick via Groups.io:
no this is not a good idea, a newbey might try this feature that
you want and download a snap and it might have problems then threw
word of mouth nvda gets a bad reputation, this was asked for some
years ago and the devs gave this explanation of why it was a bad
idea I agree with them.

On 26/03/2016 03:51, Christopher-Mark Gilland wrote:
I was just thinking how cool of a feature this would be, and I'd not
think it would be terribly hard either to implement.
How hard would it be from the official build, like in this case,
2016.1,
to put an option in the NVDA menu, maybe under Tools, that
automatically
like downloading updates would let the user download and install the
latest snapshot build rather than them having to go out to the web
site
and manually get it. Either that, or maybe under the General tab of
preferences, where you have the box to check or uncheck for
checking for
updates, maybe have another one that says download snapshot builds
when
updating.
What do you all think?
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.
clgilland07@gmail.com <mailto:clgilland07@gmail.com>
Phone: (704) 256-8010 Extension 401.








Re: Suggestion for upcoming NVDA build

Christopher-Mark Gilland <clgilland07@...>
 

Oh yeah, I didn't mean remove the update option to a normal build. I was just simply meaning to add the option to update to a snapshot from within the app if desired. In no way was I suggesting to remove the ability to update to the next official non snapshop build. I agree. That would be a very stupid thing to do.
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.

clgilland07@gmail.com
Phone: (704) 256-8010 Extension 401.

----- Original Message -----
From: "Pete" <emac00@cogeco.ca>
To: <nvda@groups.io>
Sent: Sunday, March 27, 2016 11:13 AM
Subject: Re: [nvda] Suggestion for upcoming NVDA build



Snapshot users use snapshots.
Main branch users use main versions.
This doesn't require the main branch to be modified and instead targets the wanted modification users, snapshot users with the update to snapshots witch is what they want rite?
The normal update channel will stil be there in the snapshot version so if a snapshot user wants to update to a main version she or he can do so if desired.
People using snapshots are more likely to upgrade snapshots.
Why clutter up nvda main with extra options they may, no more than likely use?
Having said all that, the option to update to snapshot versions in the main branchbrantch would keep the code consistant between main and snapshot.
if a snapshot user upgrades to a main version they would loose upgrade to snapshot version, so may be better to modifie the main branch.
Keeping the snapshot and main versions separate makes more sense.
It is less confusing for
snapshot users to update to snapshot version updates
and
main version users update to main version updates
respectively and exclusively.

Pete


On 3/27/2016 10:04 AM, Lenron wrote:
You should just have the option in the main version if you wish to
update to a snap shot or not. I normally love grabbing the next build
as soon as I can.

On 3/27/16, Pete <emac00@cogeco.ca> wrote:
Hi Chris
What I am talking about is the snap shot versions of nvda check for
snap shot updates them selves.
In that way the normal nvda dist users could just go on using the
normal nvda dist with out worrying if it will update to a snap shot.
Pete



On 3/26/2016 6:41 PM, Christopher-Mark Gilland wrote:
Well, when on a snapshot, it actually does notify you of updates at
this point. Not sure when the last time was you tried.
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.

clgilland07@gmail.com
Phone: (704) 256-8010 Extension 401.
----- Original Message ----- From: "Alexander Masic" <list@masic.se>
To: <nvda@groups.io>
Sent: Saturday, March 26, 2016 9:03 AM
Subject: Re: [nvda] Suggestion for upcoming NVDA build


Personaly i think it could be an good idea. I think many like me
often forgot to check for updates even for snapshot, so at least some
kind of notification would be apresiated.



Den 2016-03-26 kl. 13:54, skrev Kevin Cussick via Groups.io:
no this is not a good idea, a newbey might try this feature that
you want and download a snap and it might have problems then threw
word of mouth nvda gets a bad reputation, this was asked for some
years ago and the devs gave this explanation of why it was a bad
idea I agree with them.

On 26/03/2016 03:51, Christopher-Mark Gilland wrote:
I was just thinking how cool of a feature this would be, and I'd not
think it would be terribly hard either to implement.
How hard would it be from the official build, like in this case,
2016.1,
to put an option in the NVDA menu, maybe under Tools, that
automatically
like downloading updates would let the user download and install the
latest snapshot build rather than them having to go out to the web
site
and manually get it. Either that, or maybe under the General tab of
preferences, where you have the box to check or uncheck for
checking for
updates, maybe have another one that says download snapshot builds
when
updating.
What do you all think?
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.
clgilland07@gmail.com <mailto:clgilland07@gmail.com>
Phone: (704) 256-8010 Extension 401.







Re: attempting to instal the google hangouts plugin to firefox

 

Thanks for that note, as it is something I should have mentioned.




On 3/27/2016 5:09 PM, Kevin Chao wrote:
Note:
This seems to be specific to Firefox, as Governor was able to make a Hangouts video call to me using Internet Explorer. The plugin also installs fine with Chrome and Safari. 

On Sun, Mar 27, 2016 at 1:37 PM Governor staten <govsta@...> wrote:
I"ve tried to do this multiple times. It doesn't seem to work. How do I
know this, you ask? I try to make a video call, and it keeps tkaing me
to the plugin install page. I install it, and it sits there saying it
needs to be verified.


While I"m at it, it appears Webvisum is now disabled. I can't remember
why they say it is. I"m running the latest version of Firefox. Any help,
ideas, or whatever would be welcome.
Thanks in advance.










Re: danger, danger nvda

Pete <emac00@...>
 

Hi
There lots of distributions, easiest one I found was vinux, up to 5.0 now.
I was reading about wine. I wanted to put together a small linux system I could run nvda and the windows command prompt in to run some simple windows programs. Installing and configuring especially with dependencies missing and no list of dependencys listed say in a text file in the source tar ball discouraged me on the project. I like the gentoo boot cd-rom. It uses speakup with software synth. I don't care for Z shell would rather use bash or even ash.
I would still like to do nvda running on a linux system using wine!
I would welcome any help in this endeavor.
Thanks!
Pete

On 3/27/2016 2:20 PM, Shaun Everiss wrote:
Hmmm.
Well I havn't touched linux for a while.
When I went to school it was fedora 4 or was it 3 I forget.
I had an old synth then, the sound stuff started after school.
I fiddled with grml for a bit, then ran vinux 3 then ubuntu shell.
I fiddled with arch while I was sick but never got it working again and due to my system I used it for not being active for a while its stopped working I guess my time is out of date.
My plan is to use sonar but to be honest linux is a hobby for me.
I am a primarily windows user, and so is just about everyone on the network both remote and local so right now I don't use linux.
Its been a fiddle here and there nothing serious.



On 28/03/2016 7:08 a.m., Pete wrote:

Hi Shaun

Multiple versions of dot net behave better. Some games wanted dot
net 2.0 to run and a t i and intel install managers use dot net 2.0. My
old x p computer had dot net 1.1 2.0 3.0 3.5 and 4.0 installed. I need
to figure out a way to capture the info for the visual c + + errors to
present them here. Not sure how to do this. Some of the v c messages
are in a dialog box but the latest things I am talking about I think are
in a balloon or some thing that disappears. The message was about
conflicting instances of some v c dot d l l being loaded.
What dist & ver of Linux are you using?
Pete


On 3/26/2016 12:36 AM, Shaun Everiss wrote:
Well, I have a multipul installs of dotnet from 3.5 to 4.6 here on 7
win10 has 5 and does not run other versions.
v3.5 works on v2, and v4 on v3 the latest dotnets should work as far
back as 2.
As for visual c, they shouldn't conflict as such because certain
programs need certain libraries.
Now, my only wish would be that windows does what linux does.
The libs don't take up that much space but even so.
I'd prefur say you install something or try to do something.\
Say I want to run x program but its missing y z dll.
Windows is unable to start this program because *.dll is not loaded
please reinstall.
To avoid this I load just about every library I can to stop that error.
It happens with codecs.
If I am using linux, I type in something to install, it says this
needs such and such component, do you want to install it or it tells
you what to do.
I have often installed programs for ssh and a few things on linux, and
got messages like this program is not installed, or this program is
part of another install for servers, or in deed, unable to start
because this thing is missing.
However in linux you can then install it because it basically tells
you what to install.
If ms would do the same at least with its libs then we wouldn't have
this issue better still with linux it tells you what is needed, what
could be nice, what is not but if you need it it would be nice or
simply whatever.
In windows, I have slim dx, java latest, klite codec, visual c 2005sp1
2008sp1 2010 2012 2013 2015 2016 and their 64 bit equivilants.
On the subject of python, both 3x and 2x are still supported 2.7x is
the version a lot of stuff uses however its a good point a lot of
stuff has moved on from the older releases.



On 26/03/2016 2:29 a.m., Pete wrote:

Hi
The proliferation of the famous Microsoft Visual C + + redistributable
packages is dangerous to nvva.
Windows loads multiple instances of the d l l s and not all instances
are the same version or even the correct version for a given program
causing untraceable bugs in nvda along with other programs like explorer
or the w10 file manager.
There doesn't seem to be backward compatibility say from visual c + +
2015 to earlier versions.
A second dangerous trend is the proliferation of multiple versions of
dot net frame work.
Again here no apparent backward compatibility seems to exists.
So one has his or her windows computer cluttered up with multiple
versions in most cases taking up hard drive real estate and causing
conflicts.
A lot of the nvda bugs possibly can be linked to miss matched
versions of d l l s being loaded by windows.
A third concern is the old version of python being used. If it's
time to upgrade from say visual c + + 2008 it should be time to update
to a newer version of python.
Shouldn't it?
Pete




.







Re: announcing empty lines can be annouing

Pete <emac00@...>
 

o k
LOL

On 3/27/2016 5:01 PM, Chris wrote:
laughing smiley :D
well jthats what nvda tells me anyway :D

cheers


On 27/03/2016 21:53, Pete wrote:

at the bottom I just have one blank line.
The equals equals equals and so on is realy
equals dash equals dash equals dash and so on.
If it's a solid line of equals with no spaces or other symbols I think nvda will say the character 3 to 5 times and then say how many are there.
What is the colon cap d after the five equals message?
Pete
On 3/27/2016 3:30 PM, Chris wrote:
go to bottom of this message and you see what i mean

just above the signature


On 27/03/2016 17:03, Andre Fisher wrote:
I don't understand what you are saying.
========== comes out as 10 = on my end.

On 3/26/16, Chris <chrismedley@btinternet.com> wrote:
and ===== can be equally annoying :D
why not say ten equals instead of repeating over and over :(


On 26/03/2016 11:26, Patrick Le Baudour wrote:
Hi,

I have found one way :
add an entry in the dictionnary, with input
^empty$
(assuming nvda tells you empty for empty lines) replaced by nothing.
Select regular expression as type.

The side effect would be that it probably not read any line, button or
any other object containing only the word empty. But so far I have
found no better way.

-- Patrick.

Le 25/03/2016 17:37, Davy Cuppens a écrit :
Hi folks
Last question before Easter,
When reading texts line per line, NVDA always announces empty line when
it encounters one.
Can this be set off?
Regards
Davy










Re: attempting to instal the google hangouts plugin to firefox

Kevin Chao
 

Note:
This seems to be specific to Firefox, as Governor was able to make a Hangouts video call to me using Internet Explorer. The plugin also installs fine with Chrome and Safari. 

On Sun, Mar 27, 2016 at 1:37 PM Governor staten <govsta@...> wrote:
I"ve tried to do this multiple times. It doesn't seem to work. How do I
know this, you ask? I try to make a video call, and it keeps tkaing me
to the plugin install page. I install it, and it sits there saying it
needs to be verified.


While I"m at it, it appears Webvisum is now disabled. I can't remember
why they say it is. I"m running the latest version of Firefox. Any help,
ideas, or whatever would be welcome.
Thanks in advance.









Re: Suggestion for upcoming NVDA build

Pete <emac00@...>
 

Hi Joseph
1. Correct me if I am wrong.
If I have nvda snapshot latest installed now, then say 4 or five days go by and a new snapshot is released the nvda snapshot I am currently using will update to the newer snapshot.
2. I was thinking about moving the donate item into the help about page from help menu.
Pete

On 3/27/2016 3:44 PM, Joseph Lee wrote:
Hi,
1. Yes, each branch knows which update branch to use.
2. No, I'm in favor of keeping it (and this is useful as a good reminder as to how nVDA funding works and to state the fact that NV Access relies on grants and donations).
Cheers,
Joseph

-----Original Message-----
From: Pete [mailto:emac00@cogeco.ca]
Sent: Sunday, March 27, 2016 12:19 PM
To: nvda@groups.io
Subject: Re: [nvda] Suggestion for upcoming NVDA build


Hi Joseph
Are you saying each branch updates itself from it's own branch?
A second question is can the donate menu item be removed from nvda's menu?
Pete
On 3/27/2016 2:13 PM, Joseph Lee wrote:
Hi everyone,
Let me give you a "backstage tour" regarding this issue and why the suggestion will not be implemented:
As you may know by now, NV Access produces at least three branches: rc (release candidate), master, and next. The rc branch is where the stable (and official) releases happen, master is perpetual beta, and next is alpha-level code (bleeding-edge). For those using Chrome (or are reading the Chrome thread) may have noticed a similar pattern: Canary is equivalent to NVDA next (alpha-level code and is built nightly), dev and beta are equivalent to NVDA master, and the release that gets used by many users is equivalent to NVDA stable build.
Sometimes, NV Access or others may produce other snapshots. In the past, NV Access was known for producing snapshots from branches that required public testing (such as feedback when entering Asian characters). At one point, I have produced third-party snapshots, ranging from Windows 10 support, support for newer processor instructions, initial support for Outlook Calendar, and most recently, UEB tests (my snapshots, unlike those of NV Access, does not support updates).
When we produce snapshots, we assume the following:
* Many people are using stable builds.
* Using a snapshot means more bugs.
* When users are installing snapshots, they do so either because they are adventurous or would like to test upcoming features.
Regarding the last point, in order to move from stable build to development branches and vice versa, you need to download and install the desired build in question. This is because of the following:
* NVDA keeps a record of the branch it should query when connecting to NV Access server to retrieve updates. You can "fool" NVDA to download a different snapshot via code, but it won't work (this record is constant and will revert back to its original string once NVDA restarts).
* When NVDA checks for updates, it'll check the branch in question, and will present the update prompt if the version you've got is different than that of the one hosted on the server.
* Unless silenced, NVDA will check for updates every 24 hours.
Thus, when "changing" branches, you need to do this willingly. Because snapshots are reserved for a specific audience (although stable build users could try them out), the user interface for specifying branches will not be implemented.
Cheers,
Joseph

-----Original Message-----
From: Pete [mailto:emac00@cogeco.ca]
Sent: Sunday, March 27, 2016 8:14 AM
To: nvda@groups.io
Subject: Re: [nvda] Suggestion for upcoming NVDA build


Snapshot users use snapshots.
Main branch users use main versions.
This doesn't require the main branch to be modified and instead targets the wanted modification users, snapshot users with the update to snapshots witch is what they want rite?
The normal update channel will stil be there in the snapshot version so if a snapshot user wants to update to a main version she or he can do so if desired.
People using snapshots are more likely to upgrade snapshots.
Why clutter up nvda main with extra options they may, no more than likely use?
Having said all that, the option to update to snapshot versions in the main branchbrantch would keep the code consistant between main and snapshot.
if a snapshot user upgrades to a main version they would loose upgrade to snapshot version, so may be better to modifie the main branch.
Keeping the snapshot and main versions separate makes more sense.
It is less confusing for
snapshot users to update to snapshot version updates
and
main version users update to main version updates
respectively and exclusively.

Pete


On 3/27/2016 10:04 AM, Lenron wrote:
You should just have the option in the main version if you wish to
update to a snap shot or not. I normally love grabbing the next build
as soon as I can.

On 3/27/16, Pete <emac00@cogeco.ca> wrote:
Hi Chris
What I am talking about is the snap shot versions of nvda check
for snap shot updates them selves.
In that way the normal nvda dist users could just go on using
the normal nvda dist with out worrying if it will update to a snap shot.
Pete



On 3/26/2016 6:41 PM, Christopher-Mark Gilland wrote:
Well, when on a snapshot, it actually does notify you of updates at
this point. Not sure when the last time was you tried.
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.

clgilland07@gmail.com
Phone: (704) 256-8010 Extension 401.
----- Original Message ----- From: "Alexander Masic"
<list@masic.se>
To: <nvda@groups.io>
Sent: Saturday, March 26, 2016 9:03 AM
Subject: Re: [nvda] Suggestion for upcoming NVDA build


Personaly i think it could be an good idea. I think many like me
often forgot to check for updates even for snapshot, so at least
some kind of notification would be apresiated.



Den 2016-03-26 kl. 13:54, skrev Kevin Cussick via Groups.io:
no this is not a good idea, a newbey might try this feature that
you want and download a snap and it might have problems then threw
word of mouth nvda gets a bad reputation, this was asked for some
years ago and the devs gave this explanation of why it was a bad
idea I agree with them.

On 26/03/2016 03:51, Christopher-Mark Gilland wrote:
I was just thinking how cool of a feature this would be, and I'd
not think it would be terribly hard either to implement.
How hard would it be from the official build, like in this case,
2016.1, to put an option in the NVDA menu, maybe under Tools,
that automatically like downloading updates would let the user
download and install the latest snapshot build rather than them
having to go out to the web site and manually get it. Either
that, or maybe under the General tab of preferences, where you
have the box to check or uncheck for checking for updates, maybe
have another one that says download snapshot builds when
updating.
What do you all think?
---
Christopher Gilland
JAWS Certified, 2016.
Training Instructor.
clgilland07@gmail.com <mailto:clgilland07@gmail.com>
Phone: (704) 256-8010 Extension 401.









Re: suggestion: giving google chrome a try Performance degradation in current Firefox

Scott VanDeWalle
 

Hey.
I've been using chrome now for a couple of weeks now i believe.
It is pretty good for the most part.
hth

Scott

On 3/27/2016 9:20 AM, Peter Beasley wrote:
My problem with Firefox is that I am no longer able to use the BBC iplayer. Every time I try to listen to something, I get a message telling me that the Adobe flash plugin has crashed. This particular plugin is up to date and I have been having this problem since early December. I know this is not anNVDA issue but would be greatful if anyone has any ideas on how I can sort this out. I have been using Firefox as my primary browser now for nearly 9 and a half years. 
 
From: mk360
Sent: Sunday, March 27, 2016 1:31 PM
Subject: Re: [nvda] Performance degradation in current Firefox
 
I've in firefox 45.0.1 and all is working fine.

El 27-03-2016 a las 8:46, Mr. Wong Chi Wai, William escribió:
I see no problem with NVDA. I recommend you go onto google and search for about:config that can help improve firefox performace and that pretty helps.


Kevin Chao 於 27/3/2016 10:13 寫道:
One of Chrome's strengths is performance...I experience 0% lag with MVDA when interacting with modern web apps.
On Sat, Mar 26, 2016 at 5:11 PM Supanut Leepaisomboon <supanut2000@...> wrote:
I noticed performance issues with Firefox as well, but not just with NVDA, but Jaws as well, especially on Facebook where the browser lags. Firefox seemed to perform poorly on my Surface 3, despite not having any addons installed.




Re: danger, danger nvda

Mallard
 

Very untrue!

Linux has hundreds of distros, of course, a bit like Android and its many versions and variants, dependent on manufacturers.

But there are quite a few distros made for the visually impaired, like Talking Arch (that's definitely a bit fiddly, from what I understand), SonarLinux (not fiddly), and Vinux (based on Ubuntu, and not fiddly at all).

Linux is becoming more and more accessible, although there are some programmes I can't find a match for yet.

Windows is definitely more blind-friendly, but all this fear of Linux within the blind community is unnecessary, and it's a pity that we should deprive ourselves of more choices.

I have two Linux installations on my pc, and I alternate them with my Windows 10.
Happily using Linux, although still in a limited way, because of my laziness more than its inaccessibility... lol

Have a go, guys, it's fun!
Ciao,
Ollie

Il 27/03/2016 22:26, Arlene ha scritto:
Oh, It sounds like Linux is very fiddly. I had a friend who was having a
friend fix her windows computer. He wanted to put it on her computer. But
she had to heavily convince him that it was not usable for blind people. I'm
glad you use it for a hobby. I don't know it. But if you like it use it as
your hobby. I thought it was an old old program that hardly nobody uses.

-----Original Message-----
From: Shaun Everiss [mailto:sm.everiss@gmail.com]
Sent: March-27-16 11:21 AM
To: nvda@groups.io
Subject: Re: [nvda] danger, danger nvda

Hmmm.
Well I havn't touched linux for a while.
When I went to school it was fedora 4 or was it 3 I forget.
I had an old synth then, the sound stuff started after school.
I fiddled with grml for a bit, then ran vinux 3 then ubuntu shell.
I fiddled with arch while I was sick but never got it working again and
due to my system I used it for not being active for a while its stopped
working I guess my time is out of date.
My plan is to use sonar but to be honest linux is a hobby for me.
I am a primarily windows user, and so is just about everyone on the
network both remote and local so right now I don't use linux.
Its been a fiddle here and there nothing serious.



On 28/03/2016 7:08 a.m., Pete wrote:
Hi Shaun

Multiple versions of dot net behave better. Some games wanted dot
net 2.0 to run and a t i and intel install managers use dot net 2.0. My
old x p computer had dot net 1.1 2.0 3.0 3.5 and 4.0 installed. I need
to figure out a way to capture the info for the visual c + + errors to
present them here. Not sure how to do this. Some of the v c messages
are in a dialog box but the latest things I am talking about I think are
in a balloon or some thing that disappears. The message was about
conflicting instances of some v c dot d l l being loaded.
What dist & ver of Linux are you using?
Pete


On 3/26/2016 12:36 AM, Shaun Everiss wrote:
Well, I have a multipul installs of dotnet from 3.5 to 4.6 here on 7
win10 has 5 and does not run other versions.
v3.5 works on v2, and v4 on v3 the latest dotnets should work as far
back as 2.
As for visual c, they shouldn't conflict as such because certain
programs need certain libraries.
Now, my only wish would be that windows does what linux does.
The libs don't take up that much space but even so.
I'd prefur say you install something or try to do something.\
Say I want to run x program but its missing y z dll.
Windows is unable to start this program because *.dll is not loaded
please reinstall.
To avoid this I load just about every library I can to stop that error.
It happens with codecs.
If I am using linux, I type in something to install, it says this
needs such and such component, do you want to install it or it tells
you what to do.
I have often installed programs for ssh and a few things on linux, and
got messages like this program is not installed, or this program is
part of another install for servers, or in deed, unable to start
because this thing is missing.
However in linux you can then install it because it basically tells
you what to install.
If ms would do the same at least with its libs then we wouldn't have
this issue better still with linux it tells you what is needed, what
could be nice, what is not but if you need it it would be nice or
simply whatever.
In windows, I have slim dx, java latest, klite codec, visual c 2005sp1
2008sp1 2010 2012 2013 2015 2016 and their 64 bit equivilants.
On the subject of python, both 3x and 2x are still supported 2.7x is
the version a lot of stuff uses however its a good point a lot of
stuff has moved on from the older releases.



On 26/03/2016 2:29 a.m., Pete wrote:
Hi
The proliferation of the famous Microsoft Visual C + + redistributable
packages is dangerous to nvva.
Windows loads multiple instances of the d l l s and not all instances
are the same version or even the correct version for a given program
causing untraceable bugs in nvda along with other programs like explorer
or the w10 file manager.
There doesn't seem to be backward compatibility say from visual c + +
2015 to earlier versions.
A second dangerous trend is the proliferation of multiple versions of
dot net frame work.
Again here no apparent backward compatibility seems to exists.
So one has his or her windows computer cluttered up with multiple
versions in most cases taking up hard drive real estate and causing
conflicts.
A lot of the nvda bugs possibly can be linked to miss matched
versions of d l l s being loaded by windows.
A third concern is the old version of python being used. If it's
time to upgrade from say visual c + + 2008 it should be time to update
to a newer version of python.
Shouldn't it?
Pete




.







Re: announcing empty lines can be annouing

Chris
 

laughing smiley :D
well jthats what nvda tells me anyway :D

cheers

On 27/03/2016 21:53, Pete wrote:

at the bottom I just have one blank line.
The equals equals equals and so on is realy
equals dash equals dash equals dash and so on.
If it's a solid line of equals with no spaces or other symbols I think nvda will say the character 3 to 5 times and then say how many are there.
What is the colon cap d after the five equals message?
Pete
On 3/27/2016 3:30 PM, Chris wrote:
go to bottom of this message and you see what i mean

just above the signature


On 27/03/2016 17:03, Andre Fisher wrote:
I don't understand what you are saying.
========== comes out as 10 = on my end.

On 3/26/16, Chris <chrismedley@btinternet.com> wrote:
and ===== can be equally annoying :D
why not say ten equals instead of repeating over and over :(


On 26/03/2016 11:26, Patrick Le Baudour wrote:
Hi,

I have found one way :
add an entry in the dictionnary, with input
^empty$
(assuming nvda tells you empty for empty lines) replaced by nothing.
Select regular expression as type.

The side effect would be that it probably not read any line, button or
any other object containing only the word empty. But so far I have
found no better way.

-- Patrick.

Le 25/03/2016 17:37, Davy Cuppens a écrit :
Hi folks
Last question before Easter,
When reading texts line per line, NVDA always announces empty line when
it encounters one.
Can this be set off?
Regards
Davy







Re: announcing empty lines can be annouing

Pete <emac00@...>
 

Here nvda says blank for empty lines.
Pete

On 3/27/2016 4:53 PM, Pete wrote:

at the bottom I just have one blank line.
The equals equals equals and so on is realy
equals dash equals dash equals dash and so on.
If it's a solid line of equals with no spaces or other symbols I think nvda will say the character 3 to 5 times and then say how many are there.
What is the colon cap d after the five equals message?
Pete
On 3/27/2016 3:30 PM, Chris wrote:
go to bottom of this message and you see what i mean

just above the signature


On 27/03/2016 17:03, Andre Fisher wrote:
I don't understand what you are saying.
========== comes out as 10 = on my end.

On 3/26/16, Chris <chrismedley@btinternet.com> wrote:
and ===== can be equally annoying :D
why not say ten equals instead of repeating over and over :(


On 26/03/2016 11:26, Patrick Le Baudour wrote:
Hi,

I have found one way :
add an entry in the dictionnary, with input
^empty$
(assuming nvda tells you empty for empty lines) replaced by nothing.
Select regular expression as type.

The side effect would be that it probably not read any line, button or
any other object containing only the word empty. But so far I have
found no better way.

-- Patrick.

Le 25/03/2016 17:37, Davy Cuppens a écrit :
Hi folks
Last question before Easter,
When reading texts line per line, NVDA always announces empty line when
it encounters one.
Can this be set off?
Regards
Davy