Date   

Re: NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

Sky Mundell
 

Hi Ralf. I totally agree with you. As an assistive technology instructor I can agree with what your saying. Not many folks are going to know where to find where to contact the offer if they don’t know how to do it. So I second your suggestion Ralf.

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Ralf Kefferpuetz
Sent: Sunday, December 15, 2019 12:49 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi,

 

It is very confusing or unclear how to contact the author of an addon. I know that from my 3 addons around. People don’t read the nanifest.ine to get the authors email or they just don’t know how to copy it and insert it in a new mail.

If we could have a button called “contact author” eiter in the addons management screen or/and on the addons page on Nvaccess.org it would be much easier for most users to contact the author.

It is easy for me, but that does not mean that it is easy for the community 😊

 

Cheers,

  Ralf

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Sonntag, 15. Dezember 2019 21:04
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi,

It’s really up to the author to tell you the answer at this time (sorry).

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of abdul muhamin
Sent: Sunday, December 15, 2019 11:54 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi, I’ve tried the addon on the beta version v2019.3, its incompatible, is there any other addon which can do the things like file reader?

 

Regards

Abdulmuhamin.

Chief content officer at

Blind Help Project

Contact me through the following!

On Facebook

On twitter

On skype

On WhatsApp

E-mail me at

A.Muhamin@...

Sent from Mail for Windows 10

 

From: Joseph Lee
Sent: Sunday, December 15, 2019 8:30 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi,

I’d leave it up to the author to ask for add-on review and registration. Once that’s done, someone from the community will review the add-on and suggest changes if any, and once the author say yes, it’ll be registered.

In case of File Reader (and for that matter, other add-on suggestions in 2020 and beyond), it must be compatible with at least NVDA 2019.3, both in code and add-on manifest. Even if the source code is compatible but manifest information is not, it cannot be registered on community add-ons website.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of abdul muhamin
Sent: Sunday, December 15, 2019 2:44 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Hi joseph, its really a good news that we are getting the 2019.3 very soon, and much of the addons are compatible, I want to ask, there is an addon called file reader by oriel Goma’s, is there any chance for this addon to be register on the community addons site, and be compatible for the latest version of NVDA? If you don’t know about the addon, let me know, I can provide the link for this, its currently working on NVDA2019.2.1, thanks

 

Regards

Abdulmuhamin.

Chief content officer at

Blind Help Project

Contact me through the following!

On Facebook

On twitter

On skype

On WhatsApp

E-mail me at

A.Muhamin@...

Sent from Mail for Windows 10

 

From: Joseph Lee
Sent: Saturday, December 14, 2019 10:01 AM
To: nvda-devel@groups.io
Subject: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Dear NVDA community,

 

A few days ago NVDA 2019.3 beta was released, marking the milestone on our journey toward letting everyone meet NVDA 2019.3 soon. Along with this milestone, I’m delighted to announce that add-ons community is seeing uptake in getting add-ons ready for NVDA 2019.3, including announcements from speech synthesizer vendors such as Code Factory releasing updated versions of synthesizer add-ons. In addition, more add-ons listed on community add-ons website is preparing themselves for NVDA 2019.3.

 

Regarding which add-ons are compatible with NVDA 2019.3 as of December 14, 2019:

 

  • Out of 69 add-ons registered on community add-ons website, two-thirds (46) are compatible, with 12 add-ons marked as incompatible. Others are being worked on, planned to be ported, or add-on features are now part of NVDA as of 2019.3 (specifically, Focus Highlight and Enhanced Aria features are now part of NVDA 2019.3). Including add-ons being worked on (under development and testing), the number of compatible add-ons rises to 54 (78%).
  • Notable add-ons with status changes include Clipspeak, Audio Themes, Braille Extender, Clip Contents Designer, Emoticons, Place Markers, and Report Symbols. Most of these are going through development snapshot testing at the moment, and Braille Extender and Clipspeak are declared compatible. For Audio Themes fans, version 6.0 beta is available for testing.
  • And no, NVDA Remote is still incompatible, although one of the authors said he is looking into making it ready for 2019.3 and sent a word about it and asked for help from NV Access.

 

The next status update (hopefully with changes) will be sent just before Christmas. As always, you can view latest compatibility list at:

https://addons.nvda-project.org/addons/nvdapy3.en.html

 

Cheers,

Joseph

 

 


Re: NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

Ralf Kefferpuetz
 

Hi,

 

It is very confusing or unclear how to contact the author of an addon. I know that from my 3 addons around. People don’t read the nanifest.ine to get the authors email or they just don’t know how to copy it and insert it in a new mail.

If we could have a button called “contact author” eiter in the addons management screen or/and on the addons page on Nvaccess.org it would be much easier for most users to contact the author.

It is easy for me, but that does not mean that it is easy for the community 😊

 

Cheers,

  Ralf

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Sonntag, 15. Dezember 2019 21:04
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi,

It’s really up to the author to tell you the answer at this time (sorry).

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of abdul muhamin
Sent: Sunday, December 15, 2019 11:54 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi, I’ve tried the addon on the beta version v2019.3, its incompatible, is there any other addon which can do the things like file reader?

 

Regards

Abdulmuhamin.

Chief content officer at

Blind Help Project

Contact me through the following!

On Facebook

On twitter

On skype

On WhatsApp

E-mail me at

A.Muhamin@...

Sent from Mail for Windows 10

 

From: Joseph Lee
Sent: Sunday, December 15, 2019 8:30 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi,

I’d leave it up to the author to ask for add-on review and registration. Once that’s done, someone from the community will review the add-on and suggest changes if any, and once the author say yes, it’ll be registered.

In case of File Reader (and for that matter, other add-on suggestions in 2020 and beyond), it must be compatible with at least NVDA 2019.3, both in code and add-on manifest. Even if the source code is compatible but manifest information is not, it cannot be registered on community add-ons website.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of abdul muhamin
Sent: Sunday, December 15, 2019 2:44 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Hi joseph, its really a good news that we are getting the 2019.3 very soon, and much of the addons are compatible, I want to ask, there is an addon called file reader by oriel Goma’s, is there any chance for this addon to be register on the community addons site, and be compatible for the latest version of NVDA? If you don’t know about the addon, let me know, I can provide the link for this, its currently working on NVDA2019.2.1, thanks

 

Regards

Abdulmuhamin.

Chief content officer at

Blind Help Project

Contact me through the following!

On Facebook

On twitter

On skype

On WhatsApp

E-mail me at

A.Muhamin@...

Sent from Mail for Windows 10

 

From: Joseph Lee
Sent: Saturday, December 14, 2019 10:01 AM
To: nvda-devel@groups.io
Subject: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Dear NVDA community,

 

A few days ago NVDA 2019.3 beta was released, marking the milestone on our journey toward letting everyone meet NVDA 2019.3 soon. Along with this milestone, I’m delighted to announce that add-ons community is seeing uptake in getting add-ons ready for NVDA 2019.3, including announcements from speech synthesizer vendors such as Code Factory releasing updated versions of synthesizer add-ons. In addition, more add-ons listed on community add-ons website is preparing themselves for NVDA 2019.3.

 

Regarding which add-ons are compatible with NVDA 2019.3 as of December 14, 2019:

 

  • Out of 69 add-ons registered on community add-ons website, two-thirds (46) are compatible, with 12 add-ons marked as incompatible. Others are being worked on, planned to be ported, or add-on features are now part of NVDA as of 2019.3 (specifically, Focus Highlight and Enhanced Aria features are now part of NVDA 2019.3). Including add-ons being worked on (under development and testing), the number of compatible add-ons rises to 54 (78%).
  • Notable add-ons with status changes include Clipspeak, Audio Themes, Braille Extender, Clip Contents Designer, Emoticons, Place Markers, and Report Symbols. Most of these are going through development snapshot testing at the moment, and Braille Extender and Clipspeak are declared compatible. For Audio Themes fans, version 6.0 beta is available for testing.
  • And no, NVDA Remote is still incompatible, although one of the authors said he is looking into making it ready for 2019.3 and sent a word about it and asked for help from NV Access.

 

The next status update (hopefully with changes) will be sent just before Christmas. As always, you can view latest compatibility list at:

https://addons.nvda-project.org/addons/nvdapy3.en.html

 

Cheers,

Joseph

 

 


Latest NVDA Alpha Snapshot and Add-on Updater

 

Hi. I'm posting this to a few lists since I'm not sure where it belongs. I'm using the latest alpha snapshot of NVDA, alpha-19441,855bf207, with Add-on Updater version 19.11, which I believe is also the latest version. For some reason, Add-on Updater doesn't seem to be working with this version for me. NVDA says it's enabled in the Add-ons Manager dialog, but I can't check for add-on updates or see the settings. NVDA also plays an error tone when it starts, and at least some of the errors in the log mention Add-on Updater. I'm attaching an NVDA log file I saved a couple days ago that I think shows the problem. Is anyone else having this problem? Thanks.

--

Lanie Molinar

Disability Rights Advocate and Software Engineering Student at Brigham Young University-Idaho

Connect with me on LinkedIn

Phone: 832-284-2426

Certified expert with general use of NVDA (Non Visual Desktop Access and use of it with Microsoft Word. Learn more here.

Do you have multiple disabilities or know someone who does? Please check out and share my blog on life with multiple disabilities. Click the "Available Groups" link to find support and advocacy groups for people with multiple disabilities.


Re: NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi,

It’s really up to the author to tell you the answer at this time (sorry).

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of abdul muhamin
Sent: Sunday, December 15, 2019 11:54 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi, I’ve tried the addon on the beta version v2019.3, its incompatible, is there any other addon which can do the things like file reader?

 

Regards

Abdulmuhamin.

Chief content officer at

Blind Help Project

Contact me through the following!

On Facebook

On twitter

On skype

On WhatsApp

E-mail me at

A.Muhamin@...

Sent from Mail for Windows 10

 

From: Joseph Lee
Sent: Sunday, December 15, 2019 8:30 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi,

I’d leave it up to the author to ask for add-on review and registration. Once that’s done, someone from the community will review the add-on and suggest changes if any, and once the author say yes, it’ll be registered.

In case of File Reader (and for that matter, other add-on suggestions in 2020 and beyond), it must be compatible with at least NVDA 2019.3, both in code and add-on manifest. Even if the source code is compatible but manifest information is not, it cannot be registered on community add-ons website.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of abdul muhamin
Sent: Sunday, December 15, 2019 2:44 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Hi joseph, its really a good news that we are getting the 2019.3 very soon, and much of the addons are compatible, I want to ask, there is an addon called file reader by oriel Goma’s, is there any chance for this addon to be register on the community addons site, and be compatible for the latest version of NVDA? If you don’t know about the addon, let me know, I can provide the link for this, its currently working on NVDA2019.2.1, thanks

 

Regards

Abdulmuhamin.

Chief content officer at

Blind Help Project

Contact me through the following!

On Facebook

On twitter

On skype

On WhatsApp

E-mail me at

A.Muhamin@...

Sent from Mail for Windows 10

 

From: Joseph Lee
Sent: Saturday, December 14, 2019 10:01 AM
To: nvda-devel@groups.io
Subject: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Dear NVDA community,

 

A few days ago NVDA 2019.3 beta was released, marking the milestone on our journey toward letting everyone meet NVDA 2019.3 soon. Along with this milestone, I’m delighted to announce that add-ons community is seeing uptake in getting add-ons ready for NVDA 2019.3, including announcements from speech synthesizer vendors such as Code Factory releasing updated versions of synthesizer add-ons. In addition, more add-ons listed on community add-ons website is preparing themselves for NVDA 2019.3.

 

Regarding which add-ons are compatible with NVDA 2019.3 as of December 14, 2019:

 

  • Out of 69 add-ons registered on community add-ons website, two-thirds (46) are compatible, with 12 add-ons marked as incompatible. Others are being worked on, planned to be ported, or add-on features are now part of NVDA as of 2019.3 (specifically, Focus Highlight and Enhanced Aria features are now part of NVDA 2019.3). Including add-ons being worked on (under development and testing), the number of compatible add-ons rises to 54 (78%).
  • Notable add-ons with status changes include Clipspeak, Audio Themes, Braille Extender, Clip Contents Designer, Emoticons, Place Markers, and Report Symbols. Most of these are going through development snapshot testing at the moment, and Braille Extender and Clipspeak are declared compatible. For Audio Themes fans, version 6.0 beta is available for testing.
  • And no, NVDA Remote is still incompatible, although one of the authors said he is looking into making it ready for 2019.3 and sent a word about it and asked for help from NV Access.

 

The next status update (hopefully with changes) will be sent just before Christmas. As always, you can view latest compatibility list at:

https://addons.nvda-project.org/addons/nvdapy3.en.html

 

Cheers,

Joseph

 

 


Re: NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

abdul muhamin
 

Hi, I’ve tried the addon on the beta version v2019.3, its incompatible, is there any other addon which can do the things like file reader?

 

Regards

Abdulmuhamin.

Chief content officer at

Blind Help Project

Contact me through the following!

On Facebook

On twitter

On skype

On WhatsApp

E-mail me at

A.Muhamin@...

Sent from Mail for Windows 10

 

From: Joseph Lee
Sent: Sunday, December 15, 2019 8:30 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019with2019.3 beta

 

Hi,

I’d leave it up to the author to ask for add-on review and registration. Once that’s done, someone from the community will review the add-on and suggest changes if any, and once the author say yes, it’ll be registered.

In case of File Reader (and for that matter, other add-on suggestions in 2020 and beyond), it must be compatible with at least NVDA 2019.3, both in code and add-on manifest. Even if the source code is compatible but manifest information is not, it cannot be registered on community add-ons website.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of abdul muhamin
Sent: Sunday, December 15, 2019 2:44 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Hi joseph, its really a good news that we are getting the 2019.3 very soon, and much of the addons are compatible, I want to ask, there is an addon called file reader by oriel Goma’s, is there any chance for this addon to be register on the community addons site, and be compatible for the latest version of NVDA? If you don’t know about the addon, let me know, I can provide the link for this, its currently working on NVDA2019.2.1, thanks

 

Regards

Abdulmuhamin.

Chief content officer at

Blind Help Project

Contact me through the following!

On Facebook

On twitter

On skype

On WhatsApp

E-mail me at

A.Muhamin@...

Sent from Mail for Windows 10

 

From: Joseph Lee
Sent: Saturday, December 14, 2019 10:01 AM
To: nvda-devel@groups.io
Subject: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Dear NVDA community,

 

A few days ago NVDA 2019.3 beta was released, marking the milestone on our journey toward letting everyone meet NVDA 2019.3 soon. Along with this milestone, I’m delighted to announce that add-ons community is seeing uptake in getting add-ons ready for NVDA 2019.3, including announcements from speech synthesizer vendors such as Code Factory releasing updated versions of synthesizer add-ons. In addition, more add-ons listed on community add-ons website is preparing themselves for NVDA 2019.3.

 

Regarding which add-ons are compatible with NVDA 2019.3 as of December 14, 2019:

 

  • Out of 69 add-ons registered on community add-ons website, two-thirds (46) are compatible, with 12 add-ons marked as incompatible. Others are being worked on, planned to be ported, or add-on features are now part of NVDA as of 2019.3 (specifically, Focus Highlight and Enhanced Aria features are now part of NVDA 2019.3). Including add-ons being worked on (under development and testing), the number of compatible add-ons rises to 54 (78%).
  • Notable add-ons with status changes include Clipspeak, Audio Themes, Braille Extender, Clip Contents Designer, Emoticons, Place Markers, and Report Symbols. Most of these are going through development snapshot testing at the moment, and Braille Extender and Clipspeak are declared compatible. For Audio Themes fans, version 6.0 beta is available for testing.
  • And no, NVDA Remote is still incompatible, although one of the authors said he is looking into making it ready for 2019.3 and sent a word about it and asked for help from NV Access.

 

The next status update (hopefully with changes) will be sent just before Christmas. As always, you can view latest compatibility list at:

https://addons.nvda-project.org/addons/nvdapy3.en.html

 

Cheers,

Joseph

 

 


Re: Unable to use vocaliser voices from code-factory. Any ideas why?

matthew dyer
 

Hi,

 

I am using nvda 2019.2.1.  The beta version of the beta says it is not compatible.  Not sure why they were not working now as they worked rite after I installed them.  After I restarted the computer the next day then that’s when it  starting problem.

 

Matthew

 

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Gene
Sent: Saturday, December 14, 2019 1:01 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Unable to use vocaliser voices from code-factory. Any ideas why?

 

Probably you need to use the NVDA beta for the current version with those voices.  I very much doubt they are backward compatible with earlier NVDA versions because of changes in NVDA.

 

If you want to see if that is the problem and not disturb your current NVDA installation, you can run a portable version of the NVDA beta and try the voices with that.

 

Gene

----- Or ginal Message -----

Sent: Saturday, December 14, 2019 10:07 AM

Subject: [nvda] Unable to use vocaliser voices from code-factory. Any ideas why?

 

Hi all

 

I have a trial of code fatory vocalizer which Is giving me am error everytime I try to switch to it.  Here is the log I get.  Anyone else having this problem with nvda 2019.2.1?  Using windows 10.1909.  See below.

 

INFO - __main__ (10:47:54.029):

Starting NVDA

INFO - core.main (10:47:54.341):

Config dir: C:\Users\ilove\AppData\Roaming\nvda

INFO - config.ConfigManager._loadConfig (10:47:54.341):

Loading config: C:\Users\ilove\AppData\Roaming\nvda\nvda.ini

INFO - core.main (10:47:54.857):

NVDA version 2019.2.1

INFO - core.main (10:47:54.857):

Using Windows version 10.0.18363 workstation

INFO - core.main (10:47:54.857):

Using Python version 2.7.16 (v2.7.16:413a49145e, Mar  4 2019, 01:30:55) [MSC v.1500 32 bit (Intel)]

INFO - core.main (10:47:54.857):

Using comtypes version 1.1.7

INFO - core.main (10:47:54.857):

Using configobj version 5.1.0 with validate version 1.0.1

WARNING - synthDriverHandler.SynthDriver.loadSettings (10:47:56.783):

Invalid voice: Maged  [ara] (Plus)

ERROR - synthDriverHandler.setSynth (10:47:57.111):

setSynth

Traceback (most recent call last):

  File "synthDriverHandler.pyo", line 101, in setSynth

  File "synthDriverHandler.pyo", line 75, in getSynthInstance

  File "synthDriverHandler.pyo", line 421, in initSettings

  File "synthDriverHandler.pyo", line 436, in loadSettings

  File "synthDriverHandler.pyo", line 33, in changeVoice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_codefactorytts.py", line 172, in _set_voice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 530, in setVoice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 288, in _execWhenDone

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 523, in _setVoice

WindowsError: exception: priviledged instruction

INFO - synthDriverHandler.setSynth (10:47:57.428):

Loaded synthDriver oneCore

INFO - core.main (10:47:57.428):

Using wx version 4.0.3 msw (phoenix) wxWidgets 3.0.5

INFO - brailleInput.initialize (10:47:57.428):

Braille input initialized

INFO - braille.initialize (10:47:57.428):

Using liblouis version 3.10.0

INFO - braille.BrailleHandler.setDisplayByName (10:47:57.450):

Loaded braille display driver noBraille, current display has 0 cells.

WARNING - core.main (10:47:57.551):

Java Access Bridge not available

INFO - _UIAHandler.UIAHandler.MTAThreadFunc (10:47:57.598):

UIAutomation: IUIAutomation6

INFO - core.main (10:47:58.214):

NVDA initialized

WARNING - synthDriverHandler.SynthDriver.loadSettings (10:52:37.065):

Invalid voice: Maged  [ara] (Plus)

ERROR - synthDriverHandler.setSynth (10:52:37.290):

setSynth

Traceback (most recent call last):

  File "synthDriverHandler.pyo", line 101, in setSynth

  File "synthDriverHandler.pyo", line 75, in getSynthInstance

  File "synthDriverHandler.pyo", line 421, in initSettings

  File "synthDriverHandler.pyo", line 436, in loadSettings

  File "synthDriverHandler.pyo", line 33, in changeVoice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_codefactorytts.py", line 172, in _set_voice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 530, in setVoice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 288, in _execWhenDone

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 523, in _setVoice

WindowsError: exception: priviledged instruction

INFO - synthDriverHandler.setSynth (10:52:37.515):

Loaded synthDriver oneCore

WARNING - synthDriverHandler.SynthDriver.loadSettings (10:54:36.947):

Invalid voice: Maged  [ara] (Plus)

ERROR - synthDriverHandler.setSynth (10:54:37.180):

setSynth

Traceback (most recent call last):

  File "synthDriverHandler.pyo", line 101, in setSynth

  File "synthDriverHandler.pyo", line 75, in getSynthInstance

  File "synthDriverHandler.pyo", line 421, in initSettings

  File "synthDriverHandler.pyo", line 436, in loadSettings

  File "synthDriverHandler.pyo", line 33, in changeVoice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_codefactorytts.py", line 172, in _set_voice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 530, in setVoice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 288, in _execWhenDone

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 523, in _setVoice

WindowsError: exception: priviledged instruction

INFO - synthDriverHandler.setSynth (10:54:37.392):

Loaded synthDriver oneCore

WARNING - synthDriverHandler.SynthDriver.loadSettings (10:56:49.993):

Invalid voice: Maged  [ara] (Plus)

ERROR - synthDriverHandler.setSynth (10:56:50.206):

setSynth

Traceback (most recent call last):

  File "synthDriverHandler.pyo", line 101, in setSynth

  File "synthDriverHandler.pyo", line 75, in getSynthInstance

  File "synthDriverHandler.pyo", line 421, in initSettings

  File "synthDriverHandler.pyo", line 436, in loadSettings

  File "synthDriverHandler.pyo", line 33, in changeVoice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_codefactorytts.py", line 172, in _set_voice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 530, in setVoice

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 288, in _execWhenDone

  File "C:\Users\ilove\AppData\Roaming\nvda\addons\codefactory\synthDrivers\_cfnvdainterface.py", line 523, in _setVoice

WindowsError: exception: priviledged instruction

INFO - synthDriverHandler.setSynth (10:56:50.418):

Loaded synthDriver oneCore

 

 


Re: NVDA no longer recognizes the status bar in Thunderbird

Rui Fontes
 

The problem is not from NVDA or from Mozilla add-on...


The statusBar in the new Thunderbird have a role: ROLE_STATICTEXT, instead of StatusBar


Rui Fontes


Às 16:57 de 15/12/2019, Dejan Ristic escreveu:

I've forgot to tell you that I use the latest stable version of NVDA and that my operating system in use is Windows 7, 64 bit.

On 15/12/2019 17:43, Dejan Ristic via Groups.Io wrote:
Hi,


When I installed the latest (68.3.0 (32-bit) version of Thunderbird, I discovered that it could no longer report the status bar information when the defined keystroke was pressed to perform that task.


Let me also say that the status bar found in the view menu, toolbars submenu within Thunderbird is checked, which means that NVDA is supposed to be able to read the status.


When I press the keystroke, NVDA says 'No status bar information'.


If such a problem has been already reported, let me appologize for skipping it.


Cheers,


Dejan




Re: NVDA no longer recognizes the status bar in Thunderbird

Dejan Ristic
 

It was reported in the previous 32 bit versions on my 64 bit system. This is for the first time that it fails.

On 15/12/2019 17:53, René Linke wrote:
Hi,

I can confirm that with Thunderbird 68.3.0 (for 64 bit), NVDA 2019.3 Beta 1, and Mozilla Apps Enhancements add-on 1.9.1.

René



Re: NVDA no longer recognizes the status bar in Thunderbird

René Linke
 

Hi,

I can confirm that with Thunderbird 68.3.0 (for 64 bit), NVDA 2019.3 Beta 1, and Mozilla Apps Enhancements add-on 1.9.1.

René


Re: NVDA no longer recognizes the status bar in Thunderbird

Dejan Ristic
 

I've forgot to tell you that I use the latest stable version of NVDA and that my operating system in use is Windows 7, 64 bit.

On 15/12/2019 17:43, Dejan Ristic via Groups.Io wrote:
Hi,


When I installed the latest (68.3.0 (32-bit) version of Thunderbird, I discovered that it could no longer report the status bar information when the defined keystroke was pressed to perform that task.


Let me also say that the status bar found in the view menu, toolbars submenu within Thunderbird is checked, which means that NVDA is supposed to be able to read the status.


When I press the keystroke, NVDA says 'No status bar information'.


If such a problem has been already reported, let me appologize for skipping it.


Cheers,


Dejan



NVDA no longer recognizes the status bar in Thunderbird

Dejan Ristic
 

Hi,


When I installed the latest (68.3.0 (32-bit) version of Thunderbird, I discovered that it could no longer report the status bar information when the defined keystroke was pressed to perform that task.


Let me also say that the status bar found in the view menu, toolbars submenu within Thunderbird is checked, which means that NVDA is supposed to be able to read the status.


When I press the keystroke, NVDA says 'No status bar information'.


If such a problem has been already reported, let me appologize for skipping it.


Cheers,


Dejan


Re: NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Hi,

I’d leave it up to the author to ask for add-on review and registration. Once that’s done, someone from the community will review the add-on and suggest changes if any, and once the author say yes, it’ll be registered.

In case of File Reader (and for that matter, other add-on suggestions in 2020 and beyond), it must be compatible with at least NVDA 2019.3, both in code and add-on manifest. Even if the source code is compatible but manifest information is not, it cannot be registered on community add-ons website.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of abdul muhamin
Sent: Sunday, December 15, 2019 2:44 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Hi joseph, its really a good news that we are getting the 2019.3 very soon, and much of the addons are compatible, I want to ask, there is an addon called file reader by oriel Goma’s, is there any chance for this addon to be register on the community addons site, and be compatible for the latest version of NVDA? If you don’t know about the addon, let me know, I can provide the link for this, its currently working on NVDA2019.2.1, thanks

 

Regards

Abdulmuhamin.

Chief content officer at

Blind Help Project

Contact me through the following!

On Facebook

On twitter

On skype

On WhatsApp

E-mail me at

A.Muhamin@...

Sent from Mail for Windows 10

 

From: Joseph Lee
Sent: Saturday, December 14, 2019 10:01 AM
To: nvda-devel@groups.io
Subject: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Dear NVDA community,

 

A few days ago NVDA 2019.3 beta was released, marking the milestone on our journey toward letting everyone meet NVDA 2019.3 soon. Along with this milestone, I’m delighted to announce that add-ons community is seeing uptake in getting add-ons ready for NVDA 2019.3, including announcements from speech synthesizer vendors such as Code Factory releasing updated versions of synthesizer add-ons. In addition, more add-ons listed on community add-ons website is preparing themselves for NVDA 2019.3.

 

Regarding which add-ons are compatible with NVDA 2019.3 as of December 14, 2019:

 

  • Out of 69 add-ons registered on community add-ons website, two-thirds (46) are compatible, with 12 add-ons marked as incompatible. Others are being worked on, planned to be ported, or add-on features are now part of NVDA as of 2019.3 (specifically, Focus Highlight and Enhanced Aria features are now part of NVDA 2019.3). Including add-ons being worked on (under development and testing), the number of compatible add-ons rises to 54 (78%).
  • Notable add-ons with status changes include Clipspeak, Audio Themes, Braille Extender, Clip Contents Designer, Emoticons, Place Markers, and Report Symbols. Most of these are going through development snapshot testing at the moment, and Braille Extender and Clipspeak are declared compatible. For Audio Themes fans, version 6.0 beta is available for testing.
  • And no, NVDA Remote is still incompatible, although one of the authors said he is looking into making it ready for 2019.3 and sent a word about it and asked for help from NV Access.

 

The next status update (hopefully with changes) will be sent just before Christmas. As always, you can view latest compatibility list at:

https://addons.nvda-project.org/addons/nvdapy3.en.html

 

Cheers,

Joseph

 


Re: Android studio accessibility for windows 32 bit

Ramesh Patil
 

Yes, I am absolutely sure I have installed 32 bit Android studio because my windows is 32bit only.

Another have set the environment variable for java home.
How to check android_home variable question mark

Thank you


On Sun, Dec 15, 2019, 7:41 PM Jaffar Sidek <jaffar.sidek10@...> wrote:

Hello!  Are you absolutely sure you installed the 32 bit version of Android Studio?  Also, Check your JAVA_HOME and ANDROID_HOME variables.

On 12/15/2019 7:10 PM, Ramesh Patil wrote:



I am using windows 10 32 bit version with JDK 8 installed for 32 bit also I have activated Java access bridge but Android studio is not supporting Nvda screen reader. I vhecked check box of screen reader support under setting of android studio. But still not works.  Please guide me

Regards
Ramesh Patil


Re: A simple question about vocalizer voices and portable version of NVDA

Luke
 

Yes I am talking about Tiflotecnia . I am going to make the change For the portable ersion to use the non-high quality voice. Thank you.

On Dec 14, 2019, at 8:10 PM, Rui Fontes <rui.fontes@...> wrote:

about Tiflotecnia


Re: Android studio accessibility for windows 32 bit

Jaffar Sidek
 

Hello!  Are you absolutely sure you installed the 32 bit version of Android Studio?  Also, Check your JAVA_HOME and ANDROID_HOME variables.

On 12/15/2019 7:10 PM, Ramesh Patil wrote:



I am using windows 10 32 bit version with JDK 8 installed for 32 bit also I have activated Java access bridge but Android studio is not supporting Nvda screen reader. I vhecked check box of screen reader support under setting of android studio. But still not works.  Please guide me

Regards
Ramesh Patil


Re: NVDA 2019.3 and add-ons: update as of December 14, 2019 with 2019.3 beta

molly the blind tech lover
 

This is great news 😀

Thank you

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Joseph Lee
Sent: Saturday, December 14, 2019 12:01 AM
To: nvda-devel@groups.io
Subject: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with 2019.3 beta

 

Dear NVDA community,

 

A few days ago NVDA 2019.3 beta was released, marking the milestone on our journey toward letting everyone meet NVDA 2019.3 soon. Along with this milestone, I’m delighted to announce that add-ons community is seeing uptake in getting add-ons ready for NVDA 2019.3, including announcements from speech synthesizer vendors such as Code Factory releasing updated versions of synthesizer add-ons. In addition, more add-ons listed on community add-ons website is preparing themselves for NVDA 2019.3.

 

Regarding which add-ons are compatible with NVDA 2019.3 as of December 14, 2019:

 

  • Out of 69 add-ons registered on community add-ons website, two-thirds (46) are compatible, with 12 add-ons marked as incompatible. Others are being worked on, planned to be ported, or add-on features are now part of NVDA as of 2019.3 (specifically, Focus Highlight and Enhanced Aria features are now part of NVDA 2019.3). Including add-ons being worked on (under development and testing), the number of compatible add-ons rises to 54 (78%).
  • Notable add-ons with status changes include Clipspeak, Audio Themes, Braille Extender, Clip Contents Designer, Emoticons, Place Markers, and Report Symbols. Most of these are going through development snapshot testing at the moment, and Braille Extender and Clipspeak are declared compatible. For Audio Themes fans, version 6.0 beta is available for testing.
  • And no, NVDA Remote is still incompatible, although one of the authors said he is looking into making it ready for 2019.3 and sent a word about it and asked for help from NV Access.

 

The next status update (hopefully with changes) will be sent just before Christmas. As always, you can view latest compatibility list at:

https://addons.nvda-project.org/addons/nvdapy3.en.html

 

Cheers,

Joseph


Re: NVDA SOUNDS in word

molly the blind tech lover
 

Your welcome 😀

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Kerryn Gunness via Groups.Io
Sent: Saturday, December 14, 2019 4:34 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA SOUNDS in word

 

thanks allot

 

----- Original Message -----

Sent: Friday, December 13, 2019 9:16 PM

Subject: Re: [nvda] NVDA SOUNDS in word

 

Hi.

I think what you are referring to is that NVDA makes a buzzing sound when you spell something incorrectly. If you go to NVDA’s keyboard settings there is an option play sound for spelling errors. Uncheck that option.

Hope this helps

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Kerryn Gunness via Groups.Io
Sent: Friday, December 13, 2019 7:27 PM
To: nvda@nvda.groups.io
Subject: [nvda] NVDA SOUNDS in word

 

hello

when u type an incorrect word in ms word, and u press space bar, nvda makes an audable sound

can this sound be turned off?

thanks

 

----- Original Message -----

From: Joseph Lee

Sent: Friday, December 13, 2019 5:20 PM

Subject: [nvda] StationPlaylist add-on 19.11.2, Windows 10 App Essentials 1911.4 #AddonRelease

 

Hi all,

 

In about an hour from now StationPlaylist add-on 19.11.2 and Windows 10 App Essentials 19.11.4 will show up for stable channel subscribers. These releases are localization updates.

 

NOTE: this or the next releases for these add-ons will be the final version compatible with NVDA versions earlier than 2019.3. Sometime next week, I’ll create a link to old releases on the community add-ons website under entries for these add-ons. The old releases link will be online until sometime in 2020.

Cheers,

Joseph


Re: How to make Android studio accessible

erik burggraaf <erik@...>
 

it worked for me, but I am using 64 bit windows.

Best,

Erik

On December 15, 2019 12:49:36 AM "Ramesh Patil" <ramesh.patil1989@...> wrote:

I am using windows 10 32 bit version with JDK 8 installed for 32 bit also I have activated Java access bridge but Android studio is not supporting Nvda screen reader


Android studio accessibility for windows 32 bit

Ramesh Patil
 



I am using windows 10 32 bit version with JDK 8 installed for 32 bit also I have activated Java access bridge but Android studio is not supporting Nvda screen reader. I vhecked check box of screen reader support under setting of android studio. But still not works.  Please guide me

Regards
Ramesh Patil

_._,_._,_


Re: NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

abdul muhamin
 

Hi joseph, its really a good news that we are getting the 2019.3 very soon, and much of the addons are compatible, I want to ask, there is an addon called file reader by oriel Goma’s, is there any chance for this addon to be register on the community addons site, and be compatible for the latest version of NVDA? If you don’t know about the addon, let me know, I can provide the link for this, its currently working on NVDA2019.2.1, thanks

 

Regards

Abdulmuhamin.

Chief content officer at

Blind Help Project

Contact me through the following!

On Facebook

On twitter

On skype

On WhatsApp

E-mail me at

A.Muhamin@...

Sent from Mail for Windows 10

 

From: Joseph Lee
Sent: Saturday, December 14, 2019 10:01 AM
To: nvda-devel@groups.io
Subject: [nvda] NVDA 2019.3 and add-ons: update as of December 14, 2019 with2019.3 beta

 

Dear NVDA community,

 

A few days ago NVDA 2019.3 beta was released, marking the milestone on our journey toward letting everyone meet NVDA 2019.3 soon. Along with this milestone, I’m delighted to announce that add-ons community is seeing uptake in getting add-ons ready for NVDA 2019.3, including announcements from speech synthesizer vendors such as Code Factory releasing updated versions of synthesizer add-ons. In addition, more add-ons listed on community add-ons website is preparing themselves for NVDA 2019.3.

 

Regarding which add-ons are compatible with NVDA 2019.3 as of December 14, 2019:

 

  • Out of 69 add-ons registered on community add-ons website, two-thirds (46) are compatible, with 12 add-ons marked as incompatible. Others are being worked on, planned to be ported, or add-on features are now part of NVDA as of 2019.3 (specifically, Focus Highlight and Enhanced Aria features are now part of NVDA 2019.3). Including add-ons being worked on (under development and testing), the number of compatible add-ons rises to 54 (78%).
  • Notable add-ons with status changes include Clipspeak, Audio Themes, Braille Extender, Clip Contents Designer, Emoticons, Place Markers, and Report Symbols. Most of these are going through development snapshot testing at the moment, and Braille Extender and Clipspeak are declared compatible. For Audio Themes fans, version 6.0 beta is available for testing.
  • And no, NVDA Remote is still incompatible, although one of the authors said he is looking into making it ready for 2019.3 and sent a word about it and asked for help from NV Access.

 

The next status update (hopefully with changes) will be sent just before Christmas. As always, you can view latest compatibility list at:

https://addons.nvda-project.org/addons/nvdapy3.en.html

 

Cheers,

Joseph