Editing Excel Cells


Louis Maher <ljmaher03@...>
 

Folks,

I recently migrated from JAWS to NVDA. In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2. Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@outlook.com


Quentin Christensen
 

Hi Louis,

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

Regards

Quentin.

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:
Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...







--
Quentin Christensen
Training and Support Manager

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Ralf Kefferpuetz
 

I can confirm this behavior. I only hear “unknown” when pressing F2 in Excel 2016.

To focus on the editfield I have to to a nvda-numpad4, a nvda-numpad-divide and finally numpad-divide (in other words I click on it with the left mouse button.

Seems NVDA is focussing the wrong control.

 

Cheers,

   Ralf

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Freitag, 20. April 2018 07:00
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hi Louis,

 

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

 

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

 

Regards


Quentin.

 

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:

Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...





 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Ervin, Glenn
 

I would say that it is a screenreader problem, because I started having trouble with it in my Excel 2000.

Glenn

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Quentin Christensen
Sent: Friday, April 20, 2018 12:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hi Louis,

 

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

 

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

 

Regards


Quentin.

 

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:

Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...





 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Louis Maher <ljmaher03@...>
 

Hello Quentin,

 

I believe you are correct in saying that Microsoft changed something in office that disabled the F2 cell editing capability in Excel.  It took VFO several months to solve this issue. 

 

I looked up the NVDA incident report.  Following the suggestions there, I removed and restored my Office 365.  I still do not have the NVDA F2 cell editing function.

 

I am using NVDA 2018.1.1.

 

Thanks for your information.

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Friday, April 20, 2018 12:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hi Louis,

 

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

 

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

 

Regards


Quentin.

 

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:

Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...





 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Pranav Lal
 

Hi Quentin.

 

There is a setting in Excel that talks about editing directly in cells. I think this should be  enabled for NVDA to read the contents of the cell. In addition, disabling hardware acceleration may help.

 

Pranav


Cearbhall O'Meadhra
 

Quentin,

 

I use F2 to edit the cell but then NVDA cannot read the contents as the cell opens minimised. When I maximise the cell NVDA reads the contents immediately. I had not noticed this before! Could it be part of the change that you are referring to? I agree that this is a Microsoft issue as the cell is not minimised by NVDA but by Excel.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Friday, April 20, 2018 3:32 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hello Quentin,

 

I believe you are correct in saying that Microsoft changed something in office that disabled the F2 cell editing capability in Excel.  It took VFO several months to solve this issue. 

 

I looked up the NVDA incident report.  Following the suggestions there, I removed and restored my Office 365.  I still do not have the NVDA F2 cell editing function.

 

I am using NVDA 2018.1.1.

 

Thanks for your information.

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Friday, April 20, 2018 12:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hi Louis,

 

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

 

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

 

Regards


Quentin.

 

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:

Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...




 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Quentin Christensen
 

Pranav,

I hadn't actually touched my Excel settings when this started.  I just went in and the setting (in Advanced) was checked.  When I unchecked it, when I press F2 now visually the caret moves to the function bar rather than editing directly in the cell, and NVDA is currently reading the text correctly while editing.

Cearbhall, I'm not exactly sure what you mean by minimised and maximised here?  When you press F2, the Excel window doesn't change dramatically.  If editing in cell as I was previously, the caret would appear in the current cell, and if needed the text would flow across to the right of the screen and then down to lower rows, if it didn't fit in the current cell.  If editing in the function bar, the caret appears up there instead, but there is no other minimise or maximise aside from the entire Excel window (which was already maximised).

On Mon, Apr 23, 2018 at 8:35 AM, Cearbhall O'Meadhra <cearbhall.omeadhra@...> wrote:

Quentin,

 

I use F2 to edit the cell but then NVDA cannot read the contents as the cell opens minimised. When I maximise the cell NVDA reads the contents immediately. I had not noticed this before! Could it be part of the change that you are referring to? I agree that this is a Microsoft issue as the cell is not minimised by NVDA but by Excel.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Friday, April 20, 2018 3:32 PM


To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hello Quentin,

 

I believe you are correct in saying that Microsoft changed something in office that disabled the F2 cell editing capability in Excel.  It took VFO several months to solve this issue. 

 

I looked up the NVDA incident report.  Following the suggestions there, I removed and restored my Office 365.  I still do not have the NVDA F2 cell editing function.

 

I am using NVDA 2018.1.1.

 

Thanks for your information.

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Friday, April 20, 2018 12:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hi Louis,

 

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

 

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

 

Regards


Quentin.

 

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:

Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...




 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 




--
Quentin Christensen
Training and Support Manager

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Louis Maher <ljmaher03@...>
 

Thank you Quentin,

 

Unchecking the “edit cells directly” option in the advanced options allows f2 to work correctly.

 

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Sunday, April 22, 2018 7:32 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Pranav,

 

I hadn't actually touched my Excel settings when this started.  I just went in and the setting (in Advanced) was checked.  When I unchecked it, when I press F2 now visually the caret moves to the function bar rather than editing directly in the cell, and NVDA is currently reading the text correctly while editing.

 

Cearbhall, I'm not exactly sure what you mean by minimised and maximised here?  When you press F2, the Excel window doesn't change dramatically.  If editing in cell as I was previously, the caret would appear in the current cell, and if needed the text would flow across to the right of the screen and then down to lower rows, if it didn't fit in the current cell.  If editing in the function bar, the caret appears up there instead, but there is no other minimise or maximise aside from the entire Excel window (which was already maximised).

 

On Mon, Apr 23, 2018 at 8:35 AM, Cearbhall O'Meadhra <cearbhall.omeadhra@...> wrote:

Quentin,

 

I use F2 to edit the cell but then NVDA cannot read the contents as the cell opens minimised. When I maximise the cell NVDA reads the contents immediately. I had not noticed this before! Could it be part of the change that you are referring to? I agree that this is a Microsoft issue as the cell is not minimised by NVDA but by Excel.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Friday, April 20, 2018 3:32 PM


To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hello Quentin,

 

I believe you are correct in saying that Microsoft changed something in office that disabled the F2 cell editing capability in Excel.  It took VFO several months to solve this issue. 

 

I looked up the NVDA incident report.  Following the suggestions there, I removed and restored my Office 365.  I still do not have the NVDA F2 cell editing function.

 

I am using NVDA 2018.1.1.

 

Thanks for your information.

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Friday, April 20, 2018 12:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hi Louis,

 

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

 

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

 

Regards


Quentin.

 

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:

Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...



 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 



 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Cearbhall O'Meadhra
 

Quentin,

 

When I open an excel sheet in OFFice 2016, windows 10 and latest NVDA, NVDA speaks the cell results and so I missed the fact that the worksheet was stil minimised! In that state, when I press F2, NVDA says blank. In the case of a formula  in the cell, control-shift-home gets equals and so it is evident that there is a problem. At this stage I maximise the screen and NVDA speaks the entire formula immediately.

 

From your question I examined my actions and realised that I should maximise the screen before doing anything else!

 

I am very pleased with the ease with which NVDA works with Excel and I am able to write macros and build formulas whenever I need them.

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Monday, April 23, 2018 2:38 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Thank you Quentin,

 

Unchecking the “edit cells directly” option in the advanced options allows f2 to work correctly.

 

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Sunday, April 22, 2018 7:32 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Pranav,

 

I hadn't actually touched my Excel settings when this started.  I just went in and the setting (in Advanced) was checked.  When I unchecked it, when I press F2 now visually the caret moves to the function bar rather than editing directly in the cell, and NVDA is currently reading the text correctly while editing.

 

Cearbhall, I'm not exactly sure what you mean by minimised and maximised here?  When you press F2, the Excel window doesn't change dramatically.  If editing in cell as I was previously, the caret would appear in the current cell, and if needed the text would flow across to the right of the screen and then down to lower rows, if it didn't fit in the current cell.  If editing in the function bar, the caret appears up there instead, but there is no other minimise or maximise aside from the entire Excel window (which was already maximised).

 

On Mon, Apr 23, 2018 at 8:35 AM, Cearbhall O'Meadhra <cearbhall.omeadhra@...> wrote:

Quentin,

 

I use F2 to edit the cell but then NVDA cannot read the contents as the cell opens minimised. When I maximise the cell NVDA reads the contents immediately. I had not noticed this before! Could it be part of the change that you are referring to? I agree that this is a Microsoft issue as the cell is not minimised by NVDA but by Excel.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Friday, April 20, 2018 3:32 PM


To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hello Quentin,

 

I believe you are correct in saying that Microsoft changed something in office that disabled the F2 cell editing capability in Excel.  It took VFO several months to solve this issue. 

 

I looked up the NVDA incident report.  Following the suggestions there, I removed and restored my Office 365.  I still do not have the NVDA F2 cell editing function.

 

I am using NVDA 2018.1.1.

 

Thanks for your information.

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Friday, April 20, 2018 12:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hi Louis,

 

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

 

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

 

Regards


Quentin.

 

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:

Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...



 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 



 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Louis Maher <ljmaher03@...>
 

Hello Cearbhall,

 

Following Quentin’s suggestion: I hit alt + f, up-arrowed to options, hit enter, arrowed down to advanced, tabbed to the check box for “directly editing cells “, unchecked that box, and hit OK.  This solved my f2 Excel editing problem. 

 

You should not have to concern yourself with maximizing Excel after this change.

 

 

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Cearbhall O'Meadhra
Sent: Monday, April 23, 2018 12:48 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Quentin,

 

When I open an excel sheet in OFFice 2016, windows 10 and latest NVDA, NVDA speaks the cell results and so I missed the fact that the worksheet was stil minimised! In that state, when I press F2, NVDA says blank. In the case of a formula  in the cell, control-shift-home gets equals and so it is evident that there is a problem. At this stage I maximise the screen and NVDA speaks the entire formula immediately.

 

From your question I examined my actions and realised that I should maximise the screen before doing anything else!

 

I am very pleased with the ease with which NVDA works with Excel and I am able to write macros and build formulas whenever I need them.

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Monday, April 23, 2018 2:38 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Thank you Quentin,

 

Unchecking the “edit cells directly” option in the advanced options allows f2 to work correctly.

 

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Sunday, April 22, 2018 7:32 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Pranav,

 

I hadn't actually touched my Excel settings when this started.  I just went in and the setting (in Advanced) was checked.  When I unchecked it, when I press F2 now visually the caret moves to the function bar rather than editing directly in the cell, and NVDA is currently reading the text correctly while editing.

 

Cearbhall, I'm not exactly sure what you mean by minimised and maximised here?  When you press F2, the Excel window doesn't change dramatically.  If editing in cell as I was previously, the caret would appear in the current cell, and if needed the text would flow across to the right of the screen and then down to lower rows, if it didn't fit in the current cell.  If editing in the function bar, the caret appears up there instead, but there is no other minimise or maximise aside from the entire Excel window (which was already maximised).

 

On Mon, Apr 23, 2018 at 8:35 AM, Cearbhall O'Meadhra <cearbhall.omeadhra@...> wrote:

Quentin,

 

I use F2 to edit the cell but then NVDA cannot read the contents as the cell opens minimised. When I maximise the cell NVDA reads the contents immediately. I had not noticed this before! Could it be part of the change that you are referring to? I agree that this is a Microsoft issue as the cell is not minimised by NVDA but by Excel.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Friday, April 20, 2018 3:32 PM


To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hello Quentin,

 

I believe you are correct in saying that Microsoft changed something in office that disabled the F2 cell editing capability in Excel.  It took VFO several months to solve this issue. 

 

I looked up the NVDA incident report.  Following the suggestions there, I removed and restored my Office 365.  I still do not have the NVDA F2 cell editing function.

 

I am using NVDA 2018.1.1.

 

Thanks for your information.

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Friday, April 20, 2018 12:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hi Louis,

 

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

 

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

 

Regards


Quentin.

 

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:

Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...



 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 



 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Suzy
 

Hello,

 

Thanks for this tip. It is nice to have a work-around. I have always set up Excel to edit directly in the cell, because past experience indicated that was best.

 

I’ve had Excel issues for more than six weeks now. It began with the PC freezing, when editing a worksheet. After trying several things, I resorted to using the Fresh Start option in Windows 10’s Security Settings. (I did this after checking for updates to Office 365 and finding none.)

When Windows, NVDA 2018.1.1, and Office 365 were reinstalled and set up, I discovered the situation described in this thread. I was annoyed.

I did not have time to add my input until now. Thanks again for this resolution. I hope Microsoft doesn’t break something else. I firmly believe the need to change from editing in the cell to editing in the formula bar is due to some change Microsoft made to the Excel program.

 

Thanks!

Suzy

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Monday, April 23, 2018 2:04 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hello Cearbhall,

 

Following Quentin’s suggestion: I hit alt + f, up-arrowed to options, hit enter, arrowed down to advanced, tabbed to the check box for “directly editing cells “, unchecked that box, and hit OK.  This solved my f2 Excel editing problem. 

 

You should not have to concern yourself with maximizing Excel after this change.

 

 

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Cearbhall O'Meadhra
Sent: Monday, April 23, 2018 12:48 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Quentin,

 

When I open an excel sheet in OFFice 2016, windows 10 and latest NVDA, NVDA speaks the cell results and so I missed the fact that the worksheet was stil minimised! In that state, when I press F2, NVDA says blank. In the case of a formula  in the cell, control-shift-home gets equals and so it is evident that there is a problem. At this stage I maximise the screen and NVDA speaks the entire formula immediately.

 

From your question I examined my actions and realised that I should maximise the screen before doing anything else!

 

I am very pleased with the ease with which NVDA works with Excel and I am able to write macros and build formulas whenever I need them.

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Monday, April 23, 2018 2:38 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Thank you Quentin,

 

Unchecking the “edit cells directly” option in the advanced options allows f2 to work correctly.

 

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Sunday, April 22, 2018 7:32 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Pranav,

 

I hadn't actually touched my Excel settings when this started.  I just went in and the setting (in Advanced) was checked.  When I unchecked it, when I press F2 now visually the caret moves to the function bar rather than editing directly in the cell, and NVDA is currently reading the text correctly while editing.

 

Cearbhall, I'm not exactly sure what you mean by minimised and maximised here?  When you press F2, the Excel window doesn't change dramatically.  If editing in cell as I was previously, the caret would appear in the current cell, and if needed the text would flow across to the right of the screen and then down to lower rows, if it didn't fit in the current cell.  If editing in the function bar, the caret appears up there instead, but there is no other minimise or maximise aside from the entire Excel window (which was already maximised).

 

On Mon, Apr 23, 2018 at 8:35 AM, Cearbhall O'Meadhra <cearbhall.omeadhra@...> wrote:

Quentin,

 

I use F2 to edit the cell but then NVDA cannot read the contents as the cell opens minimised. When I maximise the cell NVDA reads the contents immediately. I had not noticed this before! Could it be part of the change that you are referring to? I agree that this is a Microsoft issue as the cell is not minimised by NVDA but by Excel.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Friday, April 20, 2018 3:32 PM


To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hello Quentin,

 

I believe you are correct in saying that Microsoft changed something in office that disabled the F2 cell editing capability in Excel.  It took VFO several months to solve this issue. 

 

I looked up the NVDA incident report.  Following the suggestions there, I removed and restored my Office 365.  I still do not have the NVDA F2 cell editing function.

 

I am using NVDA 2018.1.1.

 

Thanks for your information.

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Friday, April 20, 2018 12:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hi Louis,

 

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

 

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

 

Regards


Quentin.

 

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:

Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...



 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 



 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Cearbhall O'Meadhra
 

Hanks Louis,

 

That is unchecked OK!

 

All is working well at my end.

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Monday, April 23, 2018 7:04 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hello Cearbhall,

 

Following Quentin’s suggestion: I hit alt + f, up-arrowed to options, hit enter, arrowed down to advanced, tabbed to the check box for “directly editing cells “, unchecked that box, and hit OK.  This solved my f2 Excel editing problem. 

 

You should not have to concern yourself with maximizing Excel after this change.

 

 

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Cearbhall O'Meadhra
Sent: Monday, April 23, 2018 12:48 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Quentin,

 

When I open an excel sheet in OFFice 2016, windows 10 and latest NVDA, NVDA speaks the cell results and so I missed the fact that the worksheet was stil minimised! In that state, when I press F2, NVDA says blank. In the case of a formula  in the cell, control-shift-home gets equals and so it is evident that there is a problem. At this stage I maximise the screen and NVDA speaks the entire formula immediately.

 

From your question I examined my actions and realised that I should maximise the screen before doing anything else!

 

I am very pleased with the ease with which NVDA works with Excel and I am able to write macros and build formulas whenever I need them.

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Monday, April 23, 2018 2:38 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Thank you Quentin,

 

Unchecking the “edit cells directly” option in the advanced options allows f2 to work correctly.

 

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Sunday, April 22, 2018 7:32 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Pranav,

 

I hadn't actually touched my Excel settings when this started.  I just went in and the setting (in Advanced) was checked.  When I unchecked it, when I press F2 now visually the caret moves to the function bar rather than editing directly in the cell, and NVDA is currently reading the text correctly while editing.

 

Cearbhall, I'm not exactly sure what you mean by minimised and maximised here?  When you press F2, the Excel window doesn't change dramatically.  If editing in cell as I was previously, the caret would appear in the current cell, and if needed the text would flow across to the right of the screen and then down to lower rows, if it didn't fit in the current cell.  If editing in the function bar, the caret appears up there instead, but there is no other minimise or maximise aside from the entire Excel window (which was already maximised).

 

On Mon, Apr 23, 2018 at 8:35 AM, Cearbhall O'Meadhra <cearbhall.omeadhra@...> wrote:

Quentin,

 

I use F2 to edit the cell but then NVDA cannot read the contents as the cell opens minimised. When I maximise the cell NVDA reads the contents immediately. I had not noticed this before! Could it be part of the change that you are referring to? I agree that this is a Microsoft issue as the cell is not minimised by NVDA but by Excel.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Louis Maher
Sent: Friday, April 20, 2018 3:32 PM


To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hello Quentin,

 

I believe you are correct in saying that Microsoft changed something in office that disabled the F2 cell editing capability in Excel.  It took VFO several months to solve this issue. 

 

I looked up the NVDA incident report.  Following the suggestions there, I removed and restored my Office 365.  I still do not have the NVDA F2 cell editing function.

 

I am using NVDA 2018.1.1.

 

Thanks for your information.

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail ljmaher03@...

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Quentin Christensen
Sent: Friday, April 20, 2018 12:00 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Editing Excel Cells

 

Hi Louis,

 

Pressing F2 to edit cell contents in Excel is a function of Excel itself, rather than the screen reader.  So, yes you can do this with NVDA.  Interesting that you say this functionality no longer works with Jaws, as we have started seeing problems with it in NVDA, so I wonder if it is not something either screen reader has done, but perhaps something Microsoft has done that has broken how we get the information about cells being edited.  For a sighted user, and indeed using NVDA, the functionality appears to work just the same as it ever has, it's just that NVDA reports "unknown" when you press F2, and then does not read the contents of the cell.

 

We have at least one issue open for this: https://github.com/nvaccess/nvda/issues/8146

 

Regards


Quentin.

 

On Fri, Apr 20, 2018 at 8:32 AM, Louis Maher <ljmaher03@...> wrote:

Folks,

I recently migrated from JAWS to NVDA.  In JAWS, a user can edit an Excel cell by putting the cursor on the cell and hitting f2.  Recently this functionality disappeared from JAWS; however, with today's release (J2018.1804.26) this functionality has returned.

Does NVDA have an Excel cell editing method?


Regards
Louis Maher
Phone: 713-444-7838
E-mail ljmaher03@...



 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 



 

--

Quentin Christensen
Training and Support Manager

 

Official NVDA Training modules and expert certification now available: http://www.nvaccess.org/shop/

 

Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Pranav Lal
 

Hi Quentin,

 

I have allow editing directly in cells unchecked. I see the explanation from subsequent messages so this works for me.

 

Pranav