NVDA not reading table in MSWord


Cearbhall O'Meadhra
 

Hi all,

 

I am attempting to read an annual audit report in MS Word 2016 using NVDA 2016.2 and windows 10. I can read the document from top to bottom with “say all”. However, although I can jump to a table of financial figures in browse mode using the letter “t”, I cannot move through the table in the usual way with control+alt+arrows. How can I find out what is wrong with the word document that is preventing me from reading the table?

 

As this is a confidential draft document, I cannot share it with you until it is published. Meanwhile, I have to read it before next Wednesday!

 

Incidentally, I copied the entire contetnts of the Word file to the clipboard and pasted it into a fresh Excel 2016 file. The tables were set out perfectly and I could arrow from cell to cell in the usual Excel way.

 

Question is: If the tables are so correct that NVDA says “table 3rows and 4 columns” or some such, I would assume that the table is correctly constructed. How, then, is it that NVDA cannot read the cells  with control+alt+arrows? I can read through the row using control+right or left arrow but this is only moving from word to word. The column number is then reported and the right edge of the cell is reported as “Carriage return” There is no indication of a tab character.

 

Any ideas?

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

I use the free version of Spam Reader to get rid of spam. The Professional version doesn't have this disclaimer in outgoing emails. Try Spam Reader for free now!

 


Louis Maher <ljmaher@...>
 

One emergency strategy would be to convert it into a .txt file.

 

Regards

Louis Maher

Phone: 713-444-7838

E-mail: ljmaher@...

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Cearbhall O'Meadhra
Sent: Thursday, July 21, 2016 7:45 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA not reading table in MSWord

 

Hi all,

 

I am attempting to read an annual audit report in MS Word 2016 using NVDA 2016.2 and windows 10. I can read the document from top to bottom with “say all”. However, although I can jump to a table of financial figures in browse mode using the letter “t”, I cannot move through the table in the usual way with control+alt+arrows. How can I find out what is wrong with the word document that is preventing me from reading the table?

 

As this is a confidential draft document, I cannot share it with you until it is published. Meanwhile, I have to read it before next Wednesday!

 

Incidentally, I copied the entire contetnts of the Word file to the clipboard and pasted it into a fresh Excel 2016 file. The tables were set out perfectly and I could arrow from cell to cell in the usual Excel way.

 

Question is: If the tables are so correct that NVDA says “table 3rows and 4 columns” or some such, I would assume that the table is correctly constructed. How, then, is it that NVDA cannot read the cells  with control+alt+arrows? I can read through the row using control+right or left arrow but this is only moving from word to word. The column number is then reported and the right edge of the cell is reported as “Carriage return” There is no indication of a tab character.

 

Any ideas?

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

I use the free version of Spam Reader to get rid of spam. The Professional version doesn't have this disclaimer in outgoing emails. Try Spam Reader for free now!

 


Cearbhall O'Meadhra
 

How would that help? I could not then read the tables at all, surely!

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

 

I use the free version of Spam Reader to get rid of spam. The Professional version doesn't have this disclaimer in outgoing emails. Try Spam Reader for free now!

 


Mike Sedmak
 

Sanity check, are you in browse mode? "ALT-space

Thanks,
Mike

Sent from my iPhone, please forgive the typos. 

On Jul 21, 2016, at 6:44 AM, Cearbhall O'Meadhra <cearbhall.omeadhra@...> wrote:

Hi all,

 

I am attempting to read an annual audit report in MS Word 2016 using NVDA 2016.2 and windows 10. I can read the document from top to bottom with “say all”. However, although I can jump to a table of financial figures in browse mode using the letter “t”, I cannot move through the table in the usual way with control+alt+arrows. How can I find out what is wrong with the word document that is preventing me from reading the table?

 

As this is a confidential draft document, I cannot share it with you until it is published. Meanwhile, I have to read it before next Wednesday!

 

Incidentally, I copied the entire contetnts of the Word file to the clipboard and pasted it into a fresh Excel 2016 file. The tables were set out perfectly and I could arrow from cell to cell in the usual Excel way.

 

Question is: If the tables are so correct that NVDA says “table 3rows and 4 columns” or some such, I would assume that the table is correctly constructed. How, then, is it that NVDA cannot read the cells  with control+alt+arrows? I can read through the row using control+right or left arrow but this is only moving from word to word. The column number is then reported and the right edge of the cell is reported as “Carriage return” There is no indication of a tab character.

 

Any ideas?

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

I use the free version of Spam Reader to get rid of spam. The Professional version doesn't have this disclaimer in outgoing emails. Try Spam Reader for free now!

 


Chris Mullins
 

Hi

I have heard many people complaining of accessibility issues with Office 2016.  I have the same NVDA version and Operating system as you and can read tables in Office 2007 Word documents perfectly using the keystrokes you mentioned.  Could you perhaps save the Word document as a pdf file and read it using acrobat?

 

Cheers

Chris

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Mike Sedmak
Sent: 21 July 2016 17:16
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA not reading table in MSWord

 

Sanity check, are you in browse mode? "ALT-space

Thanks,

Mike

 

Sent from my iPhone, please forgive the typos. 


On Jul 21, 2016, at 6:44 AM, Cearbhall O'Meadhra <cearbhall.omeadhra@...> wrote:

Hi all,

 

I am attempting to read an annual audit report in MS Word 2016 using NVDA 2016.2 and windows 10. I can read the document from top to bottom with “say all”. However, although I can jump to a table of financial figures in browse mode using the letter “t”, I cannot move through the table in the usual way with control+alt+arrows. How can I find out what is wrong with the word document that is preventing me from reading the table?

 

As this is a confidential draft document, I cannot share it with you until it is published. Meanwhile, I have to read it before next Wednesday!

 

Incidentally, I copied the entire contetnts of the Word file to the clipboard and pasted it into a fresh Excel 2016 file. The tables were set out perfectly and I could arrow from cell to cell in the usual Excel way.

 

Question is: If the tables are so correct that NVDA says “table 3rows and 4 columns” or some such, I would assume that the table is correctly constructed. How, then, is it that NVDA cannot read the cells  with control+alt+arrows? I can read through the row using control+right or left arrow but this is only moving from word to word. The column number is then reported and the right edge of the cell is reported as “Carriage return” There is no indication of a tab character.

 

Any ideas?

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

I use the free version of Spam Reader to get rid of spam. The Professional version doesn't have this disclaimer in outgoing emails. Try Spam Reader for free now!

 


Cearbhall O'Meadhra
 

Chris,

 

Yes, I have found that that is the most efficient way to get around the problem. NVDA reads the tables in adobe perfectly with the read cell commands. However, it cannot set row and column headers as that command does not appear to be available in Adobe.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

 

I use the free version of Spam Reader to get rid of spam. The Professional version doesn't have this disclaimer in outgoing emails. Try Spam Reader for free now!

 


Quentin Christensen
 

Hi Cearbhall,

Just replied to your message on the Win10 group.  I'll repost what I wrote there here just as it may be useful to anyone in this group not in that group, but I see it is a confidential document so that answers my question about sharing it with me.

It could be in Protected view if you're opening it from an email attachemnt.  By default Word shows those files in "Read mode" which is really annoying to navigate.  In the reply below I noted how to get around that if it is the issue.  Ok what follows is my original reply:

Re the strange Word template, if the document isn't too sensitive and you can send it to me privately I'd be happy to have a look - it might be something we can work on addressing.

As you've found with other files, NVDA's table commands SHOULD work on tables in Word.  As an intermediate workaround, possibly converting the document to HTML would enable it to be read as a web page.  If you go to File, Save As and from the filename field, press TAB to move to the "save as type" drop down and choose "Web page (*.htm, *.html)".

The HTML Word creates is ugly and bloated, but for reading it on a local machine, it might work.

When you open files from e-mail or the web, by default Word will open them in "reading view" which is possible to read but works very differently  (I wrote a section on it in the Word training material we'll be releasing in the next couple of months).  What I would recommend, is if you go into the Word options (alt+f then t), on that first, general page, tab to an option called "Open e-mail attachments and other uneditable files in reading view", and uncheck that - If you open a file from an email attachment etc then, it will open in the regular print layout so you can navigate as normal.  It will still be protected, so you'll need to press F6 to go to the "Protected view grouping" and press the "enable editing" button if you trust the sender and want to enable editing.

When you open any of the Office 2016 programs, instead of opening to a blank document / spreadsheet etc, it opens to the start screen.  You can either press ENTER to open a blank document, or you can navigate around to recent files or templates.  If you want to go back to the old style of opening directly to a blank file, go into the settings again and on that general page, the option after the one about opening email attachments is "show the start screen when this application starts" which you'll want to uncheck.

These options only apply to the current program so you'll need to uncheck it in Excel and any other Office programs you use too.

Re opening recent documents from the file list - Do you mean when you press alt+f you can press up arrow and find them listed at the bottom near exit?  You actually can do that:  Back in the options, this time control+tab down to "advanced", then tab a heap of times, or press alt+q to jump straight to "Quickly access this number of recent documents".  Once you check that option, you can tab to the next edit field which has a number (4 by default) and set that to whatever you like.

What that does, is visually, it puts the recent files at the bottom of the file menu, although if you press up arrow or shift+tab it actually starts moving around the file info tab, so instead you need to press either a number (1 for the most recent, 2 for the next most recent etc), or down arrow to the list.  Interestingly once you start down arrowing and get to the "new" tab, you could then up arrow twice to get to the last recent file in the list, but I haven't found a more direct way (if anyone does, please let me know!).

Note: most of this will be in the "Microsoft Word with NVDA" material, available in the next couple of months.  It is designed as a follow up to the "Basic Training for NVDA" module which is available now: http://www.nvaccess.org/shop/

Kind regards

Quentin.

On Fri, Jul 22, 2016 at 7:06 AM, Cearbhall O'Meadhra <cearbhall.omeadhra@...> wrote:

Chris,

 

Yes, I have found that that is the most efficient way to get around the problem. NVDA reads the tables in adobe perfectly with the read cell commands. However, it cannot set row and column headers as that command does not appear to be available in Adobe.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

 

I use the free version of Spam Reader to get rid of spam. The Professional version doesn't have this disclaimer in outgoing emails. Try Spam Reader for free now!

 




--
Quentin Christensen
Training Material Developer

Ph +61 7 3149 3306 
Direct: +61 413 904 383
www.nvaccess.org 
Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Cearbhall O'Meadhra
 

Quentin,

 

What a magnificent reply! I will keep this nearby for future reference. I look forward to the full document when it comes out.

 

Strangely, something has changed! I now find that I can read the offending table. I spent about four hours yesterday struggling with various ways of reading the document and getting a full analysis of how the table was created.

 

As I reported last night, I found that I was able to read word documents without any trouble by the end of the evening. Prompted by your request this morning, I went to the original file attachment, saved it again, unblocked it  and tried the table in both browse and focus modes. I was surprised to find that now the reading command works fine (control+alt+arrow keys).

 

The start-up screen is just as you describe, so I will try to remove that as you instruct.

 

I apologise for raising an issue that has just evaporated! However, I welcome the advice which you have given today.

 

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

 

I use the free version of Spam Reader to get rid of spam. The Professional version doesn't have this disclaimer in outgoing emails. Try Spam Reader for free now!

 


Quentin Christensen
 

Oh that's ok - there were several things you ran into there and that
always compounds things! Sometimes just restarting (the app, the
computer, the user) does wonders even when it shouldn't seem to make a
difference.

All the best!

Quentin.

--
22 Point

Web: http://www.22point.com.au
Facebook: https://www.facebook.com/22Point
Twitter: https://twitter.com/22PointApps

Check out our first app, RapiTap! - Tap targets fast & avoid decoys:
Adrenaline pumping, Challenging, Accessible!
https://play.google.com/store/apps/details?id=au.com.twentytwopoint.rapitap
Free trial: https://play.google.com/store/apps/details?id=au.com.twentytwopoint.rapitapfree


On 22 July 2016 at 18:06, Cearbhall O'Meadhra
<cearbhall.omeadhra@blbc.ie> wrote:
Quentin,



What a magnificent reply! I will keep this nearby for future reference. I
look forward to the full document when it comes out.



Strangely, something has changed! I now find that I can read the offending
table. I spent about four hours yesterday struggling with various ways of
reading the document and getting a full analysis of how the table was
created.



As I reported last night, I found that I was able to read word documents
without any trouble by the end of the evening. Prompted by your request this
morning, I went to the original file attachment, saved it again, unblocked
it and tried the table in both browse and focus modes. I was surprised to
find that now the reading command works fine (control+alt+arrow keys).



The start-up screen is just as you describe, so I will try to remove that as
you instruct.



I apologise for raising an issue that has just evaporated! However, I
welcome the advice which you have given today.





All the best,



Cearbhall



m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@blbc.ie







I use the free version of Spam Reader to get rid of spam. The Professional
version doesn't have this disclaimer in outgoing emails. Try Spam Reader for
free now!