problem with addon updater


Darren Harris
 

Hi,

 

I’ve tried uninstalling and reinstalling addon updater. I can’t get the check for updates option to show up at all.


 

Hi,

Which NVDA version do you have? If it is 2018.2, chances are that it might be something going wrong when the add-on starts, or somehow the installation has become corrupt.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Darren Harris via Groups.Io
Sent: Saturday, August 11, 2018 2:29 PM
To: nvda@nvda.groups.io
Subject: [nvda] problem with addon updater

 

Hi,

 

I’ve tried uninstalling and reinstalling addon updater. I can’t get the check for updates option to show up at all.


Darren Harris
 

Hi, it is the latest version.


On 11 Aug 2018, at 22:46, Joseph Lee <joseph.lee22590@...> wrote:

Hi,

Which NVDA version do you have? If it is 2018.2, chances are that it might be something going wrong when the add-on starts, or somehow the installation has become corrupt.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Darren Harris via Groups.Io
Sent: Saturday, August 11, 2018 2:29 PM
To: nvda@nvda.groups.io
Subject: [nvda] problem with addon updater

 

Hi,

 

I’ve tried uninstalling and reinstalling addon updater. I can’t get the check for updates option to show up at all.


Brian's Mail list account <bglists@...>
 

I'm in the same position with it on the beta 2 version installed, yet alpha snaps are working as portable and the add on is OK there. Look at the errors I posted on the add ons list. It seems to be the eof error that is doing it. I cannot see any difference between the add ons on both systems, so unless the beta of nvda latest version is somehow different. I have had to turn it off as all I get otherwise is an error on nvda start up and no menu option.
Could there be some remnant of something left that its seeing as a file it needs to scan?
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Joseph Lee" <joseph.lee22590@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Saturday, August 11, 2018 10:46 PM
Subject: Re: [nvda] problem with addon updater


Hi,

Which NVDA version do you have? If it is 2018.2, chances are that it might
be something going wrong when the add-on starts, or somehow the installation
has become corrupt.

Cheers,

Joseph



From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Darren Harris
via Groups.Io
Sent: Saturday, August 11, 2018 2:29 PM
To: nvda@nvda.groups.io
Subject: [nvda] problem with addon updater



Hi,



I've tried uninstalling and reinstalling addon updater. I can't get the
check for updates option to show up at all.






David Moore
 

Yes, I am getting the same results!

Updater works great with alpha snapshots, but not with beta!

David Moore

 

Sent from Mail for Windows 10

 

From: Brian's Mail list account via Groups.Io
Sent: Sunday, August 12, 2018 3:59 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] problem with addon updater

 

I'm in the same position with it on the beta 2 version installed, yet alpha

snaps are working as portable and the add on is OK there. Look at the errors

I posted on the add ons list. It seems to be the eof error that is doing it.

I cannot see any difference between the add ons on both systems, so unless

the beta of nvda latest version is somehow different. I have had to turn it

off as all I get otherwise is an error on nvda start up and no menu option.

Could there be some remnant of something left that its seeing as a file it

needs to scan?

Brian

 

bglists@...

Sent via blueyonder.

Please address personal E-mail to:-

briang1@..., putting 'Brian Gaff'

in the display name field.

----- Original Message -----

From: "Joseph Lee" <joseph.lee22590@...>

To: <nvda@nvda.groups.io>

Sent: Saturday, August 11, 2018 10:46 PM

Subject: Re: [nvda] problem with addon updater

 

 

> Hi,

> Which NVDA version do you have? If it is 2018.2, chances are that it might

> be something going wrong when the add-on starts, or somehow the

> installation

> has become corrupt.

> Cheers,

> Joseph

> From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Darren Harris

> via Groups.Io

> Sent: Saturday, August 11, 2018 2:29 PM

> To: nvda@nvda.groups.io

> Subject: [nvda] problem with addon updater

> Hi,

> I've tried uninstalling and reinstalling addon updater. I can't get the

> check for updates option to show up at all.

>

>

 

 

 

 


 

Hi,

I see. Could you mind sending me a log (preferably privately if set to debug log output) so we can find out what’s going on? Thanks.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Darren Harris via Groups.Io
Sent: Saturday, August 11, 2018 10:59 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] problem with addon updater

 

Hi, it is the latest version.


On 11 Aug 2018, at 22:46, Joseph Lee <joseph.lee22590@...> wrote:

Hi,

Which NVDA version do you have? If it is 2018.2, chances are that it might be something going wrong when the add-on starts, or somehow the installation has become corrupt.

Cheers,

Joseph

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Darren Harris via Groups.Io
Sent: Saturday, August 11, 2018 2:29 PM
To: nvda@nvda.groups.io
Subject: [nvda] problem with addon updater

 

Hi,

 

I’ve tried uninstalling and reinstalling addon updater. I can’t get the check for updates option to show up at all.


Brian's Mail list account <bglists@...>
 

Do you think its wx4 perhaps the syntax is not supported in the older version?
When I looked at the code that failed it seems to be not watching for the error its actually seeing, but not knowing enough about the inner workings of python, I cannot really see how to make it work correctly. Joseph will have to do a fix.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "David Moore" <jesusloves1966@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Sunday, August 12, 2018 9:17 AM
Subject: Re: [nvda] problem with addon updater


Yes, I am getting the same results!
Updater works great with alpha snapshots, but not with beta!
David Moore

Sent from Mail for Windows 10

From: Brian's Mail list account via Groups.Io
Sent: Sunday, August 12, 2018 3:59 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] problem with addon updater

I'm in the same position with it on the beta 2 version installed, yet alpha
snaps are working as portable and the add on is OK there. Look at the errors
I posted on the add ons list. It seems to be the eof error that is doing it.
I cannot see any difference between the add ons on both systems, so unless
the beta of nvda latest version is somehow different. I have had to turn it
off as all I get otherwise is an error on nvda start up and no menu option.
Could there be some remnant of something left that its seeing as a file it
needs to scan?
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Joseph Lee" <joseph.lee22590@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Saturday, August 11, 2018 10:46 PM
Subject: Re: [nvda] problem with addon updater


Hi,

Which NVDA version do you have? If it is 2018.2, chances are that it might
be something going wrong when the add-on starts, or somehow the
installation
has become corrupt.

Cheers,

Joseph



From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Darren Harris
via Groups.Io
Sent: Saturday, August 11, 2018 2:29 PM
To: nvda@nvda.groups.io
Subject: [nvda] problem with addon updater



Hi,



I've tried uninstalling and reinstalling addon updater. I can't get the
check for updates option to show up at all.







Clare Page <clare.page@...>
 

Hi !

It isn’t just in alpha and beta snapshots of NVDA that this problem with Add-On Updater occurs: I have had it twice using the latest full version of NVDA, 2018.2.1, on a Windows 7 computer.

I had already had that problem when I installed Add-On Updater 18.08.4, but at the time, having read that it was a patch to get rid of a bug in 18.08.3 which I had never installed, I thought maybe skipping versions might be to blame; When I read on this list about the release of Add-On Updater 18.08.5, I did a clean install of that version, and I still don’t have Check For Updates in my NVDA Tools menu, nor anything to do with the add-on updater in my NVDA settings.

It’s interesting that only a few of us have this bug. Does this add-on only work for Windows 8 or Windows 10? Or is there something else causing this problem, Thanks in advance for any possible theories in answer to these questions.

Bye for now!

From Clare

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of David Moore
Sent: dimanche 12 août 2018 10:18
To: nvda@nvda.groups.io
Subject: Re: [nvda] problem with addon updater

 

Yes, I am getting the same results!

Updater works great with alpha snapshots, but not with beta!

David Moore

 

Sent from Mail for Windows 10

 

From: Brian's Mail list account via Groups.Io
Sent: Sunday, August 12, 2018 3:59 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] problem with addon updater

 

I'm in the same position with it on the beta 2 version installed, yet alpha

snaps are working as portable and the add on is OK there. Look at the errors

I posted on the add ons list. It seems to be the eof error that is doing it.

I cannot see any difference between the add ons on both systems, so unless

the beta of nvda latest version is somehow different. I have had to turn it

off as all I get otherwise is an error on nvda start up and no menu option.

Could there be some remnant of something left that its seeing as a file it

needs to scan?

Brian

 

bglists@...

Sent via blueyonder.

Please address personal E-mail to:-

briang1@..., putting 'Brian Gaff'

in the display name field.

----- Original Message -----

From: "Joseph Lee" <joseph.lee22590@...>

To: <nvda@nvda.groups.io>

Sent: Saturday, August 11, 2018 10:46 PM

Subject: Re: [nvda] problem with addon updater

 

 

> Hi,

> Which NVDA version do you have? If it is 2018.2, chances are that it might

> be something going wrong when the add-on starts, or somehow the

> installation

> has become corrupt.

> Cheers,

> Joseph

> From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Darren Harris

> via Groups.Io

> Sent: Saturday, August 11, 2018 2:29 PM

> To: nvda@nvda.groups.io

> Subject: [nvda] problem with addon updater

> Hi,

> I've tried uninstalling and reinstalling addon updater. I can't get the

> check for updates option to show up at all.

>

>

 

 

 

 


Kevin Cussick
 

running nvda beta2 and windows10 home 64 bit and having no problems. strange.

On 13/08/2018 10:16, Clare Page wrote:
Hi !
It isn’t just in alpha and beta snapshots of NVDA that this problem with Add-On Updater occurs: I have had it twice using the latest full version of NVDA, 2018.2.1, on a Windows 7 computer.
I had already had that problem when I installed Add-On Updater 18.08.4, but at the time, having read that it was a patch to get rid of a bug in 18.08.3 which I had never installed, I thought maybe skipping versions might be to blame; When I read on this list about the release of Add-On Updater 18.08.5, I did a clean install of that version, and I still don’t have Check For Updates in my NVDA Tools menu, nor anything to do with the add-on updater in my NVDA settings.
It’s interesting that only a few of us have this bug. Does this add-on only work for Windows 8 or Windows 10? Or is there something else causing this problem, Thanks in advance for any possible theories in answer to these questions.
Bye for now!
From Clare
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of David Moore
Sent: dimanche 12 août 2018 10:18
To: nvda@nvda.groups.io
Subject: Re: [nvda] problem with addon updater
Yes, I am getting the same results!
Updater works great with alpha snapshots, but not with beta!
David Moore
Sent from Mail <https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10
From: Brian's Mail list account via Groups.Io <mailto:bglists=blueyonder.co.uk@groups.io>
Sent: Sunday, August 12, 2018 3:59 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] problem with addon updater
I'm in the same position with it on the beta 2 version installed, yet alpha
snaps are working as portable and the add on is OK there. Look at the errors
I posted on the add ons list. It seems to be the eof error that is doing it.
I cannot see any difference between the add ons on both systems, so unless
the beta of nvda latest version is somehow different. I have had to turn it
off as all I get otherwise is an error on nvda start up and no menu option.
Could there be some remnant of something left that its seeing as a file it
needs to scan?
Brian
bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Joseph Lee" <joseph.lee22590@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Saturday, August 11, 2018 10:46 PM
Subject: Re: [nvda] problem with addon updater

Hi,
Which NVDA version do you have? If it is 2018.2, chances are that it might
be something going wrong when the add-on starts, or somehow the
installation
has become corrupt.
Cheers,
Joseph
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Darren Harris
via Groups.Io
Sent: Saturday, August 11, 2018 2:29 PM
To: nvda@nvda.groups.io
Subject: [nvda] problem with addon updater
Hi,
I've tried uninstalling and reinstalling addon updater. I can't get the
check for updates option to show up at all.