NVDA remote server refusing to auto start on debian8, any ideas?


Mobeen Iqbal
 

Hello Everyone.


I am new here, so please forgive me if this has been covered before. I am trying to get the NVDA remote server available on git hub running on my server running debian8 Jessie.


I have done the  following to get version 1.8 installed and running, but debian still refuses to automatically start the server on boot. I am executing all commands as root.


git clone https://github.com/jmdaweb/NVDARemoteServer.git


cd NVDARemoteServer/debian8


sudo chmod +x build.sh


sudo ./build.sh


sudo dpkg -i nvda-remote-server_1.8.deb


sudo NVDARemoteServer enable


In the past, the above commands have worked fine on debian7. Running the latest versions of all packages available for jessie. Anyone have any ideas on what else I can try?


Cheers,


Mo.


Christian Schoepplein
 

Hi,

On Wed, 26 Sep 2018 09:53:03 +0100, Mobeen Iqbal wrote:

I am trying to get the NVDA remote server available on git hub
running on my server running debian8 Jessie.
Are there any errors in the logs or can the server be executed in debug mode to get more information? Without an error message or more detailed logs it is hart to find the problem...

Cheers,

Schoepp


Patrick ZAJDA
 

Hello,

Why don't you use systemd?
sudo systemctl start NVDARemoteServer.service
The debian package install it, if this is not the case look for the path
to the PID file in /etc/nvdaremote.conf
It should be: /var/run/NVDARemoteServer/NVDARemoteServer.pid

Hop this helps.

Le 26/09/2018 à 10:53, Mobeen Iqbal a écrit :
Hello Everyone.


I am new here, so please forgive me if this has been covered before. I
am trying to get the NVDA remote server available on git hub running on
my server running debian8 Jessie.


I have done the  following to get version 1.8 installed and running, but
debian still refuses to automatically start the server on boot. I am
executing all commands as root.


git clone https://github.com/jmdaweb/NVDARemoteServer.git


cd NVDARemoteServer/debian8


sudo chmod +x build.sh


sudo ./build.sh


sudo dpkg -i nvda-remote-server_1.8.deb


sudo NVDARemoteServer enable


In the past, the above commands have worked fine on debian7. Running the
latest versions of all packages available for jessie. Anyone have any
ideas on what else I can try?


Cheers,


Mo.





Mobeen Iqbal
 

Hi.


Many thanks for the emails I've received so far. In terms of log output, does the following help? The server claims to be receiving some kind of signal from the system to terminate. what's causing the termination?


Loggin system initialized.
Wed Sep 26 11:59:25 2018
Configuring signal handlers
Wed Sep 26 11:59:25 2018
Initialized instance variables
Wed Sep 26 11:59:25 2018
Socket created.
Wed Sep 26 11:59:25 2018
Enabled ssl in socket.
Wed Sep 26 11:59:25 2018
Setting socket options...
Wed Sep 26 11:59:25 2018
IPV6 socket has started listening on port 6837
Wed Sep 26 11:59:25 2018
IPV4 socket has not been created
Wed Sep 26 11:59:25 2018
NVDA Remote Server is ready.
Wed Sep 26 11:59:25 2018
The server is using TLS v 1.2
Wed Sep 26 11:59:25 2018
The server is running with pid 451
Wed Sep 26 12:00:54 2018
Received system signal. Waiting for server stop.
Wed Sep 26 12:01:25 2018
Shuting down server...
Wed Sep 26 12:01:25 2018
Closing channels...
Wed Sep 26 12:01:25 2018
Disconnecting clients...
Wed Sep 26 12:01:25 2018
Closing server socket...
Closing logger thread...

How can I run the server in debug mode as a service? Would debug mode append more descriptive messages to the above log?


Many thanks,


Mo.

On 26/09/2018 11:45, Patrick ZAJDA via Groups.Io wrote:
Hello,

Why don't you use systemd?
sudo systemctl start NVDARemoteServer.service
The debian package install it, if this is not the case look for the path
to the PID file in /etc/nvdaremote.conf
It should be: /var/run/NVDARemoteServer/NVDARemoteServer.pid

Hop this helps.

Le 26/09/2018 à 10:53, Mobeen Iqbal a écrit :
Hello Everyone.


I am new here, so please forgive me if this has been covered before. I
am trying to get the NVDA remote server available on git hub running on
my server running debian8 Jessie.


I have done the  following to get version 1.8 installed and running, but
debian still refuses to automatically start the server on boot. I am
executing all commands as root.


git clone https://github.com/jmdaweb/NVDARemoteServer.git


cd NVDARemoteServer/debian8


sudo chmod +x build.sh


sudo ./build.sh


sudo dpkg -i nvda-remote-server_1.8.deb


sudo NVDARemoteServer enable


In the past, the above commands have worked fine on debian7. Running the
latest versions of all packages available for jessie. Anyone have any
ideas on what else I can try?


Cheers,


Mo.





Mobeen Iqbal
 

Hi.


Further to my last email containing the log, I tried running the server in debug mode. The server has so far not exited when running in debug mode, so it would be a little pointless me posting a log here as the problem is not occurring in debug mode. I have added an entry to /etc/rc.local to make it run in debug mode for now in the backround, but I will post this issue on git hub if no one has any further ideas. To replicate, install the latest server on a fully up to date jessie install and try to enable it as a service. When you restart, the server will run for a few minutes. Then it will receive a kill command or similar from debian and exit as shown in the previous log I posted. Now try disabling the service and adding an entry to /etc/rc.local with sudo -u root NVDARemoteServer debug&

this will make the server run next time you reboot. When you reboot, the server stays running as it should. Very strange indeed. Does anyone have a debian system such as a raspberry pi to replicate? So far I have tested on a VPS and pi both running clean installs of debian.


Cheers,


Mo.

On 26/09/2018 11:45, Patrick ZAJDA via Groups.Io wrote:
Hello,

Why don't you use systemd?
sudo systemctl start NVDARemoteServer.service
The debian package install it, if this is not the case look for the path
to the PID file in /etc/nvdaremote.conf
It should be: /var/run/NVDARemoteServer/NVDARemoteServer.pid

Hop this helps.

Le 26/09/2018 à 10:53, Mobeen Iqbal a écrit :
Hello Everyone.


I am new here, so please forgive me if this has been covered before. I
am trying to get the NVDA remote server available on git hub running on
my server running debian8 Jessie.


I have done the  following to get version 1.8 installed and running, but
debian still refuses to automatically start the server on boot. I am
executing all commands as root.


git clone https://github.com/jmdaweb/NVDARemoteServer.git


cd NVDARemoteServer/debian8


sudo chmod +x build.sh


sudo ./build.sh


sudo dpkg -i nvda-remote-server_1.8.deb


sudo NVDARemoteServer enable


In the past, the above commands have worked fine on debian7. Running the
latest versions of all packages available for jessie. Anyone have any
ideas on what else I can try?


Cheers,


Mo.