Some time nvda seems quite laggy in my laptop. I am using asus laptop with windows 10 1803, latest version of nvda and I have 8 gb ram along with ssd as well Most of the time nvda is unable to respond specially on file explorer, eg When I open this-pc nvda stop reading all those list as local disk c, d and other shortcut icon. This is mainly happening when I am using some other program in the background, if I am downloading some thing then I open file explorer then nvda keeps quite. In another case if I had close other running program and open file explorer then also nvda’s feedback is very slow and laggy. I do have another disappointing experience with nvda, mainly I have to work in a Microsoft office’s program like word, excel etc in their also nvda gives very let respond while typing and reading. Please fixed this issue if possible, thankyou Madhusudan ghimire from Nepal.

Quentin Christensen


I responded over the weekend on Facebook and to your direct message about this, so I won't repeat the conversation here (for anyone else, try restarting NVDA with addons disabled, ensure you are using the latest version of NVDA, and consider trying the latest alpha snapshot.  Also consider what else is happening on the PC, and also consider using a less frugal power setting in Windows.  Some people find they need to use "Always On", others can use a more power saving setting).

What I did want to add here though, was that you've written your entire message in the subject.  In email, it is best to write only a few words in the subject "NVDA lagging in File Explorer", for instance, and write the main text and further description in the body of the message itself.

Kind regards


On Fri, Oct 12, 2018 at 10:40 PM <ma.sudan.10@...> wrote:
nvda's slow respond and laggy issue

Quentin Christensen
Training and Support Manager

Official NVDA Training modules and expert certification now available:

Twitter: @NVAccess 


nvda's slow respond and laggy issue