Topics

Add-on Updater 18.12.2 released, manual update recommended, Python 3 readiness #addonrelease


 

Hi all,

 

For those on development list, don’t worry about the hashtag.

 

I’m delighted to announce immediate release of Add-on Updater 18.12.2. In addition to localization updates, today’s update fixes an outstanding issue when installed on latest NVDA alpha builds, namely inability to download updates.

 

Also, I’m happy to announce that Add-on Updater is Python 3 ready. Although there are things to be done here and there, for the most part, it’ll run under Python 3 version of NVDA. At the same time, I have updated last tested version flag so you won’t have to sorry about running to issues until NVDA 2019.3.

 

IMPORTANT: Add-on Updater 18.12.x is the last series to run on NVDA 2018.2. Starting from version 19.01, NVDA 2018.4 will be required.

 

For consideration for people using alpha snapshots and found themselves unable to update add-ons, I’ll be asking those on alpha snapshots to manually apply today’s build. For those using 2018.3.x and 2018.4 betas, you can go ahead and check for add-on updates.

 

The manual download link is:

https://addons.nvda-project.org/files/get.php?file=nvda3208

 

Cheers,

Joseph


Brian's Mail list account <bglists@...>
 

Now its not happened this time, so maybe it remembers things between the portable and the installed versions? How can this be?
Really irritating though!
Brian

----- Original Message -----
From: "Joseph Lee" <@joslee>
To: "'NVDA screen reader development'" <nvda-devel@...>
Sent: Saturday, December 08, 2018 5:09 PM
Subject: [nvda] Add-on Updater 18.12.2 released, manual update recommended, Python 3 readiness #AddonRelease


Hi all,



For those on development list, don't worry about the hashtag.



I'm delighted to announce immediate release of Add-on Updater 18.12.2. In
addition to localization updates, today's update fixes an outstanding issue
when installed on latest NVDA alpha builds, namely inability to download
updates.



Also, I'm happy to announce that Add-on Updater is Python 3 ready. Although
there are things to be done here and there, for the most part, it'll run
under Python 3 version of NVDA. At the same time, I have updated last tested
version flag so you won't have to sorry about running to issues until NVDA
2019.3.



IMPORTANT: Add-on Updater 18.12.x is the last series to run on NVDA 2018.2.
Starting from version 19.01, NVDA 2018.4 will be required.



For consideration for people using alpha snapshots and found themselves
unable to update add-ons, I'll be asking those on alpha snapshots to
manually apply today's build. For those using 2018.3.x and 2018.4 betas, you
can go ahead and check for add-on updates.



The manual download link is:

https://addons.nvda-project.org/files/get.php?file=nvda3208



Cheers,

Joseph




Brian's Mail list account <bglists@...>
 

Hi Joseph, is this error expected on the latest Alpha snap?

IO - speech.speak (19:46:03.266):
Speaking [LangChangeCommand ('en_GB'), u'Update add-ons button Alt+u']
IO - inputCore.InputManager.executeGesture (19:46:04.933):
Input: kb(desktop):space
IO - speech._speakSpellingGen (19:46:04.948):
Speaking character u'space'
DEBUG - queueHandler.registerGeneratorObject (19:46:04.950):
Adding generator 2
IO - speech.speak (19:46:04.950):
Speaking [LangChangeCommand ('en_GB'), u'pressed']
DEBUG - queueHandler.pumpAll (19:46:04.966):
generator 2 finished
IO - speech.speak (19:46:05.224):
Speaking [LangChangeCommand ('en_GB'), u'Downloading Add-on Update dialog Downloading Add-on Updater']
IO - speech.speak (19:46:05.230):
Speaking [LangChangeCommand ('en_GB'), u'Cancel button']
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (19:46:05.999):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 7 and childID 0: [Error -2147467259] Unspecified error
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (19:46:06.003):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 8 and childID 0: [Error -2147467259] Unspecified error
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (19:46:06.007):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 9 and childID 0: [Error -2147467259] Unspecified error
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (19:46:06.007):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 10 and childID 0: [Error -2147467259] Unspecified error
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (19:46:06.010):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 11 and childID 0: [Error -2147467259] Unspecified error
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (19:46:06.012):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 12 and childID 0: [Error -2147467259] Unspecified error
ERROR - updateCheck.UpdateDownloader._bg (19:46:06.026):
Error downloading https://addons.nvda-project.org/files/addonUpdater-18.12.2.nvda-addon
Traceback (most recent call last):
File "updateCheck.pyc", line 588, in _bg
File "updateCheck.pyc", line 643, in _download
File "fileUtils.pyc", line 56, in getFileVersionInfo
RuntimeError: No version information
IO - speech.speak (19:46:06.132):
Speaking [LangChangeCommand ('en_GB'), u'Error dialog Error downloading update for Add-on Updater.']
IO - speech.speak (19:46:06.140):
Speaking [LangChangeCommand ('en_GB'), u'OK button']
IO - inputCore.InputManager.executeGesture (19:46:09.749):
Input: kb(desktop):enter
DEBUGWARNING - NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole (19:46:09.772):
accRole failed: (-2147024809, 'The parameter is incorrect.', (None, None, None, 0, None))
DEBUGWARNING - NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole (19:46:09.808):
accRole failed: (-2147467259, 'Unspecified error', (None, None, None, 0, None))
IO - speech.speak (19:46:09.828):
Speaking [LangChangeCommand ('en_GB'), u'Downloading Add-on Update dialog Downloading']
IO - speech.speak (19:46:09.836):
Speaking [LangChangeCommand ('en_GB'), u'Cancel button']
DEBUGWARNING - NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole (19:46:10.039):
accRole failed: (-2147024809, 'The parameter is incorrect.', (None, None, None, 0, None))
IO - speech.speak (19:46:10.140):
Speaking [LangChangeCommand ('en_GB'), u'1 nvda mail list - Outlook Express - Brians lists account BGlists']
DEBUGWARNING - NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole (19:46:10.236):
accRole failed: (-2147418094, 'The callee (server [not server application]) is not available and disappeared; all connections are invalid. The call did not execute.', (None, None, None, 0, None))
IO - speech.speak (19:46:10.236):
Speaking [LangChangeCommand ('en_GB'), u'Outlook Express Message List list']
IO - speech.speak (19:46:10.326):
Speaking [LangChangeCommand ('en_GB'), u"From: Brian's Mail list account via Groups.Io; Subject: [nvda] Funny thing happened at the update today; Received: 08/12/2018 18:00 38218 of 38218"]
IO - inputCore.InputManager.executeGesture (19:46:11.132):
Input: kb(desktop):control+alt+r
IO - speech.speak (19:46:11.266):
Speaking [LangChangeCommand ('en_GB'), u'Taskbar']
IO - speech.speak (19:46:11.315):
Speaking [LangChangeCommand ('en_GB'), u'reboot nvda with log terminal']
IO - speech.speak (19:46:11.316):
Speaking [LangChangeCommand ('en_GB'), u'80 space', u'blank']
INFO - core.main (19:46:11.361):
Exiting
DEBUG - core._terminate (19:46:11.361):
Terminating updateCheck
DEBUG - core._terminate (19:46:11.361):
Terminating watchdog
DEBUG - core._terminate (19:46:11.361):
Terminating global plugin handler
DEBUGWARNING - Python warning (19:46:11.875):
C:\nvda extra\userConfig\addons\AudioThemes3D\globalPlugins\audioThemes\__init__.py:113: wxPyDeprecationWarning: Call to deprecated item. Use Remove instead.
DEBUGWARNING - Python warning (19:46:11.875):
C:\nvda extra\userConfig\addons\AudioThemes3D\globalPlugins\AudioThemes3D_docHandler.py:66: wxPyDeprecationWarning: Call to deprecated item. Use Remove instead.
DEBUGWARNING - Python warning (19:46:11.881):
C:\nvda extra\userConfig\addons\mp3DirectCut\globalPlugins\mp3DirectCut\__init__.py:45: wxPyDeprecationWarning: Call to deprecated item. Use Remove instead.
DEBUG - core._terminate (19:46:11.881):
Terminating gui
DEBUG - fileUtils.FaultTolerantFile (19:46:11.892):
C:\nvda extra\userConfig\nvda.inimkrcqm.tmp
INFO - config.ConfigManager.save (19:46:11.913):
Base configuration saved
DEBUG - core.main (19:46:11.913):
calling lose focus on object with focus
DEBUG - core._terminate (19:46:11.914):
Terminating treeInterceptorHandler
DEBUG - core._terminate (19:46:11.915):
Terminating IAccessible support
DEBUG - core._terminate (19:46:11.915):
Terminating UIA support
DEBUGWARNING - _UIAHandler.UIAHandler.terminate (19:46:12.115):
Timeout or error while waiting for UIAHandler MTA thread
DEBUG - core._terminate (19:46:12.115):
Terminating winConsole support
DEBUG - core._terminate (19:46:12.115):
Terminating Java Access Bridge support
DEBUG - core._terminate (19:46:12.115):
Terminating app module handler
DEBUG - core._terminate (19:46:12.115):
Terminating NVDAHelper
DEBUG - core._terminate (19:46:12.127):
Terminating touchHandler
DEBUG - core._terminate (19:46:12.127):
Terminating keyboard handler
DEBUG - core._terminate (19:46:12.127):
Terminating mouseHandler
DEBUG - core._terminate (19:46:12.128):
Terminating inputCore
DEBUG - core._terminate (19:46:12.128):
Terminating brailleInput
DEBUG - core._terminate (19:46:12.128):
Terminating braille
DEBUG - core._terminate (19:46:12.128):
Terminating speech
DEBUG - core._terminate (19:46:12.128):
Terminating addonHandler
DEBUG - core.main (19:46:13.183):
core done
INFO - __main__ (19:46:13.206):
NVDA exit


Brian
bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Joseph Lee" <@joslee>
To: "'NVDA screen reader development'" <nvda-devel@...>
Sent: Saturday, December 08, 2018 5:09 PM
Subject: [nvda] Add-on Updater 18.12.2 released, manual update recommended, Python 3 readiness #AddonRelease


Hi all,



For those on development list, don't worry about the hashtag.



I'm delighted to announce immediate release of Add-on Updater 18.12.2. In
addition to localization updates, today's update fixes an outstanding issue
when installed on latest NVDA alpha builds, namely inability to download
updates.



Also, I'm happy to announce that Add-on Updater is Python 3 ready. Although
there are things to be done here and there, for the most part, it'll run
under Python 3 version of NVDA. At the same time, I have updated last tested
version flag so you won't have to sorry about running to issues until NVDA
2019.3.



IMPORTANT: Add-on Updater 18.12.x is the last series to run on NVDA 2018.2.
Starting from version 19.01, NVDA 2018.4 will be required.



For consideration for people using alpha snapshots and found themselves
unable to update add-ons, I'll be asking those on alpha snapshots to
manually apply today's build. For those using 2018.3.x and 2018.4 betas, you
can go ahead and check for add-on updates.



The manual download link is:

https://addons.nvda-project.org/files/get.php?file=nvda3208



Cheers,

Joseph




 

Hi,
That's exactly the bug I fixed in 18.12.2, which will require a manual
update for this reason.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Brian's Mail
list account via Groups.Io
Sent: Saturday, December 8, 2018 11:54 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Add-on Updater 18.12.2 released, manual update
recommended, Python 3 readiness #AddonRelease

Hi Joseph, is this error expected on the latest Alpha snap?

IO - speech.speak (19:46:03.266):
Speaking [LangChangeCommand ('en_GB'), u'Update add-ons button Alt+u'] IO
- inputCore.InputManager.executeGesture (19:46:04.933):
Input: kb(desktop):space
IO - speech._speakSpellingGen (19:46:04.948):
Speaking character u'space'
DEBUG - queueHandler.registerGeneratorObject (19:46:04.950):
Adding generator 2
IO - speech.speak (19:46:04.950):
Speaking [LangChangeCommand ('en_GB'), u'pressed'] DEBUG -
queueHandler.pumpAll (19:46:04.966):
generator 2 finished
IO - speech.speak (19:46:05.224):
Speaking [LangChangeCommand ('en_GB'), u'Downloading Add-on Update dialog
Downloading Add-on Updater'] IO - speech.speak (19:46:05.230):
Speaking [LangChangeCommand ('en_GB'), u'Cancel button'] DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:05.999):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 7 and childID
0: [Error -2147467259] Unspecified error DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:06.003):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 8 and childID
0: [Error -2147467259] Unspecified error DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:06.007):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 9 and childID
0: [Error -2147467259] Unspecified error DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:06.007):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 10 and
childID 0: [Error -2147467259] Unspecified error DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:06.010):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 11 and
childID 0: [Error -2147467259] Unspecified error DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:06.012):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 12 and
childID 0: [Error -2147467259] Unspecified error ERROR -
updateCheck.UpdateDownloader._bg (19:46:06.026):
Error downloading
https://addons.nvda-project.org/files/addonUpdater-18.12.2.nvda-addon
Traceback (most recent call last):
File "updateCheck.pyc", line 588, in _bg
File "updateCheck.pyc", line 643, in _download
File "fileUtils.pyc", line 56, in getFileVersionInfo
RuntimeError: No version information
IO - speech.speak (19:46:06.132):
Speaking [LangChangeCommand ('en_GB'), u'Error dialog Error downloading
update for Add-on Updater.'] IO - speech.speak (19:46:06.140):
Speaking [LangChangeCommand ('en_GB'), u'OK button'] IO -
inputCore.InputManager.executeGesture (19:46:09.749):
Input: kb(desktop):enter
DEBUGWARNING - NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole
(19:46:09.772):
accRole failed: (-2147024809, 'The parameter is incorrect.', (None, None,
None, 0, None)) DEBUGWARNING -
NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole
(19:46:09.808):
accRole failed: (-2147467259, 'Unspecified error', (None, None, None, 0,
None))
IO - speech.speak (19:46:09.828):
Speaking [LangChangeCommand ('en_GB'), u'Downloading Add-on Update dialog
Downloading'] IO - speech.speak (19:46:09.836):
Speaking [LangChangeCommand ('en_GB'), u'Cancel button'] DEBUGWARNING -
NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole
(19:46:10.039):
accRole failed: (-2147024809, 'The parameter is incorrect.', (None, None,
None, 0, None)) IO - speech.speak (19:46:10.140):
Speaking [LangChangeCommand ('en_GB'), u'1 nvda mail list - Outlook Express
- Brians lists account BGlists'] DEBUGWARNING -
NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole
(19:46:10.236):
accRole failed: (-2147418094, 'The callee (server [not server application])
is not available and disappeared; all connections are invalid. The call did
not execute.', (None, None, None, 0, None)) IO - speech.speak
(19:46:10.236):
Speaking [LangChangeCommand ('en_GB'), u'Outlook Express Message List list']
IO - speech.speak (19:46:10.326):
Speaking [LangChangeCommand ('en_GB'), u"From: Brian's Mail list account via
Groups.Io; Subject: [nvda] Funny thing happened at the update today;
Received: 08/12/2018 18:00 38218 of 38218"] IO -
inputCore.InputManager.executeGesture (19:46:11.132):
Input: kb(desktop):control+alt+r
IO - speech.speak (19:46:11.266):
Speaking [LangChangeCommand ('en_GB'), u'Taskbar'] IO - speech.speak
(19:46:11.315):
Speaking [LangChangeCommand ('en_GB'), u'reboot nvda with log terminal'] IO
- speech.speak (19:46:11.316):
Speaking [LangChangeCommand ('en_GB'), u'80 space', u'blank'] INFO -
core.main (19:46:11.361):
Exiting
DEBUG - core._terminate (19:46:11.361):
Terminating updateCheck
DEBUG - core._terminate (19:46:11.361):
Terminating watchdog
DEBUG - core._terminate (19:46:11.361):
Terminating global plugin handler
DEBUGWARNING - Python warning (19:46:11.875):
C:\nvda
extra\userConfig\addons\AudioThemes3D\globalPlugins\audioThemes\__init__.py:
113:
wxPyDeprecationWarning: Call to deprecated item. Use Remove instead.
DEBUGWARNING - Python warning (19:46:11.875):
C:\nvda
extra\userConfig\addons\AudioThemes3D\globalPlugins\AudioThemes3D_docHandler
.py:66:
wxPyDeprecationWarning: Call to deprecated item. Use Remove instead.
DEBUGWARNING - Python warning (19:46:11.881):
C:\nvda
extra\userConfig\addons\mp3DirectCut\globalPlugins\mp3DirectCut\__init__.py:
45:
wxPyDeprecationWarning: Call to deprecated item. Use Remove instead.
DEBUG - core._terminate (19:46:11.881):
Terminating gui
DEBUG - fileUtils.FaultTolerantFile (19:46:11.892):
C:\nvda extra\userConfig\nvda.inimkrcqm.tmp
INFO - config.ConfigManager.save (19:46:11.913):
Base configuration saved
DEBUG - core.main (19:46:11.913):
calling lose focus on object with focus
DEBUG - core._terminate (19:46:11.914):
Terminating treeInterceptorHandler
DEBUG - core._terminate (19:46:11.915):
Terminating IAccessible support
DEBUG - core._terminate (19:46:11.915):
Terminating UIA support
DEBUGWARNING - _UIAHandler.UIAHandler.terminate (19:46:12.115):
Timeout or error while waiting for UIAHandler MTA thread DEBUG -
core._terminate (19:46:12.115):
Terminating winConsole support
DEBUG - core._terminate (19:46:12.115):
Terminating Java Access Bridge support
DEBUG - core._terminate (19:46:12.115):
Terminating app module handler
DEBUG - core._terminate (19:46:12.115):
Terminating NVDAHelper
DEBUG - core._terminate (19:46:12.127):
Terminating touchHandler
DEBUG - core._terminate (19:46:12.127):
Terminating keyboard handler
DEBUG - core._terminate (19:46:12.127):
Terminating mouseHandler
DEBUG - core._terminate (19:46:12.128):
Terminating inputCore
DEBUG - core._terminate (19:46:12.128):
Terminating brailleInput
DEBUG - core._terminate (19:46:12.128):
Terminating braille
DEBUG - core._terminate (19:46:12.128):
Terminating speech
DEBUG - core._terminate (19:46:12.128):
Terminating addonHandler
DEBUG - core.main (19:46:13.183):
core done
INFO - __main__ (19:46:13.206):
NVDA exit


Brian
bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Joseph Lee" <@joslee>
To: "'NVDA screen reader development'" <nvda-devel@...>
Sent: Saturday, December 08, 2018 5:09 PM
Subject: [nvda] Add-on Updater 18.12.2 released, manual update recommended,
Python 3 readiness #AddonRelease


Hi all,



For those on development list, don't worry about the hashtag.



I'm delighted to announce immediate release of Add-on Updater 18.12.2.
In addition to localization updates, today's update fixes an
outstanding issue when installed on latest NVDA alpha builds, namely
inability to download updates.



Also, I'm happy to announce that Add-on Updater is Python 3 ready.
Although
there are things to be done here and there, for the most part, it'll
run under Python 3 version of NVDA. At the same time, I have updated
last tested version flag so you won't have to sorry about running to
issues until NVDA 2019.3.



IMPORTANT: Add-on Updater 18.12.x is the last series to run on NVDA
2018.2.
Starting from version 19.01, NVDA 2018.4 will be required.



For consideration for people using alpha snapshots and found
themselves unable to update add-ons, I'll be asking those on alpha
snapshots to manually apply today's build. For those using 2018.3.x
and 2018.4 betas, you can go ahead and check for add-on updates.



The manual download link is:

https://addons.nvda-project.org/files/get.php?file=nvda3208



Cheers,

Joseph





Brian's Mail list account <bglists@...>
 

Oh I see, I think.
What I actually did is to remove it and start from scratch as you say from a browser.

It worked on the other versions of NVDa either the full or the beta though.

However at the risk of boring those not getting this problem, I'm still getting failure to restart nvda after any kind of nvda restart about half of the time with hat pesky windows error which one cannot read about access to the file is not possible, ie the nvda.log and the funny log in the nvda folder. One has to cancel the windows error blind or no nvda will run. I note with interest somebody else with a similar issue on the dev list . Maybe somebody could build in a pause when the nvda reboot system is invoked to give windows time to rename the log file before trying to write to a locked file half way through renaming to old?
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda@nvda.groups.io>
Sent: Saturday, December 08, 2018 11:00 PM
Subject: Re: [nvda] Add-on Updater 18.12.2 released, manual update recommended, Python 3 readiness #AddonRelease


Hi,
That's exactly the bug I fixed in 18.12.2, which will require a manual
update for this reason.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Brian's Mail
list account via Groups.Io
Sent: Saturday, December 8, 2018 11:54 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Add-on Updater 18.12.2 released, manual update
recommended, Python 3 readiness #AddonRelease

Hi Joseph, is this error expected on the latest Alpha snap?

IO - speech.speak (19:46:03.266):
Speaking [LangChangeCommand ('en_GB'), u'Update add-ons button Alt+u'] IO
- inputCore.InputManager.executeGesture (19:46:04.933):
Input: kb(desktop):space
IO - speech._speakSpellingGen (19:46:04.948):
Speaking character u'space'
DEBUG - queueHandler.registerGeneratorObject (19:46:04.950):
Adding generator 2
IO - speech.speak (19:46:04.950):
Speaking [LangChangeCommand ('en_GB'), u'pressed'] DEBUG -
queueHandler.pumpAll (19:46:04.966):
generator 2 finished
IO - speech.speak (19:46:05.224):
Speaking [LangChangeCommand ('en_GB'), u'Downloading Add-on Update dialog
Downloading Add-on Updater'] IO - speech.speak (19:46:05.230):
Speaking [LangChangeCommand ('en_GB'), u'Cancel button'] DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:05.999):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 7 and childID
0: [Error -2147467259] Unspecified error DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:06.003):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 8 and childID
0: [Error -2147467259] Unspecified error DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:06.007):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 9 and childID
0: [Error -2147467259] Unspecified error DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:06.007):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 10 and
childID 0: [Error -2147467259] Unspecified error DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:06.010):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 11 and
childID 0: [Error -2147467259] Unspecified error DEBUGWARNING -
IAccessibleHandler.accessibleObjectFromEvent (19:46:06.012):
oleacc.AccessibleObjectFromEvent with window 1115272, objectID 12 and
childID 0: [Error -2147467259] Unspecified error ERROR -
updateCheck.UpdateDownloader._bg (19:46:06.026):
Error downloading
https://addons.nvda-project.org/files/addonUpdater-18.12.2.nvda-addon
Traceback (most recent call last):
File "updateCheck.pyc", line 588, in _bg
File "updateCheck.pyc", line 643, in _download
File "fileUtils.pyc", line 56, in getFileVersionInfo
RuntimeError: No version information
IO - speech.speak (19:46:06.132):
Speaking [LangChangeCommand ('en_GB'), u'Error dialog Error downloading
update for Add-on Updater.'] IO - speech.speak (19:46:06.140):
Speaking [LangChangeCommand ('en_GB'), u'OK button'] IO -
inputCore.InputManager.executeGesture (19:46:09.749):
Input: kb(desktop):enter
DEBUGWARNING - NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole
(19:46:09.772):
accRole failed: (-2147024809, 'The parameter is incorrect.', (None, None,
None, 0, None)) DEBUGWARNING -
NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole
(19:46:09.808):
accRole failed: (-2147467259, 'Unspecified error', (None, None, None, 0,
None))
IO - speech.speak (19:46:09.828):
Speaking [LangChangeCommand ('en_GB'), u'Downloading Add-on Update dialog
Downloading'] IO - speech.speak (19:46:09.836):
Speaking [LangChangeCommand ('en_GB'), u'Cancel button'] DEBUGWARNING -
NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole
(19:46:10.039):
accRole failed: (-2147024809, 'The parameter is incorrect.', (None, None,
None, 0, None)) IO - speech.speak (19:46:10.140):
Speaking [LangChangeCommand ('en_GB'), u'1 nvda mail list - Outlook Express
- Brians lists account BGlists'] DEBUGWARNING -
NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole
(19:46:10.236):
accRole failed: (-2147418094, 'The callee (server [not server application])
is not available and disappeared; all connections are invalid. The call did
not execute.', (None, None, None, 0, None)) IO - speech.speak
(19:46:10.236):
Speaking [LangChangeCommand ('en_GB'), u'Outlook Express Message List list']
IO - speech.speak (19:46:10.326):
Speaking [LangChangeCommand ('en_GB'), u"From: Brian's Mail list account via
Groups.Io; Subject: [nvda] Funny thing happened at the update today;
Received: 08/12/2018 18:00 38218 of 38218"] IO -
inputCore.InputManager.executeGesture (19:46:11.132):
Input: kb(desktop):control+alt+r
IO - speech.speak (19:46:11.266):
Speaking [LangChangeCommand ('en_GB'), u'Taskbar'] IO - speech.speak
(19:46:11.315):
Speaking [LangChangeCommand ('en_GB'), u'reboot nvda with log terminal'] IO
- speech.speak (19:46:11.316):
Speaking [LangChangeCommand ('en_GB'), u'80 space', u'blank'] INFO -
core.main (19:46:11.361):
Exiting
DEBUG - core._terminate (19:46:11.361):
Terminating updateCheck
DEBUG - core._terminate (19:46:11.361):
Terminating watchdog
DEBUG - core._terminate (19:46:11.361):
Terminating global plugin handler
DEBUGWARNING - Python warning (19:46:11.875):
C:\nvda
extra\userConfig\addons\AudioThemes3D\globalPlugins\audioThemes\__init__.py:
113:
wxPyDeprecationWarning: Call to deprecated item. Use Remove instead.
DEBUGWARNING - Python warning (19:46:11.875):
C:\nvda
extra\userConfig\addons\AudioThemes3D\globalPlugins\AudioThemes3D_docHandler
.py:66:
wxPyDeprecationWarning: Call to deprecated item. Use Remove instead.
DEBUGWARNING - Python warning (19:46:11.881):
C:\nvda
extra\userConfig\addons\mp3DirectCut\globalPlugins\mp3DirectCut\__init__.py:
45:
wxPyDeprecationWarning: Call to deprecated item. Use Remove instead.
DEBUG - core._terminate (19:46:11.881):
Terminating gui
DEBUG - fileUtils.FaultTolerantFile (19:46:11.892):
C:\nvda extra\userConfig\nvda.inimkrcqm.tmp
INFO - config.ConfigManager.save (19:46:11.913):
Base configuration saved
DEBUG - core.main (19:46:11.913):
calling lose focus on object with focus
DEBUG - core._terminate (19:46:11.914):
Terminating treeInterceptorHandler
DEBUG - core._terminate (19:46:11.915):
Terminating IAccessible support
DEBUG - core._terminate (19:46:11.915):
Terminating UIA support
DEBUGWARNING - _UIAHandler.UIAHandler.terminate (19:46:12.115):
Timeout or error while waiting for UIAHandler MTA thread DEBUG -
core._terminate (19:46:12.115):
Terminating winConsole support
DEBUG - core._terminate (19:46:12.115):
Terminating Java Access Bridge support
DEBUG - core._terminate (19:46:12.115):
Terminating app module handler
DEBUG - core._terminate (19:46:12.115):
Terminating NVDAHelper
DEBUG - core._terminate (19:46:12.127):
Terminating touchHandler
DEBUG - core._terminate (19:46:12.127):
Terminating keyboard handler
DEBUG - core._terminate (19:46:12.127):
Terminating mouseHandler
DEBUG - core._terminate (19:46:12.128):
Terminating inputCore
DEBUG - core._terminate (19:46:12.128):
Terminating brailleInput
DEBUG - core._terminate (19:46:12.128):
Terminating braille
DEBUG - core._terminate (19:46:12.128):
Terminating speech
DEBUG - core._terminate (19:46:12.128):
Terminating addonHandler
DEBUG - core.main (19:46:13.183):
core done
INFO - __main__ (19:46:13.206):
NVDA exit


Brian
bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Joseph Lee" <@joslee>
To: "'NVDA screen reader development'" <nvda-devel@...>
Sent: Saturday, December 08, 2018 5:09 PM
Subject: [nvda] Add-on Updater 18.12.2 released, manual update recommended,
Python 3 readiness #AddonRelease


Hi all,



For those on development list, don't worry about the hashtag.



I'm delighted to announce immediate release of Add-on Updater 18.12.2.
In addition to localization updates, today's update fixes an
outstanding issue when installed on latest NVDA alpha builds, namely
inability to download updates.



Also, I'm happy to announce that Add-on Updater is Python 3 ready.
Although
there are things to be done here and there, for the most part, it'll
run under Python 3 version of NVDA. At the same time, I have updated
last tested version flag so you won't have to sorry about running to
issues until NVDA 2019.3.



IMPORTANT: Add-on Updater 18.12.x is the last series to run on NVDA
2018.2.
Starting from version 19.01, NVDA 2018.4 will be required.



For consideration for people using alpha snapshots and found
themselves unable to update add-ons, I'll be asking those on alpha
snapshots to manually apply today's build. For those using 2018.3.x
and 2018.4 betas, you can go ahead and check for add-on updates.



The manual download link is:

https://addons.nvda-project.org/files/get.php?file=nvda3208



Cheers,

Joseph