getting the repeting of the subject line in an e-mail to stop repeting when you open a message


Casey <cwollner@...>
 

Hi now every time I open A message.
I hear the subject line of the message before the message starts reading.
Is that I way to get rid of that or not?
Also I turned off reports of headings under document formatting.
And I still hear level 1 or level two when I go to my e-mail inbox or my sent folders or my deleted folders how do I get that to stop or is that just something that NVDA now does?
Now also one last thing.
How do you add NVDA to your spelling words to if you want to put the word NVDA in yourmessage it won't flag it as A mussed spelled word?


--
Casey


Gene
 

Probably getting in the habit of issuing the read to end command after opening a message will stop extraneous text.  I don't know if there is any other way to stop this behavior or if stopping it might have other results you don't like.  you also haven't told us which e-mail program you are using. 
 
Gene

----- Original Message -----
From: Casey
Sent: Friday, October 14, 2016 11:19 AM
Subject: [nvda] getting the repeting of the subject line in an e-mail to stop repeting when you open a message

Hi now every time I open A message.
I hear the subject line of the message before the message starts reading.
Is that I way to get rid of that or not?
Also I turned off reports of headings under document formatting.
And I still hear level 1 or level two when I go to my e-mail inbox or my
sent folders or my deleted folders how do I get that to stop or is that
just something that NVDA now does?
Now also one last thing.
How do you add NVDA to your spelling words to if you want to put the
word NVDA in yourmessage it won't flag it as A mussed spelled word?


--
Casey



Andre Fisher
 

Turn off position information and see what happens.

On 10/14/16, Gene <gsasner@ripco.com> wrote:
Probably getting in the habit of issuing the read to end command after
opening a message will stop extraneous text. I don't know if there is any
other way to stop this behavior or if stopping it might have other results
you don't like. you also haven't told us which e-mail program you are
using.

Gene
----- Original Message -----

From: Casey
Sent: Friday, October 14, 2016 11:19 AM
To: nvda@nvda.groups.io
Subject: [nvda] getting the repeting of the subject line in an e-mail to
stop repeting when you open a message


Hi now every time I open A message.
I hear the subject line of the message before the message starts reading.
Is that I way to get rid of that or not?
Also I turned off reports of headings under document formatting.
And I still hear level 1 or level two when I go to my e-mail inbox or my
sent folders or my deleted folders how do I get that to stop or is that
just something that NVDA now does?
Now also one last thing.
How do you add NVDA to your spelling words to if you want to put the
word NVDA in yourmessage it won't flag it as A mussed spelled word?


--
Casey



Kenny Dog <hurrikennyandopo@...>
 

Hi


In what email program do you want to do it to?


Gene nz

On 15/10/2016 5:19 AM, Casey wrote:
Hi now every time I open A message.
I hear the subject line of the message before the message starts reading.
Is that I way to get rid of that or not?
Also I turned off reports of headings under document formatting.
And I still hear level 1 or level two when I go to my e-mail inbox or
my sent folders or my deleted folders how do I get that to stop or is
that just something that NVDA now does?
Now also one last thing.
How do you add NVDA to your spelling words to if you want to put the
word NVDA in yourmessage it won't flag it as A mussed spelled word?

--
Check out my website for nvda tutorials and other blindness related material at http://www.accessibilitycentral.net


Casey <cwollner@...>
 

Hi I am using Thunderbird the latest version sorry about that.


--
Casey


Roger Stewart
 

NVDA has been doing this with Thunderbird for several years now. Guess they can't fix it. What I do is open a message and immediately hit ctrl plus Home. This kills the unwanted repeating speech and puts you right at the top of the body of the message. Then just hit nvda key plus down arrow and it will read the entire message to the end if you want without any repeating of subject line.

Roger

On 10/14/2016 4:16 PM, Casey wrote:
Hi I am using Thunderbird the latest version sorry about that.


Rosemarie Chavarria
 

Hi, Roger,


What I do is when I open a message, I hit up arrow and the message is read out automatically. I have skim reading checked. That's in the keyboard setting in the NVDA menu.


Rosemarie

On 10/14/2016 2:21 PM, Roger Stewart wrote:
NVDA has been doing this with Thunderbird for several years now. Guess they can't fix it. What I do is open a message and immediately hit ctrl plus Home. This kills the unwanted repeating speech and puts you right at the top of the body of the message. Then just hit nvda key plus down arrow and it will read the entire message to the end if you want without any repeating of subject line.

Roger












On 10/14/2016 4:16 PM, Casey wrote:
Hi I am using Thunderbird the latest version sorry about that.



Roger Stewart
 

Hey, cool trick! This saves a step! I'll do it!

:-)

Roger

On 10/14/2016 4:41 PM, Rosemarie Chavarria wrote:
Hi, Roger,


What I do is when I open a message, I hit up arrow and the message is read out automatically. I have skim reading checked. That's in the keyboard setting in the NVDA menu.


Rosemarie


On 10/14/2016 2:21 PM, Roger Stewart wrote:
NVDA has been doing this with Thunderbird for several years now. Guess they can't fix it. What I do is open a message and immediately hit ctrl plus Home. This kills the unwanted repeating speech and puts you right at the top of the body of the message. Then just hit nvda key plus down arrow and it will read the entire message to the end if you want without any repeating of subject line.

Roger












On 10/14/2016 4:16 PM, Casey wrote:
Hi I am using Thunderbird the latest version sorry about that.






Rosemarie Chavarria
 

I think it was Arleen who told us about it awhile back. I went into keyboard settings and checked the box for skim reading. Try it and see if it helps.

On 10/14/2016 3:07 PM, Roger Stewart wrote:
Hey, cool trick! This saves a step! I'll do it!

:-)

Roger








On 10/14/2016 4:41 PM, Rosemarie Chavarria wrote:
Hi, Roger,


What I do is when I open a message, I hit up arrow and the message is read out automatically. I have skim reading checked. That's in the keyboard setting in the NVDA menu.


Rosemarie


On 10/14/2016 2:21 PM, Roger Stewart wrote:
NVDA has been doing this with Thunderbird for several years now. Guess they can't fix it. What I do is open a message and immediately hit ctrl plus Home. This kills the unwanted repeating speech and puts you right at the top of the body of the message. Then just hit nvda key plus down arrow and it will read the entire message to the end if you want without any repeating of subject line.

Roger












On 10/14/2016 4:16 PM, Casey wrote:
Hi I am using Thunderbird the latest version sorry about that.








Gene
 

I haven't used skim mode and I haven't looked into what it does.  You can just use the read to end command if you wish whether you have skim mode checked or not. 
 
Don't assume that extra steps are necessary when figuring out how to work around a problem.  you assumed that it was necessary to move to the top of the message and did an unnecessary command.  I'm pointing this out because you may have made inefficient and unsupported assumptions elsewhere and experimentation may allow you to do one or more things faster and more efficiently. 
 
Gene

----- Original Message -----
Sent: Friday, October 14, 2016 5:07 PM
Subject: Re: [nvda] getting the repeting of the subject line in an e-mail to stop repeting when you open a message

Hey, cool trick!  This saves a step! I'll do it!

:-)

Roger








On 10/14/2016 4:41 PM, Rosemarie Chavarria wrote:
> Hi, Roger,
>
>
> What I do is when I open a message, I hit up arrow and the message is
> read out automatically. I have skim reading checked. That's in the
> keyboard setting in the NVDA menu.
>
>
> Rosemarie
>
>
> On 10/14/2016 2:21 PM, Roger Stewart wrote:
>> NVDA has been doing this with Thunderbird for several years now. 
>> Guess they can't fix it.  What I do is open a message and immediately
>> hit ctrl plus Home.  This kills the unwanted repeating speech and
>> puts you right at the top of the body of the message.  Then just hit
>> nvda key plus down arrow and it will read the entire message to the
>> end if you want without any repeating of subject line.
>>
>> Roger
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> On 10/14/2016 4:16 PM, Casey wrote:
>>> Hi I am using Thunderbird the latest version sorry about that.
>>>
>>>
>>
>>
>>
>>
>
>
>
>
>




Gene
 

I should add that I'm not saying you shouldn't use rose's method.  I don't have an opinion.  I haven't tried it.  Just pressing up arrow is easier than issuing the read to end command.  My main concern is not to make unsupported assumptions as I discussed before.
 
Gene

----- Original Message -----
Sent: Friday, October 14, 2016 5:11 PM
Subject: Re: [nvda] getting the repeting of the subject line in an e-mail to stop repeting when you open a message

I think it was Arleen who told us about it awhile back. I went into
keyboard settings and checked the box for skim reading. Try it and see
if it helps.





On 10/14/2016 3:07 PM, Roger Stewart wrote:
> Hey, cool trick!  This saves a step! I'll do it!
>
> :-)
>
> Roger
>
>
>
>
>
>
>
>
> On 10/14/2016 4:41 PM, Rosemarie Chavarria wrote:
>> Hi, Roger,
>>
>>
>> What I do is when I open a message, I hit up arrow and the message is
>> read out automatically. I have skim reading checked. That's in the
>> keyboard setting in the NVDA menu.
>>
>>
>> Rosemarie
>>
>>
>> On 10/14/2016 2:21 PM, Roger Stewart wrote:
>>> NVDA has been doing this with Thunderbird for several years now. 
>>> Guess they can't fix it. What I do is open a message and immediately
>>> hit ctrl plus Home.  This kills the unwanted repeating speech and
>>> puts you right at the top of the body of the message.  Then just hit
>>> nvda key plus down arrow and it will read the entire message to the
>>> end if you want without any repeating of subject line.
>>>
>>> Roger
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> On 10/14/2016 4:16 PM, Casey wrote:
>>>> Hi I am using Thunderbird the latest version sorry about that.
>>>>
>>>>
>>>
>>>
>>>
>>>
>>
>>
>>
>>
>>
>
>
>
>




Rosemarie Chavarria
 

Hi, Gene,


I don't think it works inprograms like outlook and windows live mail but it does work in thunderbird. That's what I'm using.


Rosemarie

On 10/14/2016 3:17 PM, Gene wrote:
I should add that I'm not saying you shouldn't use rose's method.  I don't have an opinion.  I haven't tried it.  Just pressing up arrow is easier than issuing the read to end command.  My main concern is not to make unsupported assumptions as I discussed before.
 
Gene
----- Original Message -----
Sent: Friday, October 14, 2016 5:11 PM
Subject: Re: [nvda] getting the repeting of the subject line in an e-mail to stop repeting when you open a message

I think it was Arleen who told us about it awhile back. I went into
keyboard settings and checked the box for skim reading. Try it and see
if it helps.





On 10/14/2016 3:07 PM, Roger Stewart wrote:
> Hey, cool trick!  This saves a step! I'll do it!
>
> :-)
>
> Roger
>
>
>
>
>
>
>
>
> On 10/14/2016 4:41 PM, Rosemarie Chavarria wrote:
>> Hi, Roger,
>>
>>
>> What I do is when I open a message, I hit up arrow and the message is
>> read out automatically. I have skim reading checked. That's in the
>> keyboard setting in the NVDA menu.
>>
>>
>> Rosemarie
>>
>>
>> On 10/14/2016 2:21 PM, Roger Stewart wrote:
>>> NVDA has been doing this with Thunderbird for several years now. 
>>> Guess they can't fix it. What I do is open a message and immediately
>>> hit ctrl plus Home.  This kills the unwanted repeating speech and
>>> puts you right at the top of the body of the message.  Then just hit
>>> nvda key plus down arrow and it will read the entire message to the
>>> end if you want without any repeating of subject line.
>>>
>>> Roger
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> On 10/14/2016 4:16 PM, Casey wrote:
>>>> Hi I am using Thunderbird the latest version sorry about that.
>>>>
>>>>
>>>
>>>
>>>
>>>
>>
>>
>>
>>
>>
>
>
>
>





Gene
 

I don't see why it wouldn't work if those programs allow messages to be read automatically on opening.  I looked at the description of skim mode and it allows you to execute certain commands when using read to end such as moving by line.  Read to end continues after you move from the new position.  so any program that automatically triggers say all in NVDA should allow you to use this method.  What you are doing is to tell NVDA to move up one line but it can't because its already at the start of a message.  Since read to end is automatically being used, you are making unnecessary material such as the subject line not be read.  You are telling NVDA to start reading at the start of the message body and it continues to read because read to end is active.
 
Gene

----- Original Message -----
Sent: Friday, October 14, 2016 5:20 PM
Subject: Re: [nvda] getting the repeting of the subject line in an e-mail to stop repeting when you open a message

Hi, Gene,


I don't think it works inprograms like outlook and windows live mail but it does work in thunderbird. That's what I'm using.


Rosemarie

On 10/14/2016 3:17 PM, Gene wrote:
I should add that I'm not saying you shouldn't use rose's method.  I don't have an opinion.  I haven't tried it.  Just pressing up arrow is easier than issuing the read to end command.  My main concern is not to make unsupported assumptions as I discussed before.
 
Gene
----- Original Message -----
Sent: Friday, October 14, 2016 5:11 PM
Subject: Re: [nvda] getting the repeting of the subject line in an e-mail to stop repeting when you open a message

I think it was Arleen who told us about it awhile back. I went into
keyboard settings and checked the box for skim reading. Try it and see
if it helps.





On 10/14/2016 3:07 PM, Roger Stewart wrote:
> Hey, cool trick!  This saves a step! I'll do it!
>
> :-)
>
> Roger
>
>
>
>
>
>
>
>
> On 10/14/2016 4:41 PM, Rosemarie Chavarria wrote:
>> Hi, Roger,
>>
>>
>> What I do is when I open a message, I hit up arrow and the message is
>> read out automatically. I have skim reading checked. That's in the
>> keyboard setting in the NVDA menu.
>>
>>
>> Rosemarie
>>
>>
>> On 10/14/2016 2:21 PM, Roger Stewart wrote:
>>> NVDA has been doing this with Thunderbird for several years now. 
>>> Guess they can't fix it. What I do is open a message and immediately
>>> hit ctrl plus Home.  This kills the unwanted repeating speech and
>>> puts you right at the top of the body of the message.  Then just hit
>>> nvda key plus down arrow and it will read the entire message to the
>>> end if you want without any repeating of subject line.
>>>
>>> Roger
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> On 10/14/2016 4:16 PM, Casey wrote:
>>>> Hi I am using Thunderbird the latest version sorry about that.
>>>>
>>>>
>>>
>>>
>>>
>>>
>>
>>
>>
>>
>>
>
>
>
>





Arlene
 

Hi, I did this by a fluke.

-----Original Message-----
From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Rosemarie Chavarria
Sent: October-14-16 3:11 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] getting the repeting of the subject line in an e-mail to stop repeting when you open a message

I think it was Arleen who told us about it awhile back. I went into keyboard settings and checked the box for skim reading. Try it and see if it helps.





On 10/14/2016 3:07 PM, Roger Stewart wrote:
Hey, cool trick! This saves a step! I'll do it!

:-)

Roger








On 10/14/2016 4:41 PM, Rosemarie Chavarria wrote:
Hi, Roger,


What I do is when I open a message, I hit up arrow and the message is
read out automatically. I have skim reading checked. That's in the
keyboard setting in the NVDA menu.


Rosemarie


On 10/14/2016 2:21 PM, Roger Stewart wrote:
NVDA has been doing this with Thunderbird for several years now.
Guess they can't fix it. What I do is open a message and immediately
hit ctrl plus Home. This kills the unwanted repeating speech and
puts you right at the top of the body of the message. Then just hit
nvda key plus down arrow and it will read the entire message to the
end if you want without any repeating of subject line.

Roger












On 10/14/2016 4:16 PM, Casey wrote:
Hi I am using Thunderbird the latest version sorry about that.









Rosemarie Chavarria
 

How do you turn off position information?

On 10/14/2016 10:43 AM, Andre Fisher wrote:
Turn off position information and see what happens.

On 10/14/16, Gene <gsasner@ripco.com> wrote:
Probably getting in the habit of issuing the read to end command after
opening a message will stop extraneous text. I don't know if there is any
other way to stop this behavior or if stopping it might have other results
you don't like. you also haven't told us which e-mail program you are
using.

Gene
----- Original Message -----

From: Casey
Sent: Friday, October 14, 2016 11:19 AM
To: nvda@nvda.groups.io
Subject: [nvda] getting the repeting of the subject line in an e-mail to
stop repeting when you open a message


Hi now every time I open A message.
I hear the subject line of the message before the message starts reading.
Is that I way to get rid of that or not?
Also I turned off reports of headings under document formatting.
And I still hear level 1 or level two when I go to my e-mail inbox or my
sent folders or my deleted folders how do I get that to stop or is that
just something that NVDA now does?
Now also one last thing.
How do you add NVDA to your spelling words to if you want to put the
word NVDA in yourmessage it won't flag it as A mussed spelled word?


--
Casey



 

Hi everyone,

Okay, the following is a bit technical, so I’ll try my best to explain what’s going on. But first, to answer Casey’s original question:

 

Preventing NVDA from announcing message fields when you open a message (Thunderbird, Outlook, etc.): yes and no. Let me address the “no” answer first, as I think it is important to understand some behind the scenes work:

NVDA is armed with strategies to deal with specific controls and how it should act accordingly. For example, NVDA can treat some lists as tables, announce terminal output, read dialog texts and so on. To house these strategies (termed “behaviors” in NVDA development world), a specific subsystem is devoted to telling NVDA how it should act when meeting certain controls. This subsystem is divided into two parts:

·         Behaviors mix-in: a collection of strategies to work with various controls such as dialogs.

·         Control definitions: each accessibility API layer allows developers to specify what NVDA should do when meeting specific controls.

The advantage of this is that it is easy to extend this subsystem, but with a cost: once known, NVDA will hold onto known controls. But it is possible to tweak behaviors and add additional extensions on top of it (for example, telling NVDA to announce dialog text in reverse order).

Now the “yes” answer: it might be possible to tell NVDA to not announce message headers, provided that NVDA can recognize such cases. This is because message headers are housed inside a dialog, and this one is a generic MSAA/IAccessible dialog (from NVDA’s perspective), or in some cases, NVDA is told to announce contents of a window automatically.

 

Technical: At least in Outlook, window class name for this dialog is #32770 (very generic MSAA dialog), and it’s the matter of subclassing NVDAObjects.behaviors.Dialog) and attaching it to an overlay class. This is similar to what I did back in June to deal with newer style User Account Control dialog in Windows 10 version 1607 (took me two days to figure out the class name for the dialog and told NVDA to treat what appeared to be a window as a dialog; because it was a secure screen, I had to write a custom global plugin to figure out what was happening inside).

 

A challenge for would-be aspiring NVDA developers (I might not be able to do it for a while due to speech competitions): write a working algorithm that solves Casey’s issue. Define the problem, your research findings, source code file names/lines that needs to be modified, why your idea is good and demonstrate that it actually works. For bonus points, add one or more notes describing cases where your work would (and will) fail (I put this as a bonus point so you can think carefully before writing your solution). I’ll accept solutions from those who are:

 

·         Determined and dedicated to help someone in our community despite setbacks.

·         Willing to learn NVDA source code.

 

I will add bonus points if you:

 

·         Address your solution as though you are talking to Casey directly.

·         Are willing to explain in simple terms what’s going on (don’t copy me; come up with explanations in your own words).

·         If writing source code, conform to NV Access coding style (camel case, tabs for indentation, etc.).

 

I added these for an important reason: developers should be servants and see solutions from users’ perspective (someone who have never heard of Python, NVDA source code and what not). Please send your solutions to me directly, and I’ll accept answers until end of October. Whichever receives highest points from judges will be considered for inclusion in an NVDA issue (I’d like to ask some seasoned devs here to be judges).


thanks.

Cheers,

Joseph

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Rosemarie Chavarria
Sent: Friday, October 14, 2016 3:20 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] getting the repeting of the subject line in an e-mail to stop repeting when you open a message

 

Hi, Gene,

 

I don't think it works inprograms like outlook and windows live mail but it does work in thunderbird. That's what I'm using.

 

Rosemarie

On 10/14/2016 3:17 PM, Gene wrote:

I should add that I'm not saying you shouldn't use rose's method.  I don't have an opinion.  I haven't tried it.  Just pressing up arrow is easier than issuing the read to end command.  My main concern is not to make unsupported assumptions as I discussed before.

 

Gene

----- Original Message -----

Sent: Friday, October 14, 2016 5:11 PM

Subject: Re: [nvda] getting the repeting of the subject line in an e-mail to stop repeting when you open a message

 

I think it was Arleen who told us about it awhile back. I went into
keyboard settings and checked the box for skim reading. Try it and see
if it helps.





On 10/14/2016 3:07 PM, Roger Stewart wrote:
> Hey, cool trick!  This saves a step! I'll do it!
>
> :-)
>
> Roger
>
>
>
>
>
>
>
>
> On 10/14/2016 4:41 PM, Rosemarie Chavarria wrote:
>> Hi, Roger,
>>
>>
>> What I do is when I open a message, I hit up arrow and the message is
>> read out automatically. I have skim reading checked. That's in the
>> keyboard setting in the NVDA menu.
>>
>>
>> Rosemarie
>>
>>
>> On 10/14/2016 2:21 PM, Roger Stewart wrote:
>>> NVDA has been doing this with Thunderbird for several years now. 
>>> Guess they can't fix it. What I do is open a message and immediately
>>> hit ctrl plus Home.  This kills the unwanted repeating speech and
>>> puts you right at the top of the body of the message.  Then just hit
>>> nvda key plus down arrow and it will read the entire message to the
>>> end if you want without any repeating of subject line.
>>>
>>> Roger
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> On 10/14/2016 4:16 PM, Casey wrote:
>>>> Hi I am using Thunderbird the latest version sorry about that.
>>>>
>>>>
>>>
>>>
>>>
>>>
>>
>>
>>
>>
>>
>
>
>
>


 


Roger Stewart
 

I set it up for skim reading mode and it works just fine!

Thanks.

Roger

On 10/14/2016 5:07 PM, Roger Stewart wrote:
Hey, cool trick! This saves a step! I'll do it!

:-)

Roger








On 10/14/2016 4:41 PM, Rosemarie Chavarria wrote:
Hi, Roger,


What I do is when I open a message, I hit up arrow and the message is read out automatically. I have skim reading checked. That's in the keyboard setting in the NVDA menu.


Rosemarie


On 10/14/2016 2:21 PM, Roger Stewart wrote:
NVDA has been doing this with Thunderbird for several years now. Guess they can't fix it. What I do is open a message and immediately hit ctrl plus Home. This kills the unwanted repeating speech and puts you right at the top of the body of the message. Then just hit nvda key plus down arrow and it will read the entire message to the end if you want without any repeating of subject line.

Roger












On 10/14/2016 4:16 PM, Casey wrote:
Hi I am using Thunderbird the latest version sorry about that.








.


Ejaz Shah
 

On my computer, if I open the messages in a new tab, NVDA does not repeat the subject line. Repeating of subject line happens if the message is opened in a new window. So, I always open Thunderbird messages in new tab and close with Control + w.

On 10/15/2016 2:21 AM, Roger Stewart wrote:
NVDA has been doing this with Thunderbird for several years now. Guess they can't fix it. What I do is open a message and immediately hit ctrl plus Home. This kills the unwanted repeating speech and puts you right at the top of the body of the message. Then just hit nvda key plus down arrow and it will read the entire message to the end if you want without any repeating of subject line.

Roger












On 10/14/2016 4:16 PM, Casey wrote:
Hi I am using Thunderbird the latest version sorry about that.



Rosemarie Chavarria
 

Oh wow. I didn'tthink of that. Thanks for the tip.

On 10/14/2016 10:32 PM, Ejaz Shah wrote:
On my computer, if I open the messages in a new tab, NVDA does not repeat the subject line. Repeating of subject line happens if the message is opened in a new window. So, I always open Thunderbird messages in new tab and close with Control + w.


On 10/15/2016 2:21 AM, Roger Stewart wrote:
NVDA has been doing this with Thunderbird for several years now. Guess they can't fix it. What I do is open a message and immediately hit ctrl plus Home. This kills the unwanted repeating speech and puts you right at the top of the body of the message. Then just hit nvda key plus down arrow and it will read the entire message to the end if you want without any repeating of subject line.

Roger












On 10/14/2016 4:16 PM, Casey wrote:
Hi I am using Thunderbird the latest version sorry about that.





Brian's Mail list account BY <bglists@...>
 

Depends on your spellchecker, but certainly word allows you to put in custom words or special words if you want to, at least my old 2003 does and I think its called Add in most spellcheckers.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal email to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Casey" <cwollner@wi.rr.com>
To: <nvda@nvda.groups.io>
Sent: Friday, October 14, 2016 5:19 PM
Subject: [nvda] getting the repeting of the subject line in an e-mail to stop repeting when you open a message


Hi now every time I open A message.
I hear the subject line of the message before the message starts reading.
Is that I way to get rid of that or not?
Also I turned off reports of headings under document formatting.
And I still hear level 1 or level two when I go to my e-mail inbox or my sent folders or my deleted folders how do I get that to stop or is that just something that NVDA now does?
Now also one last thing.
How do you add NVDA to your spelling words to if you want to put the word NVDA in yourmessage it won't flag it as A mussed spelled word?


--
Casey