Hearing "Unknown" when Using a Mouse


bestuiexperience
 

I am a software developer trying to develop accessible software. I am working with some checkboxes that always announce "unknown" before announcing the label. This occurs only in forms mode and only when using a mouse (which I understand some NVDA users do). Any clue as to what might be causing the issue?


Travis Siegel <tsiegel@...>
 

When using forms mode, it is expected that some sort of identifying text will be included with the item needing to be acted upon.  Therefore, some checkboxes might have a title saying it's the yes or the no check box.  If the said text isn't present, then NVDA has no way to know what the item is refering to, so will only state the actual item and not what it is supposed to be referring to.  This goes for all gui elements, not just checkboxes.

On 2/25/2019 10:10 PM, bestuiexperience wrote:
I am a software developer trying to develop accessible software. I am working with some checkboxes that always announce "unknown" before announcing the label. This occurs only in forms mode and only when using a mouse (which I understand some NVDA users do). Any clue as to what might be causing the issue?

Virus-free. www.avast.com


Rosemarie Chavarria
 

Some forms have radio buttons which allow you to make a choice whenselecting something. There are also combo boxes.



On 2/25/2019 7:25 PM, Travis Siegel wrote:

When using forms mode, it is expected that some sort of identifying text will be included with the item needing to be acted upon.  Therefore, some checkboxes might have a title saying it's the yes or the no check box.  If the said text isn't present, then NVDA has no way to know what the item is refering to, so will only state the actual item and not what it is supposed to be referring to.  This goes for all gui elements, not just checkboxes.

On 2/25/2019 10:10 PM, bestuiexperience wrote:
I am a software developer trying to develop accessible software. I am working with some checkboxes that always announce "unknown" before announcing the label. This occurs only in forms mode and only when using a mouse (which I understand some NVDA users do). Any clue as to what might be causing the issue?

Virus-free. www.avast.com


Travis Siegel <tsiegel@...>
 

Yes, I know, and my message below applies to all such items, as I said.  I've been developing web sites myself since 1996, so I am well versed in web content components, and I dis state in the message that the label applies to other gui elements as well, which would include radio buttons, checkboxes, edit boxes, submit buttons, and the like.


On 2/25/2019 10:27 PM, Rosemarie Chavarria wrote:

Some forms have radio buttons which allow you to make a choice whenselecting something. There are also combo boxes.



On 2/25/2019 7:25 PM, Travis Siegel wrote:

When using forms mode, it is expected that some sort of identifying text will be included with the item needing to be acted upon.  Therefore, some checkboxes might have a title saying it's the yes or the no check box.  If the said text isn't present, then NVDA has no way to know what the item is refering to, so will only state the actual item and not what it is supposed to be referring to.  This goes for all gui elements, not just checkboxes.

On 2/25/2019 10:10 PM, bestuiexperience wrote:
I am a software developer trying to develop accessible software. I am working with some checkboxes that always announce "unknown" before announcing the label. This occurs only in forms mode and only when using a mouse (which I understand some NVDA users do). Any clue as to what might be causing the issue?

Virus-free. www.avast.com


Brian's Mail list account <bglists@...>
 

Yes and why cannot a site stick to one sort of combo box? IE the one which works without jumping out for all of them on the page?
Bah humbug.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Rosemarie Chavarria" <knitqueen2007@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Tuesday, February 26, 2019 3:27 AM
Subject: Re: [nvda] Hearing "Unknown" when Using a Mouse


Some forms have radio buttons which allow you to make a choice
whenselecting something. There are also combo boxes.



On 2/25/2019 7:25 PM, Travis Siegel wrote:

When using forms mode, it is expected that some sort of identifying
text will be included with the item needing to be acted upon.
Therefore, some checkboxes might have a title saying it's the yes or
the no check box. If the said text isn't present, then NVDA has no
way to know what the item is refering to, so will only state the
actual item and not what it is supposed to be referring to. This goes
for all gui elements, not just checkboxes.

On 2/25/2019 10:10 PM, bestuiexperience wrote:
I am a software developer trying to develop accessible software. I am
working with some checkboxes that always announce "unknown" before
announcing the label. This occurs only in forms mode and only when
using a mouse (which I understand some NVDA users do). Any clue as to
what might be causing the issue?
<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient&utm_term=icon>
Virus-free. www.avast.com
<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient&utm_term=link>


<#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>


Chris Mullins
 

Hi

Does NVDA identify the control as being a check box?  When NVDA lands on a check box it should identify it a as check box, speak the state and announce the label.  NVDA will say “Unknown” when it does not recognise the control.

 

Cheers

Chris

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Travis Siegel
Sent: 26 February 2019 03:26
To: nvda@nvda.groups.io
Subject: Re: [nvda] Hearing "Unknown" when Using a Mouse

 

When using forms mode, it is expected that some sort of identifying text will be included with the item needing to be acted upon.  Therefore, some checkboxes might have a title saying it's the yes or the no check box.  If the said text isn't present, then NVDA has no way to know what the item is refering to, so will only state the actual item and not what it is supposed to be referring to.  This goes for all gui elements, not just checkboxes.

On 2/25/2019 10:10 PM, bestuiexperience wrote:

I am a software developer trying to develop accessible software. I am working with some checkboxes that always announce "unknown" before announcing the label. This occurs only in forms mode and only when using a mouse (which I understand some NVDA users do). Any clue as to what might be causing the issue?

 

Virus-free. www.avast.com


 

It can also be important to know how you are developing these pages.   Are you coding the HTML from scratch, by hand or are you using a WYSIWYG page editor like DreamWeaver, BlueGriffon, etc.

You may need to tweak settings in your WYSIWYG editor, if you're using one.

Generally, for checkboxes, when I've looked at code it simply reads the text associated with the checkbox (its label).  Nothing else is needed because "it's all there."  Were I you, I'd take a look at the page source of the page you're having issues with and the page source of some random website that has a collection of checkboxes that work as expected and see where in the HTML they differ.

--

Brian - Windows 10 Home, 64-Bit, Version 1809, Build 17763  

A great deal of intelligence can be invested in ignorance when the need for illusion is deep.

          ~ Saul Bellow, To Jerusalem and Back

 

 


Jonathan COHN
 

This is most likely NVDA telling you the name of the mouse cursor. Did you perchance use a custom cursor in a MouseOver? Generally, I just look for the mouse type to change when I pay attention to it. Also, if it is the mouse announcement, then when you move off the check box you should hear “pointer”, “hand” or other such descriptions.

 

 

From: <nvda@nvda.groups.io> on behalf of bestuiexperience <bestuiexperience@...>
Reply-To: "nvda@nvda.groups.io" <nvda@nvda.groups.io>
Date: Monday, February 25, 2019 at 10:13 PM
To: "nvda@nvda.groups.io" <nvda@nvda.groups.io>
Subject: [nvda] Hearing "Unknown" when Using a Mouse

 

I am a software developer trying to develop accessible software. I am working with some checkboxes that always announce "unknown" before announcing the label. This occurs only in forms mode and only when using a mouse (which I understand some NVDA users do). Any clue as to what might be causing the issue?