Topics

NVDA at logon


Robert Logue
 

NVDA is starting when I have it set not to at logon.

I've looked at NVDA settings as well as in Ease of Access in control panel.  It is unchecked so it shouldn't load at startup. It is checked to load after startup. The settings agree.


Another problem is that NVDA is using the default sound card instead of the one designated in NVDA and Windows sound settings.



Windows 10 1809.


Bob


Chris
 

In my experience this tends to be that another screen reader, like narrator for example, it's actually starting to login and not actually NVDA, is The issue

On 3 Apr 2019, at 00:48, Robert Logue <bobcat11@shaw.ca> wrote:

NVDA is starting when I have it set not to at logon.

I've looked at NVDA settings as well as in Ease of Access in control panel. It is unchecked so it shouldn't load at startup. It is checked to load after startup. The settings agree.


Another problem is that NVDA is using the default sound card instead of the one designated in NVDA and Windows sound settings.



Windows 10 1809.


Bob





Brian's Mail list account <bglists@...>
 

Not sure, if you had it set to start at log on, once, then it can be a real pain to stop it.
Does anyone know if this is in fact possible?
What I see is that when it has been set to log in with a password prompt in windows , then the nnvda settings get used but when its fully loaded the screenreader is not actually running normally it still needs a manual start. This implies that there is, somewhere in the early start up sequence, a stub loader that gives rudimentary screenreading before the rest of windows loads up.


I'm guessing this may be some throw back to a time when nvda was not uninstalled completely and has only been seen now due to some change in the settings in windows starting up and nvda starting up.
Might be worth a look in Microsoft's autorun tool to see if you can see a key somewhere where its running something from nvda, and removing it manually.
I had a similar issue with Dolphin some years ago.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Chris via Groups.Io" <chrismedley=btinternet.com@groups.io>
To: <nvda@nvda.groups.io>
Sent: Wednesday, April 03, 2019 6:39 AM
Subject: Re: [nvda] NVDA at logon


In my experience this tends to be that another screen reader, like narrator for example, it's actually starting to login and not actually NVDA, is The issue

On 3 Apr 2019, at 00:48, Robert Logue <bobcat11@shaw.ca> wrote:

NVDA is starting when I have it set not to at logon.

I've looked at NVDA settings as well as in Ease of Access in control panel. It is unchecked so it shouldn't load at startup. It is checked to load after startup. The settings agree.


Another problem is that NVDA is using the default sound card instead of the one designated in NVDA and Windows sound settings.



Windows 10 1809.


Bob





Chris
 

Also could try copy saved settings to login and other secure screens option see if that fixes the problem if it is actually nvda starting and not another screen reader

 

 

From: Brian's Mail list account via Groups.Io
Sent: 03 April 2019 08:56
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA at logon

 

Not sure, if you had it set to start at log on, once, then it can be a real

pain to stop it.

Does anyone know if this is in fact possible?

What I see is that when it has been set to log in with a password prompt in

windows , then the nnvda settings get used but when its fully loaded the

screenreader is not actually running normally it still needs a manual start.

This implies that there is, somewhere in the early start up sequence, a stub

loader that gives rudimentary screenreading before the rest of windows loads

up.

 

 

I'm guessing this may be some throw back to a time when nvda was not

uninstalled completely and has only been seen now due to some change in the

settings in windows starting up and nvda starting up.

Might be worth a look in Microsoft's autorun  tool to see if you can see a

key somewhere where its running something from nvda, and removing it

manually.

I had a similar issue with Dolphin some years ago.

Brian

 

bglists@...

Sent via blueyonder.

Please address personal E-mail to:-

briang1@..., putting 'Brian Gaff'

in the display name field.

----- Original Message -----

From: "Chris via Groups.Io" <chrismedley@...>

To: <nvda@nvda.groups.io>

Sent: Wednesday, April 03, 2019 6:39 AM

Subject: Re: [nvda] NVDA at logon

 

 

In my experience this tends to be that another screen reader, like narrator

for example, it's actually starting to login and not actually NVDA, is The

issue

 

> On 3 Apr 2019, at 00:48, Robert Logue <bobcat11@...> wrote:

> NVDA is starting when I have it set not to at logon.

> I've looked at NVDA settings as well as in Ease of Access in control

> panel.  It is unchecked so it shouldn't load at startup. It is checked to

> load after startup. The settings agree.

> Another problem is that NVDA is using the default sound card instead of

> the one designated in NVDA and Windows sound settings.

> Windows 10 1809.

> Bob

 

 

 

 

 

 

 


Luke Davis
 

A question on this topic:

In Older days (Vista and possibly Win 7), if NVDA was not set to run on the logon screen, it would also not read UAC dialogs or applications that ran under elevated privileges.
Unless that was just a fluke of my machines.

Anyway, I just tested under Win 10, and found this no longer to be the case. If I remove NVDA from the logon screen, reboot and log in, it will still read UAC screens, although it does so with the saved configuration that was in effect for the "use on logon and other secure screens", as I can determine from the differing speech rate and volume.

I had thought (but never had it confirmed), that in order to run on the logon and other secure screens, a separate instance of NVDA had to run. If that is the case, then the behavior I experienced in Vista seems reasonable. However if that's the case, how is it running now that I have removed NVDA from the logon screen, presumably disabling the ability for that instance to run with administrative privileges?
Not that I'm complaining, but I am curious.

I ask because this might in some way be related to the original question about NVDA failing to stop running on the logon screen. Then again, i could be totally off base about how this works, and it may not be related in the slightest.

I also wonder if you have tried enabling it to run on the logon screen, rebooting, and then disabling it again.

Luke


Robert Logue
 

I do have Narrator at startup and want to switch to NVDA after logon.  Maybe that isn't a good idea.

I made sure Narrator and NVDA are not  trying to start at the same time.


Bob

On 2019-04-02 11:39 p.m., Chris via Groups.Io wrote:
In my experience this tends to be that another screen reader, like narrator for example, it's actually starting to login and not actually NVDA, is The issue

On 3 Apr 2019, at 00:48, Robert Logue <bobcat11@shaw.ca> wrote:

NVDA is starting when I have it set not to at logon.

I've looked at NVDA settings as well as in Ease of Access in control panel. It is unchecked so it shouldn't load at startup. It is checked to load after startup. The settings agree.


Another problem is that NVDA is using the default sound card instead of the one designated in NVDA and Windows sound settings.



Windows 10 1809.


Bob





Robert Logue
 

Thanks Brian.  I'll give Autoruns for Windows  a try.


Bob

On 2019-04-03 1:56 a.m., Brian's Mail list account via Groups.Io wrote:
Not sure, if you had it set to start at log on, once, then it can be a real pain to stop it.
Does anyone know if this is in fact possible?
What I see is that when it has been set to log in with a password prompt in windows , then the nnvda settings get used but when its fully loaded the screenreader is not actually running normally it still needs a manual start. This implies that there is, somewhere in the early start up sequence, a stub loader that gives rudimentary screenreading before the rest of windows loads up.


I'm guessing this may be some throw back to a time when nvda was not uninstalled completely and has only been seen now due to some change in the settings in windows starting up and nvda starting up.
Might be worth a look in Microsoft's autorun  tool to see if you can see a key somewhere where its running something from nvda, and removing it manually.
I had a similar issue with Dolphin some years ago.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
----- Original Message ----- From: "Chris via Groups.Io" <chrismedley=btinternet.com@groups.io>
To: <nvda@nvda.groups.io>
Sent: Wednesday, April 03, 2019 6:39 AM
Subject: Re: [nvda] NVDA at logon


In my experience this tends to be that another screen reader, like narrator for example, it's actually starting to login and not actually NVDA, is The issue

On 3 Apr 2019, at 00:48, Robert Logue <bobcat11@shaw.ca> wrote:

NVDA is starting when I have it set not to at logon.

I've looked at NVDA settings as well as in Ease of Access in control panel.  It is unchecked so it shouldn't load at startup. It is checked to load after startup. The settings agree.


Another problem is that NVDA is using the default sound card instead of the one designated in NVDA and Windows sound settings.



Windows 10 1809.


Bob









Robert Logue
 

Ok. I'll give copy saved settings to login a try too.  It scared me because it said something about plugins not being secure.


Bob

On 2019-04-03 2:10 a.m., Chris via Groups.Io wrote:
Also could try copy saved settings to login and other secure screens option see if that fixes the problem if it is actually nvda starting and not another screen reader


From: Brian's Mail list account via Groups.Io
Sent: 03 April 2019 08:56
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA at logon

Not sure, if you had it set to start at log on, once, then it can be a real
pain to stop it.
Does anyone know if this is in fact possible?
What I see is that when it has been set to log in with a password prompt in
windows , then the nnvda settings get used but when its fully loaded the
screenreader is not actually running normally it still needs a manual start.
This implies that there is, somewhere in the early start up sequence, a stub
loader that gives rudimentary screenreading before the rest of windows loads
up.


I'm guessing this may be some throw back to a time when nvda was not
uninstalled completely and has only been seen now due to some change in the
settings in windows starting up and nvda starting up.
Might be worth a look in Microsoft's autorun tool to see if you can see a
key somewhere where its running something from nvda, and removing it
manually.
I had a similar issue with Dolphin some years ago.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
----- Original Message -----
From: "Chris via Groups.Io" <chrismedley=btinternet.com@groups.io>
To: <nvda@nvda.groups.io>
Sent: Wednesday, April 03, 2019 6:39 AM
Subject: Re: [nvda] NVDA at logon


In my experience this tends to be that another screen reader, like narrator
for example, it's actually starting to login and not actually NVDA, is The
issue

On 3 Apr 2019, at 00:48, Robert Logue <bobcat11@shaw.ca> wrote:

NVDA is starting when I have it set not to at logon.

I've looked at NVDA settings as well as in Ease of Access in control
panel. It is unchecked so it shouldn't load at startup. It is checked to
load after startup. The settings agree.


Another problem is that NVDA is using the default sound card instead of
the one designated in NVDA and Windows sound settings.



Windows 10 1809.


Bob