Reading word documents that are flagged as read-only


Sile
 

Hello


I have noticed that when reading read-only word documents that NVDA says 'read only' for each paragraph break.  Is there a way to make it stop doing this?


I am using office 16 and windows 10.


--Sile


Gene
 

I think the only way is to use the speech dictionary to stop the phrase from being spoken.  But there may be no way to stop it from being spoken universally so you might want to do this in the temporary dictionary so the entry won't be retained beyond the current NVDA session.
 
Gene

----- Original Message -----
Sent: Wednesday, April 10, 2019 9:53 AM
Subject: [nvda] Reading word documents that are flagged as read-only

Hello


I have noticed that when reading read-only word documents that NVDA says
'read only' for each paragraph break.  Is there a way to make it stop
doing this?


I am using office 16 and windows 10.


--Sile





 

You could try the old "save as" trick, which often works.   I just save the document as another copy of itself, and in the vast majority of cases that eliminates the read only attribute on the copy.   

This doesn't work if you actually copy a file in Windows Explorer.   You must do a Save As from within Word.   I haven't tried this with Word 2016, but I know I had it work back in Word 2010, at least at one point in time.
--

Brian - Windows 10 Pro, 64-Bit, Version 1809, Build 17763  

Growth for the sake of growth is the ideology of the cancer cell.

           ~ Edward Abbey

 

 


Brian's Mail list account <bglists@...>
 

I don't have any read only ones, but if it is a read only file, maybe loading it into a different editor like Jarte might work better.

Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.

----- Original Message -----
From: "Gene" <gsasner@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Wednesday, April 10, 2019 3:59 PM
Subject: Re: [nvda] Reading word documents that are flagged as read-only


I think the only way is to use the speech dictionary to stop the phrase from being spoken. But there may be no way to stop it from being spoken universally so you might want to do this in the temporary dictionary so the entry won't be retained beyond the current NVDA session.

Gene
----- Original Message -----

From: Sile via Groups.Io
Sent: Wednesday, April 10, 2019 9:53 AM
To: nvda@nvda.groups.io
Subject: [nvda] Reading word documents that are flagged as read-only


Hello


I have noticed that when reading read-only word documents that NVDA says
'read only' for each paragraph break. Is there a way to make it stop
doing this?


I am using office 16 and windows 10.


--Sile


Andre Fisher
 

Hi.

I used to notice this behaviour before 2019.1, when I enabled the experimental UIA support in the advanced settings dialog. The workaround I used to use was to Alt+Tab away from the document and return to it.