Turning off input help if you activate numlock inbetween


Jacob Kruger
 

Not a bug report or anything, but, just a warning since it seems slightly odd, and, took me roundabout 2 seconds to realise what had happened...<smile>


Was double-checking layout of numpad keys for something else, so turned on NVDA's input help using NVDA key + number row 1.


Anyway, ran through all the numpad keys, including hitting just the numlock key, and, it did still turn on numlock, which meant that suddenly all the numpad keys were reporting their number characters, along with stating that numlock was being included - numlock numpad 5, for example.


Anyway, all this meant was that to then turn off input help, I first had to press numlock key by itself again, before then using the original keystroke of NVDA + number row 1, since otherwise it just reported numlock numpad 0, followed by 1 to me, but, kept input help turned on.


And, if relevant, this is on my windows 10, anniversary upgrade, 64 bit machine, and, running NVDA 2016.3, with full desktop keyboard layout.


Stay well


Jacob Kruger
Blind Biker
Skype: BlindZA
"Resistance is futile, but, acceptance is versatile..."


Quentin Christensen
 

Hi Jacob,

You are right, I'm going to call this a "feature".  We were aware of this behaviour.  From memory, I think it is one of those things that looks simple to fix, but would actually be very complex.

The main risk is that if you turn numlock on and use the numpad insert as the NVDA modifier, then you won't be able to exit input help until you turn numlock off again.


Regards

Quentin.

On Fri, Nov 18, 2016 at 3:36 PM, Jacob Kruger <jacob@...> wrote:
Not a bug report or anything, but, just a warning since it seems slightly odd, and, took me roundabout 2 seconds to realise what had happened...<smile>


Was double-checking layout of numpad keys for something else, so turned on NVDA's input help using NVDA key + number row 1.


Anyway, ran through all the numpad keys, including hitting just the numlock key, and, it did still turn on numlock, which meant that suddenly all the numpad keys were reporting their number characters, along with stating that numlock was being included - numlock numpad 5, for example.


Anyway, all this meant was that to then turn off input help, I first had to press numlock key by itself again, before then using the original keystroke of NVDA + number row 1, since otherwise it just reported numlock numpad 0, followed by 1 to me, but, kept input help turned on.


And, if relevant, this is on my windows 10, anniversary upgrade, 64 bit machine, and, running NVDA 2016.3, with full desktop keyboard layout.


Stay well


Jacob Kruger
Blind Biker
Skype: BlindZA
"Resistance is futile, but, acceptance is versatile..."







--
Quentin Christensen
Training Material Developer
Basic Training for NVDA & Microsoft Word with NVDA E-Books now available: http://www.nvaccess.org/shop/

Direct: +61 413 904 383
www.nvaccess.org 
Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 


Jacob Kruger
 

Depending on keyboard layout, you can, obviously, use the other insert key + number row 1 to turn off input help, but, that would depend on the option to also use extended insert as an NVDA modifier - option under keyboard preferences.


Like said, didn't think it was a bug, but, it baffled me for roundabout 2 seconds...<smile>


Stay well


Jacob Kruger
Blind Biker
Skype: BlindZA
"Resistance is futile, but, acceptance is versatile..."
On 2016-11-18 6:53 AM, Quentin Christensen wrote:

Hi Jacob,

You are right, I'm going to call this a "feature".  We were aware of this behaviour.  From memory, I think it is one of those things that looks simple to fix, but would actually be very complex.

The main risk is that if you turn numlock on and use the numpad insert as the NVDA modifier, then you won't be able to exit input help until you turn numlock off again.


Regards

Quentin.

On Fri, Nov 18, 2016 at 3:36 PM, Jacob Kruger <jacob@...> wrote:
Not a bug report or anything, but, just a warning since it seems slightly odd, and, took me roundabout 2 seconds to realise what had happened...<smile>


Was double-checking layout of numpad keys for something else, so turned on NVDA's input help using NVDA key + number row 1.


Anyway, ran through all the numpad keys, including hitting just the numlock key, and, it did still turn on numlock, which meant that suddenly all the numpad keys were reporting their number characters, along with stating that numlock was being included - numlock numpad 5, for example.


Anyway, all this meant was that to then turn off input help, I first had to press numlock key by itself again, before then using the original keystroke of NVDA + number row 1, since otherwise it just reported numlock numpad 0, followed by 1 to me, but, kept input help turned on.


And, if relevant, this is on my windows 10, anniversary upgrade, 64 bit machine, and, running NVDA 2016.3, with full desktop keyboard layout.


Stay well


Jacob Kruger
Blind Biker
Skype: BlindZA
"Resistance is futile, but, acceptance is versatile..."







--
Quentin Christensen
Training Material Developer
Basic Training for NVDA & Microsoft Word with NVDA E-Books now available: http://www.nvaccess.org/shop/

Direct: +61 413 904 383
www.nvaccess.org 
Facebook: http://www.facebook.com/NVAccess 
Twitter: @NVAccess 



Travis Siegel <tsiegel@...>
 

Also, according to the documentation, there is no touch gesture for turning on/off help mode, but a four finger doubletap does the job. (just thought it deserved mention).

On 11/17/2016 11:36 PM, Jacob Kruger wrote:
Not a bug report or anything, but, just a warning since it seems slightly odd, and, took me roundabout 2 seconds to realise what had happened...<smile>


Was double-checking layout of numpad keys for something else, so turned on NVDA's input help using NVDA key + number row 1.


Anyway, ran through all the numpad keys, including hitting just the numlock key, and, it did still turn on numlock, which meant that suddenly all the numpad keys were reporting their number characters, along with stating that numlock was being included - numlock numpad 5, for example.


Anyway, all this meant was that to then turn off input help, I first had to press numlock key by itself again, before then using the original keystroke of NVDA + number row 1, since otherwise it just reported numlock numpad 0, followed by 1 to me, but, kept input help turned on.


And, if relevant, this is on my windows 10, anniversary upgrade, 64 bit machine, and, running NVDA 2016.3, with full desktop keyboard layout.


Stay well


Jacob Kruger
Blind Biker
Skype: BlindZA
"Resistance is futile, but, acceptance is versatile..."