A bit of soundcard trouble


Anne Günther
 

Hi,
I'm using an usb-soundcard for work regularly, but don't want to send the nvda speech through that.
So I set the soundcard for that to the inbuild one of my laptop instead of "soundmapper". But when I puthe usb-card in, the speech is routed through it. I have to open the option dialogue for the speec engine and confirm that (the soundcard is still like I set it), then it works as intended.
Kind of the same when I remove the Usb-card. No speech until I reconfirmed the dialogue.
Is it me, or is it nvda? :-) And is there a way to prevent it?
take care, Guenni


 

Not really.

Its windows itself, switching default cards can be done but its a pain in the rear so I hardly do it actively.

Worse still if you switch away with nvda it may just screw up till you restart it and I have always switched back.

What I would tend to do if at all possible is make the internal card the default and switch applications as needed.

Its a pain but it probably works better.

The other way is to switch everything to the card in general bar nvda, and then switch nvda back to the card before you unplug it and it should in theory work.

Or set the external to the default card, and in theory it should switch back through.

On 20/06/2019 8:54 PM, Anne Günther wrote:
Hi,
I'm using an usb-soundcard for work regularly, but don't want to send the nvda speech through that.
So I set the soundcard for that to the inbuild one of my laptop instead of "soundmapper". But when I puthe usb-card in, the speech is routed through it. I have to open the option dialogue for the speec engine and confirm that (the soundcard is still like I set it), then it works as intended.
Kind of the same when I remove the Usb-card. No speech until I reconfirmed the dialogue.
Is it me, or is it nvda? :-) And is there a way to prevent it?
take care, Guenni




Robert Doc Wright godfearer
 

Let me see if I have this correct? You have installed a USB speakers to your laptop. You want your speech to remain on the internal speakers while the rest of the audio goes to the external speakers.

Make the external speakers the default speaker.

Press NVDA+ctrl+s tab once and then arrow down to your internal sound card and press enter

Press NVDA+ctrl+c to save configuration. NVDA should stay the same no matter what you do with your external speaker.

 

                                                                                                                                If all I have left in this world is God, I have everything!                                                                                                                                                                                                                                                                                                                                                Sent from Mail for Windows 10

 

From: Shaun Everiss
Sent: Thursday, June 20, 2019 4:54 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] A bit of soundcard trouble

 

Not really.

 

Its windows itself, switching default cards can be done but its a pain

in the rear so I hardly do it actively.

 

Worse still if you switch away with nvda it may just screw up till you

restart it and I have always switched back.

 

What I would tend to do if at all possible is make the internal card the

default and switch applications as needed.

 

Its a pain but it probably works better.

 

The other way is to switch everything to the card in general bar nvda,

and then switch nvda back to the card before you unplug it and it should

in theory work.

 

Or set the external to the default card, and in theory it should switch

back through.

 

 

 

On 20/06/2019 8:54 PM, Anne Günther wrote:

> Hi,

> I'm using an usb-soundcard for work regularly, but don't want to send

> the nvda speech through that.

> So I set the soundcard for that to the inbuild one of my laptop

> instead of "soundmapper". But when I puthe usb-card in, the speech is

> routed through it. I have to open the option dialogue for the speec

> engine and confirm that (the soundcard is still like I set it), then

> it works as intended.

> Kind of the same when I remove the Usb-card. No speech until I

> reconfirmed the dialogue.

> Is it me, or is it nvda? :-) And is there a way to prevent it?

> take care, Guenni

>