A Question About NVDA, Python 3 and Espeak


 

Hi,
How?
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of mattias
Sent: Sunday, July 28, 2019 10:54 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] A Question About NVDA, Python 3 and Espeak

no addon updater is broken

Den 2019-07-28 kl. 23:51, skrev David Csercsics:
The only add-ons I usually use are braille extender and the Windows 10
essential ones, and the add-on updater, but it looks like all of those
are either being updated, or already work fine with the new Python 3,
but I'd be happy to help with this if I can.





mattias
 

no addon updater is broken

Den 2019-07-28 kl. 23:51, skrev David Csercsics:

The only add-ons I usually use are braille extender and the Windows 10 essential ones, and the add-on updater, but it looks like all of those are either being updated, or already work fine with the new Python 3, but I'd be happy to help with this if I can.




David Csercsics
 

Alright, well, I'll poke around for another solution then, or see what can be done. At least there is time, and I do think the Python 3 changes are necessary. It is great the good work everyone is doing to make this stuff useful. Thank you!


 

Hi,
Braille Extender is broken, and it appears the site used for updating that add-on is gone somehow. Others are compatible and working.
Cheers,
Joseph

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of David Csercsics
Sent: Sunday, July 28, 2019 2:52 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] A Question About NVDA, Python 3 and Espeak

The only add-ons I usually use are braille extender and the Windows 10 essential ones, and the add-on updater, but it looks like all of those are either being updated, or already work fine with the new Python 3, but I'd be happy to help with this if I can.


David Csercsics
 

The only add-ons I usually use are braille extender and the Windows 10 essential ones, and the add-on updater, but it looks like all of those are either being updated, or already work fine with the new Python 3, but I'd be happy to help with this if I can.


Quentin Christensen
 

Also,

Just to be clear, the upcoming NVDA 2019.2 release is still based on the existing python 2 code, so any add-ons and synthesizers etc should still work.

We are also working with synth manufacturers, to ensure ongoing compatibility of their add-ons with NVDA into the future.

Regards

Quentin.

On Sat, Jul 27, 2019 at 6:27 PM Luke Davis <luke@...> wrote:
No, espeak works fine in Python 3 versions of NVDA.

On Sat, 27 Jul 2019, Marcio via Groups.Io wrote:

> Considering all the Python 3 porting conversation I have a question. It's been said that some synthesizers would stop working. Is it the case about Espeak?





--
Quentin Christensen
Training and Support Manager

NVDA 2019.2beta1 now available!


Luke Davis
 

No, espeak works fine in Python 3 versions of NVDA.

On Sat, 27 Jul 2019, Marcio via Groups.Io wrote:

Considering all the Python 3 porting conversation I have a question. It's been said that some synthesizers would stop working. Is it the case about Espeak?


 

Hi,
Considering all the Python 3 porting conversation I have a question. It's been said that some synthesizers would stop working. Is it the case about Espeak?

Thanks a lot.

Cheers,
Marcio AKA Starboy

Sent from a galaxy far, far away.

--
Are you a Thunderbird user? Then join the Thunderbird mailing list to help and be helped with all Thunderbird things - questions, features, add-ons and much more!