bug: NVDA causes all audio to play through both headphones and the pc speakers


enes sarıbaş
 

Hi all,

I am experiencing an odd issue. Frequently when using NVDA, all audio plays through both headphones and speakers. I know this is caused by NVDA, as restarting it usually resolves the problem. Even if it doesn't resolve, subsequent NVDA restarts do solve it.

I am running alpha  17808,4a78085

Does anyone know a solution?


David Csercsics
 

Does setting NVDA Synthesizer output to a specific sound card help? Normally it defaults to Microsoft sound mapper, but maybe it is doing something odd. So maybe if you give it a specific card it will work around the problem. Still a good bug report though, as something is going on with the code that shouldn't be.


Quentin Christensen
 

It sounds like it might be your audio driver.  NVDA by default sends its sound through the default audio device, unless you set a specific device in the NVDA synthesizer dialog. Are you plugging or unplugging your headphones or speakers?  I know Windows will often jump the default device to whatever you just plugged in.



On Fri, Aug 2, 2019 at 12:47 PM David Csercsics <bleeblat@...> wrote:
Does setting NVDA Synthesizer output to a specific sound card help?
Normally it defaults to Microsoft sound mapper, but maybe it is doing
something odd. So maybe if you give it a specific card it will work
around the problem. Still a good bug report though, as something is
going on with the code that shouldn't be.









--
Quentin Christensen
Training and Support Manager

NVDA 2019.2 RC 1 now available!


enes sarıbaş
 

Hi Quentin,

I don't unplug or plug the headphones for this to happen. For some reason, audio begins playing through both devices. But restarting NVDA multiple times, or a single time causes audio to get routed correctly again.

On 8/1/2019 10:59 PM, Quentin Christensen wrote:
It sounds like it might be your audio driver.  NVDA by default sends its sound through the default audio device, unless you set a specific device in the NVDA synthesizer dialog. Are you plugging or unplugging your headphones or speakers?  I know Windows will often jump the default device to whatever you just plugged in.



On Fri, Aug 2, 2019 at 12:47 PM David Csercsics <bleeblat@...> wrote:
Does setting NVDA Synthesizer output to a specific sound card help?
Normally it defaults to Microsoft sound mapper, but maybe it is doing
something odd. So maybe if you give it a specific card it will work
around the problem. Still a good bug report though, as something is
going on with the code that shouldn't be.









--
Quentin Christensen
Training and Support Manager

NVDA 2019.2 RC 1 now available!