setting Firefox as default browser using NVDA


Dan Beaver
 

I am trying to make Firefox my default browser.  I have the latest update to Firefox and am using the latest master branch of NVDA.  I am running under Win 10.


When I open Firefox it comes up with the "Firefox is not your default browser" dialog.  I click on the appropriate buttons and set Firefox as the default browser but every time I restart Firefox it still wants me to make it the default.


I am thinking that perhaps there is a dialog popping up that NVDA is not seeing and reporting to me but I am not sure of this.


Has anyone else had this issue and if so did you find a solution to it?


Thanks.


-- 
Dan Beaver (KA4DAN)


Chris
 

If you type in default browser in search it should come up with choose default browser select that to open up the default settings and select Firefox for your default browser

 

 

From: Dan Beaver
Sent: 22 August 2019 21:14
To: nvda@nvda.groups.io
Subject: [nvda] setting Firefox as default browser using NVDA

 

I am trying to make Firefox my default browser.  I have the latest update to Firefox and am using the latest master branch of NVDA.  I am running under Win 10.

 

When I open Firefox it comes up with the "Firefox is not your default browser" dialog.  I click on the appropriate buttons and set Firefox as the default browser but every time I restart Firefox it still wants me to make it the default.

 

I am thinking that perhaps there is a dialog popping up that NVDA is not seeing and reporting to me but I am not sure of this.

 

Has anyone else had this issue and if so did you find a solution to it?

 

Thanks.

 

-- 
Dan Beaver (KA4DAN)

 


Dan Beaver
 

Sorry, but this is just a shortcut way to get to the settings area for the default browser.  I did that and it doesn't stay set.


Dan Beaver

On 8/22/2019 4:20 PM, Chris via Groups.Io wrote:

If you type in default browser in search it should come up with choose default browser select that to open up the default settings and select Firefox for your default browser

 

 

From: Dan Beaver
Sent: 22 August 2019 21:14
To: nvda@nvda.groups.io
Subject: [nvda] setting Firefox as default browser using NVDA

 

I am trying to make Firefox my default browser.  I have the latest update to Firefox and am using the latest master branch of NVDA.  I am running under Win 10.

 

When I open Firefox it comes up with the "Firefox is not your default browser" dialog.  I click on the appropriate buttons and set Firefox as the default browser but every time I restart Firefox it still wants me to make it the default.

 

I am thinking that perhaps there is a dialog popping up that NVDA is not seeing and reporting to me but I am not sure of this.

 

Has anyone else had this issue and if so did you find a solution to it?

 

Thanks.

 

-- 
Dan Beaver (KA4DAN)

 

-- 
Dan Beaver (KA4DAN)


 

As a general note, setting anything as default under Windows 10 must be done in Windows 10 Settings, Apps, Default apps.

The "in program" dialogs are an anachronism that "don't stick" under Windows 10.   Those programmers who wanted to make their "in program" dialogs Windows Version agnostic query whether they're running under Windows 10 or not, then if they are actually trigger that Windows 10 Settings dialog to open to the correct pane and item to allow you to switch it.

I don't even bother "in program" anymore but just go to the Apps, Default Apps and handle it there.
--

Brian - Windows 10 Pro, 64-Bit, Version 1903, Build 18362  

The color of truth is grey.

           ~ André Gide

 

 


Dan Beaver
 

Brian,


I have tried that several times now and have even rebooted my system between tries and it still  doesn't stick.  I really do not understand what is happening here.


When I just tried it again when I click on the browser button it showed Firefox as being the default browser.  I clicked on it and then clicked on Firefox to make sure it was set and still it doesn't stick.


Maybe there is something wrong with Win 10 on my system and it isn't saving the settings in the place that Firefox is expecting it.  Not sure what is going on. 


Thanks for the suggestion though.


Dan Beaver

On 8/22/2019 4:36 PM, Brian Vogel wrote:
As a general note, setting anything as default under Windows 10 must be done in Windows 10 Settings, Apps, Default apps.

The "in program" dialogs are an anachronism that "don't stick" under Windows 10.   Those programmers who wanted to make their "in program" dialogs Windows Version agnostic query whether they're running under Windows 10 or not, then if they are actually trigger that Windows 10 Settings dialog to open to the correct pane and item to allow you to switch it.

I don't even bother "in program" anymore but just go to the Apps, Default Apps and handle it there.
--

Brian - Windows 10 Pro, 64-Bit, Version 1903, Build 18362  

The color of truth is grey.

           ~ André Gide

 

 

-- 
Dan Beaver (KA4DAN)


Gene
 

it sounds like a registry problem.  I don't know if anyone will be able to tell you how you ight solve it. 
 
All that default browser means is that something will open in Firefox if you press enter on it, such as if you press enter on a link in an e-mail.  But there are other easy ways to open something in the browser you wish.  They require a little more work, but since you evidently can't set the default browser to Firefox, an example is that, when you are on a link in an e-mail, open the context menu.  You will probably find something like copy link or something similar.  Pressing enter will copy the address to the clipboard.  Then paste it into the browser's address bar, press enter, and the page will open.  I regularly use that method.  I havbe one browser as my default because I want certain very specific things to open most easily.  But in general, I want to use another browser.
 
Gene

----- Original Message -----
From: Dan Beaver
Sent: Thursday, August 22, 2019 3:46 PM
Subject: Re: [nvda] setting Firefox as default browser using NVDA

Brian,


I have tried that several times now and have even rebooted my system between tries and it still  doesn't stick.  I really do not understand what is happening here.


When I just tried it again when I click on the browser button it showed Firefox as being the default browser.  I clicked on it and then clicked on Firefox to make sure it was set and still it doesn't stick.


Maybe there is something wrong with Win 10 on my system and it isn't saving the settings in the place that Firefox is expecting it.  Not sure what is going on. 


Thanks for the suggestion though.


Dan Beaver

On 8/22/2019 4:36 PM, Brian Vogel wrote:
As a general note, setting anything as default under Windows 10 must be done in Windows 10 Settings, Apps, Default apps.

The "in program" dialogs are an anachronism that "don't stick" under Windows 10.   Those programmers who wanted to make their "in program" dialogs Windows Version agnostic query whether they're running under Windows 10 or not, then if they are actually trigger that Windows 10 Settings dialog to open to the correct pane and item to allow you to switch it.

I don't even bother "in program" anymore but just go to the Apps, Default Apps and handle it there.
--

Brian - Windows 10 Pro, 64-Bit, Version 1903, Build 18362  

The color of truth is grey.

           ~ André Gide

 

 

-- 
Dan Beaver (KA4DAN)


Dan Beaver
 

Ok, now this is just crazy.


I decided to try setting the browser to Brave which I have been using for a while and see if that would stick.  It did.  I next went into settings and set the browser back to Firefox and now it is sticking and working as it should.  this is just nuts.


Thanks for all the suggestions.


Dan Beaver

On 8/22/2019 4:46 PM, Dan wrote:

Brian,


I have tried that several times now and have even rebooted my system between tries and it still  doesn't stick.  I really do not understand what is happening here.


When I just tried it again when I click on the browser button it showed Firefox as being the default browser.  I clicked on it and then clicked on Firefox to make sure it was set and still it doesn't stick.


Maybe there is something wrong with Win 10 on my system and it isn't saving the settings in the place that Firefox is expecting it.  Not sure what is going on. 


Thanks for the suggestion though.


Dan Beaver

On 8/22/2019 4:36 PM, Brian Vogel wrote:
As a general note, setting anything as default under Windows 10 must be done in Windows 10 Settings, Apps, Default apps.

The "in program" dialogs are an anachronism that "don't stick" under Windows 10.   Those programmers who wanted to make their "in program" dialogs Windows Version agnostic query whether they're running under Windows 10 or not, then if they are actually trigger that Windows 10 Settings dialog to open to the correct pane and item to allow you to switch it.

I don't even bother "in program" anymore but just go to the Apps, Default Apps and handle it there.
--

Brian - Windows 10 Pro, 64-Bit, Version 1903, Build 18362  

The color of truth is grey.

           ~ André Gide

 

 

-- 
Dan Beaver (KA4DAN)
-- 
Dan Beaver (KA4DAN)


 

On Thu, Aug 22, 2019 at 05:01 PM, Dan Beaver wrote:
Ok, now this is just crazy.
Seriously, this is exactly the sort of OS eccentricity that calls out for Doing a Windows 10 Repair Install or Feature Update Using the Windows 10 ISO file

 


I agree it's crazy/bizarre, which suggests something is wrong in your Windows 10 instance.   Repair installs are simple to do, and knock out an awful lot of potential problems in one fell swoop.
 
--

Brian - Windows 10 Pro, 64-Bit, Version 1903, Build 18362  

The color of truth is grey.

           ~ André Gide

 

 


Gene
 

But this may be nothing but one isolated incident, perhaps caused by a problem when you have one browser set as default and try to switch directly to another specific browser.  If no other problems exist, or they are so minor that they don't matter, there is no reason to do anything.
 
I suspect this is such a problem and I believe I recall cases from many years ago, where you couldn't switch default browsers directly from one to another if you were running one specific browser and tried to switch to another specific browser.
 
Gene

----- Original Message -----
Sent: Thursday, August 22, 2019 4:07 PM
Subject: Re: [nvda] setting Firefox as default browser using NVDA

On Thu, Aug 22, 2019 at 05:01 PM, Dan Beaver wrote:
Ok, now this is just crazy.
Seriously, this is exactly the sort of OS eccentricity that calls out for Doing a Windows 10 Repair Install or Feature Update Using the Windows 10 ISO file

 


I agree it's crazy/bizarre, which suggests something is wrong in your Windows 10 instance.   Repair installs are simple to do, and knock out an awful lot of potential problems in one fell swoop.
 
--

Brian - Windows 10 Pro, 64-Bit, Version 1903, Build 18362  

The color of truth is grey.

           ~ André Gide

 

 


 

On Thu, Aug 22, 2019 at 05:16 PM, Gene wrote:
I suspect this is such a problem and I believe I recall cases from many years ago, where you couldn't switch default browsers directly from one to another if you were running one specific browser and tried to switch to another specific browser.
Not that I doubt this, and it prompted me to test under Windows 10, Version 1903, Build 18362.295, and it does not occur.

I've switched the default browser app while all of the browsers are open and browsing, and when I activate a link in a standalone e-mail client, Thunderbird in this case, whatever I last set comes up.

This is not meant to start an argument, but probably will:  There are lots of behaviors that I am so familiar with "normal" that "atypical" just screams out at me.  The behavior described is highly atypical under Windows 10, and I prefer to take steps that address likely underlying corruption quickly.  Particularly when there's not a downside (or a significant chance of one) in doing so.
 
--

Brian - Windows 10 Pro, 64-Bit, Version 1903, Build 18362  

The color of truth is grey.

           ~ André Gide

 

 


Cearbhall O'Meadhra
 

Brian,

 

I was intrigued by your recent discussion and so I had a go at changing my default browser from Chrome to Firefox. At first, it did not hold. But after two more attempts it did take.

 

I used Restart as the shutdown procedure. Should I have used shutdown instead? I have a feeling that I read something about the Shutdown procedure closing all windows routines but the Restart does not do so. I would be glad if you could clarify this for me.

 

After the second attempt, Firefox is now my default browser. My HTML files open in Firefox, as you would expect.

 

When I type a web address into the windows search box, the web page always comes up in EDGE! How can I change that default behaviour to Firefox? Edge is listed in the potential default apps but is not checked as the default, Firefox is.

 

All the best,

 

Cearbhall

 

m +353 (0)833323487 Ph: _353 (0)1-2864623 e: cearbhall.omeadhra@...

 

 

From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Brian Vogel
Sent: Thursday, August 22, 2019 10:37 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] setting Firefox as default browser using NVDA

 

On Thu, Aug 22, 2019 at 05:16 PM, Gene wrote:

I suspect this is such a problem and I believe I recall cases from many years ago, where you couldn't switch default browsers directly from one to another if you were running one specific browser and tried to switch to another specific browser.

Not that I doubt this, and it prompted me to test under Windows 10, Version 1903, Build 18362.295, and it does not occur.

I've switched the default browser app while all of the browsers are open and browsing, and when I activate a link in a standalone e-mail client, Thunderbird in this case, whatever I last set comes up.

This is not meant to start an argument, but probably will:  There are lots of behaviors that I am so familiar with "normal" that "atypical" just screams out at me.  The behavior described is highly atypical under Windows 10, and I prefer to take steps that address likely underlying corruption quickly.  Particularly when there's not a downside (or a significant chance of one) in doing so.
 
--

Brian - Windows 10 Pro, 64-Bit, Version 1903, Build 18362  

The color of truth is grey.

           ~ André Gide

 

 


Luke Davis
 

On Thu, 22 Aug 2019, Cearbhall O'Meadhra wrote:

I used “Restart” as the shutdown procedure. Should I have used “shutdown” instead? I have a feeling that I read something about the Shutdown procedure
closing all windows routines but the Restart does not do so. I would be glad if you could clarify this for me.
I am not Brian, but I can clarify that for you. It is, in fact, the exact opposite of what you thought. A restart brings Windows down, then restarts it from the ground up. These days, shutdown actually just puts your system into a hibernation mode (a more inactive form of sleep mode), and never really shuts it down. Therefore, restart is the more effective way to be sure Windows actually shuts down and comes back up.

When I type a web address into the windows search box, the web page always comes up in EDGE! How can I change that default behavior to Firefox? Edge is
listed in the potential default apps but is not checked as the default, Firefox is.
I don't know how to (or if you can) fix that, but if you use windows+r (the run dialog) to type your web addresses, they should open in the default browser.

Luke


Gene
 

If fast boot is disabled, shutdown will completely shut down the computer.  If I had Windows 10 and had fast boot on, I would still do a restart from time to time to avoid instability caused by Windows not fully ever shutting down.  How often you would do this, you can experiment to find out.  But if you don't want to experiment, I would think four or five day intervals would be good.  But you may have stability and performance problems sooner or later so you may want to experiment.
 
Gene

----- Original Message -----
From: Luke Davis
Sent: Thursday, August 22, 2019 5:13 PM
Subject: Re: [nvda] setting Firefox as default browser using NVDA

On Thu, 22 Aug 2019, Cearbhall O'Meadhra wrote:

> I used “Restart” as the shutdown procedure. Should I have used “shutdown” instead? I have a feeling that I read something about the Shutdown procedure
> closing all windows routines but the Restart does not do so. I would be glad if you could clarify this for me.

I am not Brian, but I can clarify that for you. It is, in fact, the exact
opposite of what you thought. A restart brings Windows down, then restarts it
from the ground up. These days, shutdown actually just puts your system into a
hibernation mode (a more inactive form of sleep mode), and never really shuts it
down. Therefore, restart is the more effective way to be sure Windows actually
shuts down and comes back up.

> When I type a web address into the windows search box, the web page always comes up in EDGE! How can I change that default behavior to Firefox? Edge is
> listed in the potential default apps but is not checked as the default, Firefox is.

I don't know how to (or if you can) fix that, but if you use windows+r (the run
dialog) to type your web addresses, they should open in the default browser.

Luke




Luke Davis
 

All true, although I didn't think it necessary to get into in answering the specific question.
That said, if the topic interests anyone, here is a pretty comprehensive (and recent) article about it, why you should/shouldn't do it, and how to change it.

https://www.windowscentral.com/how-disable-windows-10-fast-startup

Luke

On Thu, 22 Aug 2019, Gene wrote:

If fast boot is disabled, shutdown will completely shut down the computer.  If I had Windows 10 and had fast boot on, I would still do a restart from time
to time to avoid instability caused by Windows not fully ever shutting down.  How often you would do this, you can experiment to find out.  But if you don't
want to experiment, I would think four or five day intervals would be good.  But you may have stability and performance problems sooner or later so you may
want to experiment.
 
Gene
----- Original Message -----
From: Luke Davis
Sent: Thursday, August 22, 2019 5:13 PM
To: nvda@nvda.groups.io
Subject: Re: [nvda] setting Firefox as default browser using NVDA
On Thu, 22 Aug 2019, Cearbhall O'Meadhra wrote:

I used “Restart” as the shutdown procedure. Should I have used “shutdown” instead? I have a feeling that I read something about the Shutdown procedure
closing all windows routines but the Restart does not do so. I would be glad if you could clarify this for me.
I am not Brian, but I can clarify that for you. It is, in fact, the exact
opposite of what you thought. A restart brings Windows down, then restarts it
from the ground up. These days, shutdown actually just puts your system into a
hibernation mode (a more inactive form of sleep mode), and never really shuts it
down. Therefore, restart is the more effective way to be sure Windows actually
shuts down and comes back up.

When I type a web address into the windows search box, the web page always comes up in EDGE! How can I change that default behavior to Firefox? Edge is
listed in the potential default apps but is not checked as the default, Firefox is.
I don't know how to (or if you can) fix that, but if you use windows+r (the run
dialog) to type your web addresses, they should open in the default browser.
Luke


 

On Thu, Aug 22, 2019 at 06:13 PM, Luke Davis wrote:
I am not Brian, but I can clarify that for you. It is, in fact, the exact opposite of what you thought. A restart brings Windows down, then restarts it from the ground up. These days, shutdown actually just puts your system into a hibernation mode (a more inactive form of sleep mode), and never really shuts it down. Therefore, restart is the more effective way to be sure Windows actually shuts down and comes back up.
Yep.   The most inane and counterintuitive change Microsoft introduced.   I have nothing against the Fast Startup, per se, but I do have a huge problem with how people can and do believe that doing a shutdown does exactly what it says.   If they wanted a separate form of Hibernation, which is what Fast Startup does (it only saves the OS system state out to disk, full hibernation does that along with the user state(s) for all user(s) active at the time), they should have called it something like Slumber.

The first thing I do when configuring a new Windows 10 system is to turn Fast Startup off.  When, not if, but when a corruption in the hiberfile occurs your system can have some of the most bizarre behaviors that make absolutely no sense.  And the multi-hour tail chasing I did once to determine this when working with one of my clients in a community college setting, trying to figure out why his keyboard would not work right (and, thus, neither did JAWS) I never wanted to do it again.

On systems with SSDs the decrease in boot times when it's off are imperceptible.  On regular HDD it's not that much longer to boot from scratch, and well worth it in my opinion.
 
--

Brian - Windows 10 Pro, 64-Bit, Version 1903, Build 18362  

The color of truth is grey.

           ~ André Gide

 

 


Luke Davis
 

On Thu, 22 Aug 2019, Brian Vogel wrote:

Yep.   The most inane and counterintuitive change Microsoft introduced.   I have nothing against the Fast Startup, per se, but I do have a huge problem with
how people can and do believe that doing a shutdown does exactly what it says.   If they wanted a separate form of Hibernation, which is what Fast Startup
does (it only saves the OS system state out to disk, full hibernation does that along with the user state(s) for all user(s) active at the time), they
should have called it something like Slumber.The first thing I do when configuring a new Windows 10 system is to turn Fast Startup off.  When, not if, but
Quite agreed. And the first thing MS does on a windows update, is turn it back on. Be warned.

On systems with SSDs the decrease in boot times when it's off are imperceptible.  On
regular HDD it's not that much longer to boot from scratch, and well worth it in my opinion.
On my HDD equipped laptop, turning it off approximately doubles boot time, to about two minutes.
Well, actually, about 50 seconds of that is between logon and desktop stability, which is usually shorter with this option turned on, although I'm not exactly sure why, since it shouldn't have any effect at that point in the process.

Luke


 

On Thu, Aug 22, 2019 at 11:02 PM, Luke Davis wrote:
And the first thing MS does on a windows update, is turn it [Fast Startup] back on. Be warned.
People should check, because what you report does happen to a subset of Windows 10 users, and for reasons I have never been able to determine.

Not a single one of my 5 machines here at home has ever had my choice of Fast Startup off revert to on after a feature update.  It's stayed off once set that way.

--

Brian - Windows 10 Pro, 64-Bit, Version 1903, Build 18362  

The color of truth is grey.

           ~ André Gide

 

 


Luke Davis
 

On Thu, 22 Aug 2019, Brian Vogel wrote:

On Thu, Aug 22, 2019 at 11:02 PM, Luke Davis wrote:
And the first thing MS does on a windows update, is turn it [Fast Startup] back on. Be warned.
People should check, because what you report does happen to a subset of Windows 10 users, and for reasons I have never been able to determine.Not a single
one of my 5 machines here at home has ever had my choice of Fast Startup off revert to on after a feature update.  It's stayed off once set that way.
Strange indeed. I've lost it twice that I know of, and the author of the WindowsCentral article I posted earlier mentioned it as well.

Luke