Admin's Note: RE: [nvda] Accappella TTS Config: OK, face it. I'mutterly confused!

Nimer Jaber

Right… if you have concerns about a moderator’s decision on this list or any other list for that matter, I suggest that you contact the owner address for that list. As for now though, because this topic does not actually have very much to do with NVDA, and because the issue could be better troubleshot individually with Chris, I am recommending that this thread does not continue further on this list. Again, if you wish to join me for a cup of tea to discuss this further off-list, please send a message to the owner address. I am very open to an off-list tea party.


Sent from Mail for Windows 10


From: Life My Way via Groups.Io
Sent: Tuesday, January 31, 2017 21:46
Subject: Re: Admin's Note: RE: [nvda] Accappella TTS Config: OK, face it. I'mutterly confused!


from what i remember, the reperesentive for the company posted this link and the way to get this to work on the list; so i think this could be talked about on list.


On 1/31/2017 9:35 PM, Nimer Jaber wrote:



Please respond to Chris off-list. Chris, you should probably also contact Acapela directly. This is more of an issue with their synth and your syntax than with the NVDA screen reader. No further admin intervention will occur unless this thread gets out of hand. Also, please endeavor to moderate your language on this list as we do have a wide variety of members, and we are the representatives of the great NVDA screen reader. If you have any questions, please submit them to the owner address.




Sent from Mail for Windows 10


From: Christopher-Mark Gilland
Sent: Tuesday, January 31, 2017 21:27
Subject: [nvda] Accappella TTS Config: OK, face it. I'm utterly confused!
Importance: High


First off, let me refer you to this link:


OK, so here's the deal.


I have NVDA 2016.4 on Windows 10 Home 64 Bit.


I'm trying whilst pulling my dang hair out over here to figure out, excuse my language, why in the bloody hell! this isn't working.


Here's what I've done up to this point.


1. Press Windows key+R to open the run dialog.


2. Typed c: and pressed enter.


3. Navigated to Program Files X86, and pressed enter on the NVDA folder.


4. Navigated to builtin.dic


5. Pressed CTRL+C to copy it to the clipboard


6. Navigated to my Documents folder


7. Pressed CTRL+V to paste the file so I'd have a backup copy.


8. Went back to the NVDA directory, and pressed enter to open Builtin.dic


9. Found the line about breaking words that end with numbers. This line, in itself was commented, but the line referenced in the link above right below it wasn't.

10. Typed a number sign, (#) right at the very beginning of the line directly after the break line. I then put a space after the number sign.


So, here is what my entire file looks like. Note that to seperate the file's content from the rest of the file, I have put the content between two lines of three hyphens. The hyphens are not in the file. They are only being used as a container placeholder to show you all where the content begins and ends, so, beware.



#break up words that use a capital letter to denote another word
([a-z])([A-Z]) \1 \2 1 1
#Break away a word starting with a capital from a fully uppercase word
([A-Z])([A-Z][a-z]) \1 \2 1 1
#Break words that have numbers at the end
# ((?:(?=\D)\w)+)(\d+) \1 \2 1 1



11. Pressed CTRL+S to save. Was presented with a save as dialog. Left the file name alone, tabbed to the save button, pressed enter, said yes to replace, then got an error access denied. Yes. I am logged on as an administrator.


12. Closed this Notepad window with the file, went to my Documents folder, found the file, editted it in Notepad to read as the following:



#break up words that use a capital letter to denote another word
([a-z])([A-Z]) \1 \2 1 1
#Break away a word starting with a capital from a fully uppercase word
([A-Z])([A-Z][a-z]) \1 \2 1 1
#Break words that have numbers at the end
# ((?:(?=\D)\w)+)(\d+) \1 \2 1 1



Then pressed CTRL+S to save. This worked as far as saving the file.


13. I then copied this file over to the c:\Program Files X86\NVDA directory, replacing the file that was already there with the newly modified version. I was asked if I wanted to use automatic elevated priveledges to complete this task, and I said OK. The file was copied over successfully.


14. I restarted NVDA.


15. I pressed NVDA+CTRL+S to select synthesizer, and went to Accappella TTS. ON my end this loaded the Ella voice, which is fine, as she's exactly who I want to do this with.


15. I opened a blank file in Notepad, and in it, I typed:




I tried this all the way up to 05, and it did absolutely no good. All she says is, number laugh 0 1  number.


I tried putting a space after this line of text, no good. I even tried a carriage return, but that didn't work either. No other text was on the same line. The whole document was totally empty except for this.


16. I tried




I wanted to make her cough as hard as she could, so I could really really hear it in case it was suttle. That didn't work. All I heard was number cough 05 number.


17. I also tried with



No good.


I dono what on earth I did wrong!


I know some voices don't have all the sounds nor exclamations recorded, but unless I read it wrong, it looks like Ella should have all the above sounds included. I should note that the syntax of how I am writing these things in Notepad on a line all by themselves is: number sign, then in all caps, the sound name, like cough, for example, c o u g h, then no space after the letter h, 05, then another number sign.


I've tried putting a space after the first number sign before the letter C in cough. No good. I tried putting a space after the 5 in cough05, no good. I've put a space before the numbers 05, no good. I put a space on both sides, before the C, and after the 5 both. No good. I even did a space before the C, after the H, and after the 5 all 3. No good. Basically, long story short, I tried every combination under the fortunate sun!


I'm totally sure the voices are activated, and these voices are on version 1.49. I've tried all 5 levels of laugh, cough, cry, sneeze, breath, and even have tried CAR REVVING. I even tried all 5 of AARGH. No good.


Have tried with Ella, Will, Will Happy, Rosey, Amilio, Josh, and I think even Heather. I also tried with Mika.


I'm totally at a loss! I even did the sloppy work around by adding the actual number sign symbol to the temporary dictionary, and replacing with nothing more than a space character, then, setting the radio button cluster to Anywhere. That didn't do it either. That got rid of it saying number, but now, all I get is




and that's it. No boo hoo hoo, no ha ha ha, no aaaaaaaaarg! Nothing.


I have some txt files of things I've written, and I really, really, really! would like to get these things working, as I think it would make reading the files really awesome, if I could get those codes to work.


If anyone's gotten this to work, then tell me step by step what to do. I have a backup copy of NVDA that I can revert back to if you'd like me to just start over totally fresh from before I ever started screwing with this, this way we're at ground square 1.


The more specific keystroke by keystroke you can be at telling me how to do this, the better. Please, be as specific as you can be. Trust me. The extral verbiage will not drive me crazy. Right now, I think I'm gonna need it.


Again, Windows 10 Home 64 bit, Accappella TTS for NVDA V 1.49, and NVDA 2016.4 official release.


Thank you profusely!