Brltty with Windows 10 Creators update


 

Hi,

Did you happen to tell Narrator to turn on braille support (if you have Creators Update)?

Cheers,

Joseph

 

From: nvda@nvda.groups.io [mailto:nvda@nvda.groups.io] On Behalf Of Deborah Armstrong
Sent: Friday, May 26, 2017 10:07 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] Brltty with Windows 10 Creators update

 

The reason using Brltty can be important is because it supports thos old, no longer produced, no longer documented Braille displays. And you can find them on Ebay for a song!


I still don't have Brltty working in Win10 but I was incorrect in my previous post. I can't actually find a brltty.conf file at all, so I'm guessing my settings for current display and interface port are stored elsewhere.  I was looking at my windows 7 machine where the brltty.conf is in C:\Program Files (x86)\BRLTTY\etc. In my Windows 10 machine, I have a brltty folder directly under the windows folder. Then there's an etc folder under that, and a brltty folder under that but no brltty.conf.

I'd really like to get this working, and am avoiding calling the Microsoft Disability Answer desk, because I bet they know less about Brltty than I do.  


Deborah Armstrong <debee@...>
 

The reason using Brltty can be important is because it supports thos old, no longer produced, no longer documented Braille displays. And you can find them on Ebay for a song!


I still don't have Brltty working in Win10 but I was incorrect in my previous post. I can't actually find a brltty.conf file at all, so I'm guessing my settings for current display and interface port are stored elsewhere.  I was looking at my windows 7 machine where the brltty.conf is in C:\Program Files (x86)\BRLTTY\etc. In my Windows 10 machine, I have a brltty folder directly under the windows folder. Then there's an etc folder under that, and a brltty folder under that but no brltty.conf.

I'd really like to get this working, and am avoiding calling the Microsoft Disability Answer desk, because I bet they know less about Brltty than I do.  


Holger Fiallo <hfiallo@...>
 

 
It works well for me. I got the new version of W10 and NVDA. No issues. However I have a desktop and not a labtop.

From: Deborah Armstrong
Sent: Wednesday, May 24, 2017 4:24 PM
To: nvda@nvda.groups.io
Subject: [nvda] Brltty with Windows 10 Creators update
 
I am an experienced user of brltty in both Linux and Windows 7. (I use Windows 7 at my job but not at home.) In Windows I use it with NVDA because the versions I’ve downloaded in the past never worked with my 64-bit Windows 7 without NVDA being present.
 
Now that I’ve got the Creators’ update with Windows 10 on my home laptop, I’m wondering what others’ experience is getting it to work with NVDA. So far I’ve had no success.
 
I confirmed my laptop had no previous version of Brltty installed and certainly no Brlapi services that might run to confuse things.
 
I next exited NVDA, ran Narrator, went to Narrator settings under the full Ease of Access settings accessed with Windows I.
 
I tabbed over to Braille, and chose Install Braille. A terminal with some program whose name I didn’t catch ran.
 
Now in Narrator settings, there’s a check box for enable Braille that’s checked. I also had to choose a display. I have several old displays that do work with Brltty and NVDA under Windows 7 on my computers in my job.  I selected one of these and made it the default.
 
I rebooted, and looked at the settings dialog for Braille with NVDA , and then exited NVDA and used Narrator to look at the same settings. I exited narrator and used JAWS to also examine the settings. All looks good; Braille is enabled and I currently have a Fredom Scientific Focus blue set as my default display and the Freedom Scientific drivers are disabled and the Braille libusb drivers are enabled. Brltty is installed in /windows/bin, whereas under windows 7 it’s installed in program files (x86), but the /etc/brltty.conf is correctly configured for my focus blue.
 
I’m still not getting any Braille, either in Narrator or Nvda. I am not getting Braille with JAWS either, but that’s because I disabled the freedom scientific drivers as instructed in Chapter 7 of Microsoft’s newest guide to using Narrator.
 
My ultimate goal is to use a TSI PowerBraille with both NVDA and narrator on this laptop, since I have several I bought on ebay and they work well.
 
Has anyone gotten Braille working under Windows 10 and also gotten NVDA to use this new Microsoft version of Brltty?
 
Thanks.
 
--Debee
 


Deborah Armstrong <debee@...>
 

I am an experienced user of brltty in both Linux and Windows 7. (I use Windows 7 at my job but not at home.) In Windows I use it with NVDA because the versions I’ve downloaded in the past never worked with my 64-bit Windows 7 without NVDA being present.
 
Now that I’ve got the Creators’ update with Windows 10 on my home laptop, I’m wondering what others’ experience is getting it to work with NVDA. So far I’ve had no success.
 
I confirmed my laptop had no previous version of Brltty installed and certainly no Brlapi services that might run to confuse things.
 
I next exited NVDA, ran Narrator, went to Narrator settings under the full Ease of Access settings accessed with Windows I.
 
I tabbed over to Braille, and chose Install Braille. A terminal with some program whose name I didn’t catch ran.
 
Now in Narrator settings, there’s a check box for enable Braille that’s checked. I also had to choose a display. I have several old displays that do work with Brltty and NVDA under Windows 7 on my computers in my job.  I selected one of these and made it the default.
 
I rebooted, and looked at the settings dialog for Braille with NVDA , and then exited NVDA and used Narrator to look at the same settings. I exited narrator and used JAWS to also examine the settings. All looks good; Braille is enabled and I currently have a Fredom Scientific Focus blue set as my default display and the Freedom Scientific drivers are disabled and the Braille libusb drivers are enabled. Brltty is installed in /windows/bin, whereas under windows 7 it’s installed in program files (x86), but the /etc/brltty.conf is correctly configured for my focus blue.
 
I’m still not getting any Braille, either in Narrator or Nvda. I am not getting Braille with JAWS either, but that’s because I disabled the freedom scientific drivers as instructed in Chapter 7 of Microsoft’s newest guide to using Narrator.
 
My ultimate goal is to use a TSI PowerBraille with both NVDA and narrator on this laptop, since I have several I bought on ebay and they work well.
 
Has anyone gotten Braille working under Windows 10 and also gotten NVDA to use this new Microsoft version of Brltty?
 
Thanks.
 
--Debee