Topics

NVDA Buzzing and Speaking in a Compressed Way During Keyboard Input on a Fast Laptop


Luke Davis
 

Hello

Today I acquired an MSI laptop. Intel I7 Hexacore 2.6 GHZ (4.5 burst), 32 GB RAM, 64 bit.

I ran 2019.2.1 as a portable without problem, and installed 2019.3 beta. Then I updated from Windows 110 Home 1709 to 1809, and noticed the following weird behavior. I subsequently updated to 1909, and nothing has changed.
I have never seen this before.

Using either ESpeak or OneCore, whenever I type quickly or move the mouse, I find that speech either hangs up in bad robotic sounding buzzes, or gets really "small", like a munchkin version of the synth in use.

It is a bit hard to describe. So I made a small recording:
http://newanswertech.com/Weird-NVDA1.m4a

It happens always when I am typing quickly, or just moving quickly through a file list with the arrow keys. As you can hear from the file, it even happens periodically when I am typing slowly.

This is really unacceptable.

I purged 2019.3 and installed 2019.2.1, but the same behavior continues.

If this were the old days, I would think there was some kind of IRQ conflict between the keyboard and the audio subsystem.
It's been so long since I have had to solve that kind of problem though, that I'm not immediately sure how to diagnose it.

Any thoughts would be welcome.

Luke


Jackie
 

Hey Luke? The file gives an unsupported video format error.

My first thought is that you're running RealTeck & that you need an
updated driver. You've also got some audio software on there called
Nahemic, & it wants to optimize your audio experience. Do not, under
any circumstances, allow that, as I will guarantee-told you it will be
beyond suboptimal. It's kind of a b-word to navigate, too,
unfortunately, but it is actually text-based, so object nav & the tab
key are your friends.

I realize the whole situation is unacceptable, unfortunately, I'm kind
of committed till after New Year's day, so I'm not in a position to
give much more help than this at present. Hopefully, though, it's
enough to give you a nudge in the proper direction. If not, we can
hopefully get together on the 2nd & troubleshoot this.

On 12/27/19, Luke Davis <luke@newanswertech.com> wrote:
Hello

Today I acquired an MSI laptop. Intel I7 Hexacore 2.6 GHZ (4.5 burst), 32 GB

RAM, 64 bit.

I ran 2019.2.1 as a portable without problem, and installed 2019.3 beta.
Then I
updated from Windows 110 Home 1709 to 1809, and noticed the following weird

behavior. I subsequently updated to 1909, and nothing has changed.
I have never seen this before.

Using either ESpeak or OneCore, whenever I type quickly or move the mouse, I

find that speech either hangs up in bad robotic sounding buzzes, or gets
really
"small", like a munchkin version of the synth in use.

It is a bit hard to describe. So I made a small recording:
http://newanswertech.com/Weird-NVDA1.m4a

It happens always when I am typing quickly, or just moving quickly through a

file list with the arrow keys. As you can hear from the file, it even
happens
periodically when I am typing slowly.

This is really unacceptable.

I purged 2019.3 and installed 2019.2.1, but the same behavior continues.

If this were the old days, I would think there was some kind of IRQ conflict

between the keyboard and the audio subsystem.
It's been so long since I have had to solve that kind of problem though,
that
I'm not immediately sure how to diagnose it.

Any thoughts would be welcome.

Luke



--
Subscribe to a WordPress for Newbies Mailing List by sending a message to:
wp4newbs-request@freelists.org with 'subscribe' in the Subject field OR by
visiting the list page at http://www.freelists.org/list/wp4newbs
& check out my sites at www.brighter-vision.com & www.mysitesbeenhacked.com


Luke Davis
 

Hi Jackie and others

I have made a new recording, and saved it as MP3 to prevent any file type problems.
This one is a demonstration of moving down through the NVDA folder in %appdata%, followed by some rapid typing in Notepad.
http://newanswertech.com/Weird-NVDA2.mp3
Not the best quality, as it's just recorded from an iPhone microphone from a foot away, but I could plug in and record the "right" way if someone needs a better demo.

There was a RealTek driver updated, although I thought this had already started at that point. Trying to roll it back would roll back the entire 1909 update, which would be annoying.

If what Jackie suggests is the case, then this is unrelated to NVDA, and shouldn't be on this list. So unless someone else has some alternative theory, I will hereby discontinue this thread, with apologies for off-topicacality.

Luke

On Fri, 27 Dec 2019, Jackie wrote:

Hey Luke? The file gives an unsupported video format error.

My first thought is that you're running RealTeck & that you need an
updated driver. You've also got some audio software on there called
Nahemic, & it wants to optimize your audio experience. Do not, under
any circumstances, allow that, as I will guarantee-told you it will be
beyond suboptimal. It's kind of a b-word to navigate, too,
unfortunately, but it is actually text-based, so object nav & the tab
key are your friends.


molly the blind tech lover
 

Hi.
I don't know if this will help, but you could try a system restore or go
back to a previous windows installation. Perhaps during one of the updates
some file or other got corrupted?

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Luke Davis
Sent: Saturday, December 28, 2019 9:34 AM
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA Buzzing and Speaking in a Compressed Way During
Keyboard Input on a Fast Laptop

Hi Jackie and others

I have made a new recording, and saved it as MP3 to prevent any file type
problems.
This one is a demonstration of moving down through the NVDA folder in
%appdata%, followed by some rapid typing in Notepad.
http://newanswertech.com/Weird-NVDA2.mp3
Not the best quality, as it's just recorded from an iPhone microphone from a
foot away, but I could plug in and record the "right" way if someone needs a
better demo.

There was a RealTek driver updated, although I thought this had already
started at that point. Trying to roll it back would roll back the entire
1909 update, which would be annoying.

If what Jackie suggests is the case, then this is unrelated to NVDA, and
shouldn't be on this list. So unless someone else has some alternative
theory, I will hereby discontinue this thread, with apologies for
off-topicacality.

Luke


On Fri, 27 Dec 2019, Jackie wrote:

Hey Luke? The file gives an unsupported video format error.

My first thought is that you're running RealTeck & that you need an
updated driver. You've also got some audio software on there called
Nahemic, & it wants to optimize your audio experience. Do not, under
any circumstances, allow that, as I will guarantee-told you it will be
beyond suboptimal. It's kind of a b-word to navigate, too,
unfortunately, but it is actually text-based, so object nav & the tab
key are your friends.


Ralf Kefferpuetz
 

Wow, that sounds really strange. I'm sure somebody already gave you the hint to disable the audio enhancements for your
realtek playback speaker device?

Cheers,
Ralf

-----Original Message-----
From: nvda@nvda.groups.io <nvda@nvda.groups.io> On Behalf Of Luke Davis
Sent: Samstag, 28. Dezember 2019 15:34
To: nvda@nvda.groups.io
Subject: Re: [nvda] NVDA Buzzing and Speaking in a Compressed Way During Keyboard Input on a Fast Laptop

Hi Jackie and others

I have made a new recording, and saved it as MP3 to prevent any file type problems.
This one is a demonstration of moving down through the NVDA folder in %appdata%, followed by some rapid typing in
Notepad.
http://newanswertech.com/Weird-NVDA2.mp3
Not the best quality, as it's just recorded from an iPhone microphone from a foot away, but I could plug in and record
the "right" way if someone needs a better demo.

There was a RealTek driver updated, although I thought this had already started at that point. Trying to roll it back
would roll back the entire 1909 update, which would be annoying.

If what Jackie suggests is the case, then this is unrelated to NVDA, and shouldn't be on this list. So unless someone
else has some alternative theory, I will hereby discontinue this thread, with apologies for off-topicacality.

Luke


On Fri, 27 Dec 2019, Jackie wrote:

Hey Luke? The file gives an unsupported video format error.

My first thought is that you're running RealTeck & that you need an
updated driver. You've also got some audio software on there called
Nahemic, & it wants to optimize your audio experience. Do not, under
any circumstances, allow that, as I will guarantee-told you it will be
beyond suboptimal. It's kind of a b-word to navigate, too,
unfortunately, but it is actually text-based, so object nav & the tab
key are your friends.


Luke Davis
 

On Sat, 28 Dec 2019, Ralf Kefferpuetz wrote:

Wow, that sounds really strange. I'm sure somebody already gave you the hint to disable the audio enhancements for your
realtek playback speaker device?
Got it in one!

I completely forgot about that setting, since I don't have it on my primary laptop. Well, former primary laptop.

That took care of the issue, and all it cost was a 10DB loss of maximum volume which enhancements seems to provide.

Thanks Ralf, and to others who offered help; and blessings for 2020 to all on this list!

Luke


Jeff Samco
 

I had  similar behavior for me start up about 3 weeks ago. I use current NVDA public release on a Windows 10 laptop. I have RealTech sound but cannot locate where to check enhancements. I looked in Sound Link oin Control Panel but couldn't find anything for enhancements. Can someone direct me?

Thanks,
jeff


At 08:13 PM 12/28/2019, you wrote:
On Sat, 28 Dec 2019, Ralf Kefferpuetz wrote:

Wow, that sounds really strange. I'm sure somebody already gave you the hint to disable the audio enhancements for your
realtek playback speaker device?

Got it in one!

I completely forgot about that setting, since I don't have it on my primary laptop. Well, former primary laptop.

That took care of the issue, and all it cost was a 10DB loss of maximum volume which enhancements seems to provide.

Thanks Ralf, and to others who offered help; and blessings for 2020 to all on this list!

Luke




Luke Davis
 

On Sat, 28 Dec 2019, Jeff Samco wrote:

I had  similar behavior for me start up about 3 weeks ago. I use current NVDA public release on a Windows 10 laptop. I have RealTech sound but cannot locate
where to check enhancements. I looked in Sound Link oin Control Panel but couldn't find anything for enhancements. Can someone direct me?
Press Windows, and type:
sound
The first thing should be sound in settings. Press enter on that.

You should then find that your primary output device is selected automatically from the dropdown provided. If not, select it.
Then tab once to "Device properties" and press enter.
Next you tab (I believe) seven times, to "Additional device properties", and press enter.
Press shift tab, which takes you to the tabs of the properties window, and move right to "Advanced".

Tab from there until you find the enhancements checkbox, if you have one, and uncheck it. It should be right after "exclusive mode". Then hit apply or OK, and the rest is just getting back out.

There are more straight forward ways of getting to those settings right now, but that's the one I used tonight, so it's most fresh in my mind.

Hth.

Luke


Jeff Samco
 

Thank you, Luke.   Your instructions got me to the same place I had found on my own. But, I don't find an enhancements checkbox or anything similar. After  Exclusive mode is just a Restore Defaults.  This has me stumped.
I am working with my default sound device which is RealTech speakers.
Any other words of advice?
Jeff


At 10:06 PM 12/28/2019, you wrote:
On Sat, 28 Dec 2019, Jeff Samco wrote:

I had  similar behavior for me start up about 3 weeks ago. I use current NVDA public release on a Windows 10 laptop. I have RealTech sound but cannot locate
where to check enhancements. I looked in Sound Link oin Control Panel but couldn't find anything for enhancements. Can someone direct me?

Press Windows, and type:
sound
The first thing should be sound in settings. Press enter on that.

You should then find that your primary output device is selected automatically from the dropdown provided. If not, select it.
Then tab once to "Device properties" and press enter.
Next you tab (I believe) seven times, to "Additional device properties", and press enter.
Press shift tab, which takes you to the tabs of the properties window, and move right to "Advanced".

Tab from there until you find the enhancements checkbox, if you have one, and uncheck it. It should be right after "exclusive mode". Then hit apply or OK, and the rest is just getting back out.

There are more straight forward ways of getting to those settings right now, but that's the one I used tonight, so it's most fresh in my mind.

Hth.

Luke




 

You may have to click about in a visual audio control panel.

I used ocr to get me to listening tab, then moved the mouse round to audio enhancements which I clicked then there is another audio enhancements button to click and it will turn off.

The issue with audio enhancements isn't the enhancements its that speech is to short of a sample of sound to get full effect of the enhancement.

These are used to well make the computers sound good because speakers in them suck.

In my aunt's entry level laptop, not only do I need to have enhancements on, I need the volume on max.

Without enhancements the audio through the speakers suck for internals at any rate.

On my workstation, running with a say ms driver has the sound to overdriven so it needs enhancements and also needs drivers to switch out to headphones else you will get sounds doing weird thhings with limiters etc even when most of them are switched off.

I do have a powerfull amp and 2 wat speakers so it does work better with enhancements off.

Of course when out you can use headphones when at home you can use speakers.

If those really get you that brassed you can buy a cheap soundcard from atguys, recording with that results in a bit of bus noise from the microphone bleedthrough but its quite slight.



On 29/12/2019 7:39 pm, Jeff Samco wrote:
Thank you, Luke.   Your instructions got me to the same place I had found on my own. But, I don't find an enhancements checkbox or anything similar. After  Exclusive mode is just a Restore Defaults.  This has me stumped.
I am working with my default sound device which is RealTech speakers.
Any other words of advice?
Jeff

At 10:06 PM 12/28/2019, you wrote:
On Sat, 28 Dec 2019, Jeff Samco wrote:

I had  similar behavior for me start up about 3 weeks ago. I use current NVDA public release on a Windows 10 laptop. I have RealTech sound but cannot locate
where to check enhancements. I looked in Sound Link oin Control Panel but couldn't find anything for enhancements. Can someone direct me?

Press Windows, and type:
sound
The first thing should be sound in settings. Press enter on that.

You should then find that your primary output device is selected automatically from the dropdown provided. If not, select it.
Then tab once to "Device properties" and press enter.
Next you tab (I believe) seven times, to "Additional device properties", and press enter.
Press shift tab, which takes you to the tabs of the properties window, and move right to "Advanced".

Tab from there until you find the enhancements checkbox, if you have one, and uncheck it. It should be right after "exclusive mode". Then hit apply or OK, and the rest is just getting back out.

There are more straight forward ways of getting to those settings right now, but that's the one I used tonight, so it's most fresh in my mind.

Hth.

Luke




Ralf Kefferpuetz
 

Please go there the following way:

  1. Open your start menu and enter sounds
  2. Select Change system sounds, Control panel
  3. You are in a window with several tabs, go 2 tabs to the left. Press 2 times control-shift-tab. You hear playback devices
  4. In the list of all your playback devices now select the realtek speakers
  5. Right click and select properties
  6. A window with several tabs openens: General tab – Levels tab – Enhancements tab.
  7. Go to the enhancements tab and check the checkbox saying: Disable all sound effects
  8. Press enter and you’re done
  9.  

    Good luck,

      Ralf

     

    Sent: Sonntag, 29. Dezember 2019 07:39
    To: nvda@nvda.groups.io
    Subject: Re: [nvda] NVDA Buzzing and Speaking in a Compressed Way During Keyboard Input on a Fast Laptop

 

Thank you, Luke.   Your instructions got me to the same place I had found on my own. But, I don't find an enhancements checkbox or anything similar. After  Exclusive mode is just a Restore Defaults.  This has me stumped.
I am working with my default sound device which is RealTech speakers.
Any other words of advice?
Jeff


At 10:06 PM 12/28/2019, you wrote:

On Sat, 28 Dec 2019, Jeff Samco wrote:


I had  similar behavior for me start up about 3 weeks ago. I use current NVDA public release on a Windows 10 laptop. I have RealTech sound but cannot locate
where to check enhancements. I looked in Sound Link oin Control Panel but couldn't find anything for enhancements. Can someone direct me?


Press Windows, and type:
sound
The first thing should be sound in settings. Press enter on that.

You should then find that your primary output device is selected automatically from the dropdown provided. If not, select it.
Then tab once to "Device properties" and press enter.
Next you tab (I believe) seven times, to "Additional device properties", and press enter.
Press shift tab, which takes you to the tabs of the properties window, and move right to "Advanced".

Tab from there until you find the enhancements checkbox, if you have one, and uncheck it. It should be right after "exclusive mode". Then hit apply or OK, and the rest is just getting back out.

There are more straight forward ways of getting to those settings right now, but that's the one I used tonight, so it's most fresh in my mind.

Hth.

Luke



hurrikennyandopo ...
 

Hi


Just wrote up a quick tutorial this was done for a windows 10 machine 1809 the steps which I will tidy up later on and paste on my website under trouble shooting.

I think when you get to the sound enhancements tab you will need to tab once or a couple of times it depends what nvda is focused on

or arrow through the listthen tab to hear the check box.

I had the box unchecked and also checked to see what it done and what you hear.



disable sound enhancements in Windows when you hear wierd noises

some times when there is a update for Windows etc you may hear a buzzing sound and other strange noises from the computer when using NVDA.

If this is the case you will need to turn off sound enhancements in Windows for your sound card. The steps to turn it off may be simular for other Windows 10 computers or earlier versions  of Windows.

Press the Windows key and in the search box type sound settings. when it comes up with this result, press the enter key.
The first option might say Choose your output device Speakers (High Definition Audio Device. next tab once to device properties then press the enter key. The next screen that comes up will say home. If you tab about 7 times you will then hear NVDA say Additional device properties then press the enter key.

The next screen should come up with  say speaker properties Shift tab back once or twice until you hear NVDA say General. there are 5 tabs there use your right arrow key to get to  the enhancements tab then tab a couple of times until you hear NVDA says Disable all enhancements. Please note after you tab once after the enhancement tab you might need to arrow down or tab to locate this disable all enhancements checkbox. You will hear other stuff for the sound card been spoken out  but they can be left unchecked.
You will need to tab to hear the disable enhancements check box if you arrowed down the list of enhancements.

 and check the check box with the space bar. You will then need to apply and ok your changes with the space bar.

Now those weird buzzing sounds etc should be gone.

 



On 29/12/2019 7:39 pm, Jeff Samco wrote:
Thank you, Luke.   Your instructions got me to the same place I had found on my own. But, I don't find an enhancements checkbox or anything similar. After  Exclusive mode is just a Restore Defaults.  This has me stumped.
I am working with my default sound device which is RealTech speakers.
Any other words of advice?
Jeff

At 10:06 PM 12/28/2019, you wrote:
On Sat, 28 Dec 2019, Jeff Samco wrote:

I had  similar behavior for me start up about 3 weeks ago. I use current NVDA public release on a Windows 10 laptop. I have RealTech sound but cannot locate
where to check enhancements. I looked in Sound Link oin Control Panel but couldn't find anything for enhancements. Can someone direct me?

Press Windows, and type:
sound
The first thing should be sound in settings. Press enter on that.

You should then find that your primary output device is selected automatically from the dropdown provided. If not, select it.
Then tab once to "Device properties" and press enter.
Next you tab (I believe) seven times, to "Additional device properties", and press enter.
Press shift tab, which takes you to the tabs of the properties window, and move right to "Advanced".

Tab from there until you find the enhancements checkbox, if you have one, and uncheck it. It should be right after "exclusive mode". Then hit apply or OK, and the rest is just getting back out.

There are more straight forward ways of getting to those settings right now, but that's the one I used tonight, so it's most fresh in my mind.

Hth.

Luke